summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/rosdistro/Manifest1
-rw-r--r--dev-python/rosdistro/rosdistro-0.5.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/rosdistro/Manifest b/dev-python/rosdistro/Manifest
index 7df74b5250a3..a75247169d03 100644
--- a/dev-python/rosdistro/Manifest
+++ b/dev-python/rosdistro/Manifest
@@ -1 +1,2 @@
DIST rosdistro-0.4.7.tar.gz 42265 SHA256 7b98e5c82ce81bd8080f159a7c907bca8bf77f6cb4bae8a3265f44e3d73b838f SHA512 adc841b19ad247f44d52cb819851715c94a73fc99ac175c0ee5656f69b86f7630a84259a9c96fa20a687ad32fa9e8e9f77802ae7b70700e53c87ee938bac2cac WHIRLPOOL 85d36fae44f895176a2ef151129baa86a9eef53700496dda2129d74d40fe67f0dbd4109df0ac7c534db1b3c712eafa73bcf3deabdd3f2dda3b5777d96a70ea69
+DIST rosdistro-0.5.0.tar.gz 48017 SHA256 dbf98013051b8ebd0e940828bb4a66c0d6fc1ec3ef36467f44636ee86d0422bf SHA512 e5a64442c56c7b60d1f334e42896172ccd07b87fbf9b5f877528073069ce63939482a5257e5dab8c16be633c044a744419017953b5dec4d9664221cf841776a8 WHIRLPOOL 4a5165340c9bcc8c46f72e70998886ec43c94a15b5c62a6a0af0c030166e369ab769fda03819b084384615cf3ad2d43f89961c73ad8ac9b835e687880b2b0a48
diff --git a/dev-python/rosdistro/rosdistro-0.5.0.ebuild b/dev-python/rosdistro/rosdistro-0.5.0.ebuild
new file mode 100644
index 000000000000..8e2e799d5e49
--- /dev/null
+++ b/dev-python/rosdistro/rosdistro-0.5.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/ros-infrastructure/rosdistro"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Tools to work with catkinized rosdistro files"
+HOMEPAGE="http://wiki.ros.org/rosdistro"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz
+ https://github.com/ros-infrastructure/rosdistro/archive/${PV}.tar.gz -> ${P}.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/catkin_pkg[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ nosetests --with-xunit test || die
+}