summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-libs/ntirpc/Manifest1
-rw-r--r--net-libs/ntirpc/ntirpc-4.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/net-libs/ntirpc/Manifest b/net-libs/ntirpc/Manifest
index a777910ea00d..96ba317c4d81 100644
--- a/net-libs/ntirpc/Manifest
+++ b/net-libs/ntirpc/Manifest
@@ -1 +1,2 @@
DIST ntirpc-3.4.tar.gz 387376 BLAKE2B db4d0fd22f1ea46da6e40a613848f9fd396bd85cf01968f5ab976627ab787e8d1bc2a57a8bb87f2ffcaf63b8e59c6ea41145ed9ccafc66d4ba420a15c9a78901 SHA512 913bc9f3208ddb667a7fab6e06585ba15ac3dd1979a15846f49114f54a270c2174a00afc3009d6158851aed779046743dd1ea704227122079164c07b394c01ad
+DIST ntirpc-4.0.tar.gz 388389 BLAKE2B b997430a119c900cfd8792af530d7baec629d7afa076838ca22b83631a461df2f267c6b786582bbefc98db870d054f37c9e9c0c3201f9a130f3f3806168043c1 SHA512 7bafad650bcebbf53a9958abdcacb8dfa9ac46c9798ac39e82c2ae3215b3e5b5a6b916bb95e3c70e7bc1a09b26a46b00bad236b2400538e9695b1c347f0672d9
diff --git a/net-libs/ntirpc/ntirpc-4.0.ebuild b/net-libs/ntirpc/ntirpc-4.0.ebuild
new file mode 100644
index 000000000000..8688e4cc9382
--- /dev/null
+++ b/net-libs/ntirpc/ntirpc-4.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Transport Independent RPC library for nfs-ganesha"
+HOMEPAGE="https://github.com/nfs-ganesha/ntirpc"
+SRC_URI="https://github.com/nfs-ganesha/ntirpc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gssapi rdma"
+
+# Since the GSS option only controls some extra files to be enabled,
+# there's nothing to list in the depend string for it.
+RDEPEND="
+ dev-libs/userspace-rcu
+ rdma? ( sys-fabric/librdmacm )
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_GSS="$(usex gssapi)"
+ -DUSE_RPC_RDMA="$(usex rdma)"
+ )
+ cmake_src_configure
+}