summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xapp-crypt/jitterentropy-rngd/files/jitterentropy-rngd-initd17
-rw-r--r--app-crypt/jitterentropy-rngd/jitterentropy-rngd-1.1.0.ebuild2
2 files changed, 19 insertions, 0 deletions
diff --git a/app-crypt/jitterentropy-rngd/files/jitterentropy-rngd-initd b/app-crypt/jitterentropy-rngd/files/jitterentropy-rngd-initd
new file mode 100755
index 000000000000..1a7fb84723bf
--- /dev/null
+++ b/app-crypt/jitterentropy-rngd/files/jitterentropy-rngd-initd
@@ -0,0 +1,17 @@
+#!/sbin/openrc-run
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+name="jitterentropy daemon"
+command="/usr/sbin/jitterentropy-rngd"
+pidfile="/run/jitterentropy-rngd.pid"
+command_args="--pid ${pidfile}"
+
+depend() {
+ need localmount
+ before net
+ use logger
+
+ provide entropy
+}
+
diff --git a/app-crypt/jitterentropy-rngd/jitterentropy-rngd-1.1.0.ebuild b/app-crypt/jitterentropy-rngd/jitterentropy-rngd-1.1.0.ebuild
index bd3a671e48d4..a0f57561d71c 100644
--- a/app-crypt/jitterentropy-rngd/jitterentropy-rngd-1.1.0.ebuild
+++ b/app-crypt/jitterentropy-rngd/jitterentropy-rngd-1.1.0.ebuild
@@ -21,4 +21,6 @@ PATCHES=(
src_install() {
emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" \
UNITDIR="$(systemd_get_systemunitdir)" install
+ newinitd "${FILESDIR}"/jitterentropy-rngd-initd jitterentropy-rngd
}
+