summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--kde-apps/kopete/Manifest1
-rw-r--r--kde-apps/kopete/kopete-22.12.1.ebuild169
2 files changed, 170 insertions, 0 deletions
diff --git a/kde-apps/kopete/Manifest b/kde-apps/kopete/Manifest
index 799348e8289c..a09d8474dfe1 100644
--- a/kde-apps/kopete/Manifest
+++ b/kde-apps/kopete/Manifest
@@ -1,2 +1,3 @@
DIST kopete-22.08.3.tar.xz 9668280 BLAKE2B f844bbd82e196507c16c568c32994b5d06077075f53a5d2fb99e74f2bcd972eb6350bdb38f597a937fdb6040bd7c232689bf2eef1b903dbccb919f3ed3b63cf6 SHA512 91e9a0e76e5b633e7e0454e7eba6fd163a912ad72675f3a2e049aba1f7cd306e54383894e783d417dde3961e91ec9b96f5b55772b4f29cd9c107acc185ef346c
DIST kopete-22.12.0.tar.xz 10274728 BLAKE2B 46bc0698a2cdb847eb2b7244079974bfaf7c5864e86a058c247f01f6702aa71235c149a8f0d24ac13f7ffb2f2eb39d9a8268f3f95894630ae548e6d1d15d591d SHA512 f53bfbf88ede9106c50f496569df8a3e59778770a04cb76ce93a627a2518486e43e7f439ec3b7590b251a2a13bd2f6ae536649abb2992e9455cdca7e9d4a5470
+DIST kopete-22.12.1.tar.xz 10274240 BLAKE2B 770453bccc848252ee36c5da6a6fa03a4429e579556c3e45bacbafcb6a16faba3ee9eebfd639832b8d33c4f421ed0a3430814b3836fe45cb1ce8e3db99778339 SHA512 07ffebd765b75c3c9eb0ea7e4899ebad33ac34d601dc9b6642cb0df6505982f7ad6e20dede4ec7422b2d0f9a61ab32dbb78e46bcf23e3a6b5ad3249b63784a57
diff --git a/kde-apps/kopete/kopete-22.12.1.ebuild b/kde-apps/kopete/kopete-22.12.1.ebuild
new file mode 100644
index 000000000000..63ac3c827021
--- /dev/null
+++ b/kde-apps/kopete/kopete-22.12.1.ebuild
@@ -0,0 +1,169 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="forceoptional"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.101.0
+QTMIN=5.15.5
+inherit ecm gear.kde.org
+
+DESCRIPTION="Multi-protocol IM client based on KDE Frameworks"
+HOMEPAGE="https://apps.kde.org/kopete/"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="ssl v4l"
+
+# Available plugins
+# addbookmarks: NO DEPS
+# alias: NO DEPS (disabled upstream)
+# autoreplace: NO DEPS
+# contactnotes: NO DEPS
+# cryptography: BROKEN (app-crypt/gpgme[cxx,qt5], kde-apps/libkleo:5)
+# highlight: NO DEPS
+# history: NO DEPS
+# latex: virtual/latex as RDEPEND
+# nowlistening: NO DEPS
+# otr: libotr
+# pipes: NO DEPS
+# privacy: NO DEPS
+# statistics: dev-db/sqlite:3
+# texteffect: NO DEPS
+# translator: NO DEPS
+# urlpicpreview: NO DEPS
+# webpresence: libxml2 libxslt
+# NOTE: By default we enable all plugins that don't have any dependencies
+PLUGINS="+addbookmarks +autoreplace +contactnotes +highlight history latex nowlistening
+otr pipes +privacy +statistics +texteffect translator +urlpicpreview webpresence"
+
+# Available protocols
+# gadu: net-libs/libgadu @since 4.3
+# groupwise: app-crypt/qca:2
+# irc: NO DEPS, probably will fail so inform user about it
+# xmpp: net-dns/libidn app-crypt/qca:2 ENABLED BY DEFAULT NETWORK
+# meanwhile: net-libs/meanwhile
+# oscar: NO DEPS
+# telepathy: net-libs/decibel
+# testbed: NO DEPS
+# winpopup: NO DEPS (we're adding samba as RDEPEND so it works)
+# zeroconf (bonjour): NO DEPS
+PROTOCOLS="gadu groupwise meanwhile oscar testbed winpopup +xmpp zeroconf"
+
+# disabled protocols
+# irc: NO DEPS
+# jingle: media-libs/speex net-libs/ortp DISABLED BY UPSTREAM
+# qq: NO DEPS
+# telepathy: net-libs/decibel
+# skype, sms (until fixed)
+
+IUSE="${IUSE} ${PLUGINS} ${PROTOCOLS}"
+
+COMMON_DEPEND="
+ app-crypt/gpgme:=[cxx,qt5]
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtsql-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ >=kde-apps/kidentitymanagement-${PVCUT}:5
+ >=kde-apps/libkleo-${PVCUT}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcontacts-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kcrash-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/kdelibs4support-${KFMIN}:5
+ >=kde-frameworks/kemoticons-${KFMIN}:5
+ >=kde-frameworks/khtml-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/knotifyconfig-${KFMIN}:5
+ >=kde-frameworks/kparts-${KFMIN}:5
+ >=kde-frameworks/ktexteditor-${KFMIN}:5
+ >=media-libs/phonon-4.11.0
+ x11-libs/libX11
+ x11-libs/libXScrnSaver
+ gadu? ( >=net-libs/libgadu-1.8.0[threads] )
+ groupwise? ( >=app-crypt/qca-2.3.0:2[qt5(+)] )
+ meanwhile? ( net-libs/meanwhile )
+ otr? ( >=net-libs/libotr-4.0.0 )
+ statistics? ( dev-db/sqlite:3 )
+ v4l? ( media-libs/libv4l )
+ webpresence? (
+ dev-libs/libxml2
+ dev-libs/libxslt
+ )
+ xmpp? (
+ >=app-crypt/qca-2.3.0:2[qt5(+)]
+ net-dns/libidn:0=
+ sys-libs/zlib
+ )
+ zeroconf? (
+ >=kde-apps/kidentitymanagement-${PVCUT}:5
+ >=kde-frameworks/kdnssd-${KFMIN}:5
+ )
+"
+# jingle? (
+# dev-libs/expat
+# dev-libs/openssl:0=
+# >=media-libs/mediastreamer-2.3.0
+# media-libs/speex
+# net-libs/libsrtp:0=
+# net-libs/ortp:=
+# )
+RDEPEND="${COMMON_DEPEND}
+ latex? (
+ || (
+ media-gfx/imagemagick
+ media-gfx/graphicsmagick[imagemagick]
+ )
+ virtual/latex-base
+ )
+ ssl? ( >=app-crypt/qca-2.3.0:2[qt5(+),ssl] )
+ xmpp? ( >=app-crypt/qca-2.3.0:2[qt5(+),ssl?] )
+"
+# sms? ( app-mobilephone/smssend )
+# winpopup? ( net-fs/samba )
+DEPEND="${COMMON_DEPEND}
+ x11-base/xorg-proto
+"
+# jingle? ( dev-libs/jsoncpp )
+
+# tests hang, last checked for 4.2.96
+RESTRICT="test"
+
+src_configure() {
+ local x x2
+ # Handle common stuff
+ local mycmakeargs=(
+ -DWITH_qq=OFF
+ -DDISABLE_VIDEOSUPPORT=$(usex !v4l)
+ )
+# $(cmake_use_find_package jingle LiboRTP)
+# $(cmake_use_find_package jingle Mediastreamer)
+# $(cmake_use_find_package jingle Speex)
+
+ # enable protocols
+ for x in ${PROTOCOLS}; do
+ case ${x/+/} in
+ jingle) x2=libjingle ;;
+ xmpp) x2=jabber ;;
+ zeroconf) x2=bonjour ;;
+ *) x2=${x/+/} ;;
+ esac
+ mycmakeargs+=( -DWITH_${x2}=$(usex ${x/+/}) )
+ done
+
+ # disable until fixed:
+ mycmakeargs+=( -DWITH_{cryptography,libjingle,skype,sms}=OFF )
+
+ # enable plugins
+ for x in ${PLUGINS}; do
+ mycmakeargs+=( -DWITH_${x/+/}=$(usex ${x/+/}) )
+ done
+
+ ecm_src_configure
+}