summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/django-compressor/Manifest1
-rw-r--r--dev-python/django-compressor/django-compressor-2.4.1.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/django-compressor/Manifest b/dev-python/django-compressor/Manifest
index 8389ec945918..b09f7e776910 100644
--- a/dev-python/django-compressor/Manifest
+++ b/dev-python/django-compressor/Manifest
@@ -1 +1,2 @@
+DIST django_compressor-2.4.1.tar.gz 123800 BLAKE2B 455938c328c787e6ca48b3c413f005f9ba3cfc186587b821afb804c0de6259702060d4493e34f240bd721e547ce496a1b0de7a478eb8c9b7ac8e4ba49be755fa SHA512 d59fc8b97f9f87b26e53a9822a9b467df77449cc480a7145d7fedf020a85516dee6f3bc04519fc2e2b751134fb10ce4ddbd4ffe394b5817b973db8d90b9ccda7
DIST django_compressor-2.4.tar.gz 111853 BLAKE2B ace3796d85d654c1c22b51cdd1331e28e735659be6c724a29c722fb9aa5cf0ebeb737a3f5c43abe1f057a015689f39ff5f8ca5a28141cb7369c5ec9edb7447a1 SHA512 b4dd43ab4ad13872138c9b9be3012e2675db2131b384350c5aa13ac7859b1aa93760cc3b9c91393f51bac404eb66ae04f35b187e0b0ebacf5f0da457dd42e727
diff --git a/dev-python/django-compressor/django-compressor-2.4.1.ebuild b/dev-python/django-compressor/django-compressor-2.4.1.ebuild
new file mode 100644
index 000000000000..1d529ff01535
--- /dev/null
+++ b/dev-python/django-compressor/django-compressor-2.4.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Compresses linked and inline JavaScript or CSS into single cached files."
+HOMEPAGE="https://django-compressor.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN/-/_}/${P/-/_}.tar.gz"
+S="${WORKDIR}/${P/-/_}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+# missing test deps, package does not handle them gracefully, also seem
+# broken or whatever
+RESTRICT="test"
+
+RDEPEND="dev-python/django-appconf[${PYTHON_USEDEP}]
+ dev-python/rcssmin[${PYTHON_USEDEP}]
+ dev-python/rjsmin[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+
+python_test() {
+ django-admin.py test --settings=compressor.test_settings compressor ||
+ die "Tests failed with ${EPYTHON}"
+}