summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/sphinxcontrib-applehelp/Manifest1
-rw-r--r--dev-python/sphinxcontrib-applehelp/sphinxcontrib-applehelp-1.0.6.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-applehelp/Manifest b/dev-python/sphinxcontrib-applehelp/Manifest
index 40247e2182ba..9b15298cbb0a 100644
--- a/dev-python/sphinxcontrib-applehelp/Manifest
+++ b/dev-python/sphinxcontrib-applehelp/Manifest
@@ -1 +1,2 @@
DIST sphinxcontrib-applehelp-1.0.4.gh.tar.gz 20710 BLAKE2B 9aa6af5b263e6d9603fb01c5ab659bf0cc117341a2c0a6b2946cbd6cdaff0274d17d833d7703711c52e65e8363175e129e452a151fbaab186b8361809bb1a72d SHA512 f281748468a9f5d9a8b71213632d55850b8642b79f33e1e0fb3c6825b0f9b392e0b17b879a8ed0d44d5bea3f076e16f01285d9f41b587af3cf194985e61e92c6
+DIST sphinxcontrib_applehelp-1.0.6.tar.gz 19492 BLAKE2B a610774d461110704388149e0b2e1978e5d53a263df6448ee2e492ba177a5368a683823d4a512cba3dda935fc12dce7eb911fb898ac7bd053ae04b9efa4c7445 SHA512 99ae58fc3bf968437b3d742dbeadf802a4b9fbfd493c0428e05dc7cfd4ed1beeec9a2ddcf759b6af47a8b865f6a322fcc0986e705464bc2c92b24708aa58a217
diff --git a/dev-python/sphinxcontrib-applehelp/sphinxcontrib-applehelp-1.0.6.ebuild b/dev-python/sphinxcontrib-applehelp/sphinxcontrib-applehelp-1.0.6.ebuild
new file mode 100644
index 000000000000..329fddf5ebca
--- /dev/null
+++ b/dev-python/sphinxcontrib-applehelp/sphinxcontrib-applehelp-1.0.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx extension which outputs Apple help book"
+HOMEPAGE="
+ https://www.sphinx-doc.org/
+ https://github.com/sphinx-doc/sphinxcontrib-applehelp/
+ https://pypi.org/project/sphinxcontrib-applehelp/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+PDEPEND="
+ >=dev-python/sphinx-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? ( ${PDEPEND} )
+"
+
+distutils_enable_tests pytest