summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/fastimport/Manifest1
-rw-r--r--dev-python/fastimport/fastimport-0.9.9.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/fastimport/Manifest b/dev-python/fastimport/Manifest
index ec268fd1126c..534030885de1 100644
--- a/dev-python/fastimport/Manifest
+++ b/dev-python/fastimport/Manifest
@@ -1 +1,2 @@
DIST fastimport-0.9.8.tar.gz 39512 BLAKE2B 484ba865e749cca33df73417285e51a9117e7c905ab2922588d6eef9a64ea6b3d72de285a2affbe7d4a770ead9ece30f6242777087af1c469d59c8f2a4e1b008 SHA512 5d195b641cf6138fdbc6c75781a4a6d3699e3ada9743bbe4c4264879b2da2f8a2e995e7cc3955a5241e9c7a7f24f8114474a0a30907f86e2e335e2be4669f588
+DIST fastimport-0.9.9.tar.gz 41690 BLAKE2B c07774916d42a6ad98fea3fa8185bd6fd4e2b908d7eb90ec28a2d7dbe5fd806a97075ba0bb5e6dc4fa3330c9e1e46db125daa11062dba52cc9ebc4486c0fff12 SHA512 15005da2056e0d489f9317138833131ae2067cc5b4acd1ab8e82142c6a71e7cc600c3d5a2cbfc151ca253ba3f6aa5f0328fb45dfa912987bb28d4762248298b8
diff --git a/dev-python/fastimport/fastimport-0.9.9.ebuild b/dev-python/fastimport/fastimport-0.9.9.ebuild
new file mode 100644
index 000000000000..a000b6debba9
--- /dev/null
+++ b/dev-python/fastimport/fastimport-0.9.9.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for parsing the fastimport VCS serialization format"
+HOMEPAGE="https://github.com/jelmer/python-fastimport"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+python_test() {
+ "${EPYTHON}" -m unittest -v fastimport.tests.test_suite ||
+ die "Tests fail with ${EPYTHON}"
+}