summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/urllib3/Manifest3
-rw-r--r--dev-python/urllib3/urllib3-1.26.16.ebuild76
-rw-r--r--dev-python/urllib3/urllib3-2.0.4.ebuild83
-rw-r--r--dev-python/urllib3/urllib3-2.0.5.ebuild87
4 files changed, 0 insertions, 249 deletions
diff --git a/dev-python/urllib3/Manifest b/dev-python/urllib3/Manifest
index 951612e28ea6..d618c2a37e71 100644
--- a/dev-python/urllib3/Manifest
+++ b/dev-python/urllib3/Manifest
@@ -1,7 +1,4 @@
-DIST urllib3-1.26.16.tar.gz 303733 BLAKE2B 94c0cfb8696b15ff7aed25927ba584d0d67b150953586ca4d74ddc8f1d0a95ca447a482cf7d0f95728fad1e7e51a610e29c3e342ebe68e65a86789308544ea51 SHA512 caa58af5bf49644459a9074be659511b56c5d66802153c72ba2ba2eb9c0aafd56b4cd8f8588964ee7d2a9b16a5e114d62298ab1e128710260ed86f1e315b5571
DIST urllib3-1.26.17.tar.gz 305031 BLAKE2B 616b183168a78737988428efa52516586b66cab067d6a257af544c67922156e1e769fbbdd65c8f1ba606f02faa5918e4bafe8c1b27105b8e3f5fe644260d093d SHA512 f26c54def8564981f241a94c915c660d26a52d5437a1e1f4b8ebb6d6cd9de834a31b5816306c2cf2cadc2af00a1633bee97c8bbefa5a45b8e732f7566b4c0327
DIST urllib3-1.26.18.tar.gz 305687 BLAKE2B f2f673761a8d80eee715a8726ba36ab6b09800fd4a4f03f27438553c36072e2abb5ff26cff71dcf30fd114f4d28c4ad9907533965b83c8a0581d3d4661904b70 SHA512 c89e93a032bf6b11375c06ef7c5abc1868f93e7655cfdca09e9bd939ad415d206ea159fe151ecd2e5f725e0e18a831c7a5382ad01dbc32264154fc8af7aec156
-DIST urllib3-2.0.4.tar.gz 281517 BLAKE2B 58635787069b6d8e83394ddacca2c70824c03190efb4e0838b9b80d8e8c1499fa0143e1d38ece4e2a7f9b34d6b50f9805050bf85707d98eb171307ff35f8b215 SHA512 64d55714d871716730af5a691fc222722cffc13b0603ecae597e5f4cfd82297beede2b08cedc030b2419bd446f51c4c6e54f466ad96c71dd0848abbf806b4db4
-DIST urllib3-2.0.5.tar.gz 281697 BLAKE2B 7ae1cc90243cd2069767d4a3f7ca3b96d9e6270f38b363ba2c2cfddeb293cc75782740524bdf91d64bd08dcf1dc44cb9fe6ec2b501d34bdf4c69d893c794382a SHA512 dead3fcda9637c6142b577f051f25578249f7513d3d2bdf4ed880b7a063ff7ee2e946e72b91355328b12205600abc487252ca025f3946408093df46134d9fc12
DIST urllib3-2.0.6.tar.gz 281846 BLAKE2B 3af632a77f07d5c686e6412b06d67df5c62517239431ead7d0c7e7bbb5efe06c298db0afda1a84fb314f3e3936edd16aef693ac316a923f67232abf8789b6201 SHA512 872a5899ad4486b45fe7a327f029beb5f7d3dd8447b58b861922b32bd15f1cff68d12136f262c2d2d3740047976bc6cff16a54590c1eab19949149e7dae2956a
DIST urllib3-2.0.7.tar.gz 282546 BLAKE2B d4fbb9e1d0b6d1f3c3d71efc3fc479c7b1c49f87ca849c387701fb0c8b4124082de6d83d958c8b2afc225a84b80e7665df857e7b0918ba50e4ad1431f8facc4d SHA512 ca21dd330cfc7f53e6f00a92be1df1d24acbe61b6ca31c52a272dccd6f50d1bb797eece9132860adc84c21a9bebc3030a12816081451fcb8384c11a6cd2d1e8b
diff --git a/dev-python/urllib3/urllib3-1.26.16.ebuild b/dev-python/urllib3/urllib3-1.26.16.ebuild
deleted file mode 100644
index 5f91d38b5e3c..000000000000
--- a/dev-python/urllib3/urllib3-1.26.16.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_TESTED=( python3_{10..12} pypy3 )
-PYTHON_COMPAT=( "${PYTHON_TESTED[@]}" )
-PYTHON_REQ_USE="ssl(+)"
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="HTTP library with thread-safe connection pooling, file post, and more"
-HOMEPAGE="
- https://github.com/urllib3/urllib3/
- https://pypi.org/project/urllib3/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="brotli test"
-RESTRICT="!test? ( test )"
-
-# dev-python/{pyopenssl,cryptography,idna,certifi} are optional runtime
-# dependencies. Do not add them to RDEPEND. They should be unnecessary with
-# modern versions of python (>= 3.2).
-RDEPEND="
- >=dev-python/PySocks-1.5.8[${PYTHON_USEDEP}]
- <dev-python/PySocks-2.0[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- brotli? ( dev-python/brotlicffi[${PYTHON_USEDEP}] )
-"
-BDEPEND="
- test? (
- $(python_gen_cond_dep "
- ${RDEPEND}
- dev-python/brotlicffi[\${PYTHON_USEDEP}]
- dev-python/mock[\${PYTHON_USEDEP}]
- dev-python/pytest[\${PYTHON_USEDEP}]
- dev-python/pytest-freezegun[\${PYTHON_USEDEP}]
- >=dev-python/tornado-4.2.1[\${PYTHON_USEDEP}]
- >=dev-python/trustme-0.5.3[\${PYTHON_USEDEP}]
- " "${PYTHON_TESTED[@]}")
- )
-"
-
-src_prepare() {
- distutils-r1_src_prepare
-
- # unbundle urllib3
- rm src/urllib3/packages/six.py || die
- find -name '*.py' -exec sed -i \
- -e 's:\([.]*\|urllib3\.\)\?packages\.six:six:g' \
- -e 's:from \([.]*\|urllib3\.\)\?packages import six:import six:g' \
- {} + || die
-}
-
-python_test() {
- local -x CI=1
- if ! has "${EPYTHON}" "${PYTHON_TESTED[@]/_/.}"; then
- einfo "Skipping tests on ${EPYTHON}"
- return
- fi
-
- local EPYTEST_DESELECT=(
- # unstable (relies on warning count)
- test/with_dummyserver/test_proxy_poolmanager.py::TestHTTPProxyManager::test_proxy_verified_warning
- )
- has "${EPYTHON}" python3.{8..10} && EPYTEST_DESELECT+=(
- test/contrib/test_pyopenssl.py::TestPyOpenSSLHelpers::test_get_subj_alt_name
- )
-
- epytest
-}
diff --git a/dev-python/urllib3/urllib3-2.0.4.ebuild b/dev-python/urllib3/urllib3-2.0.4.ebuild
deleted file mode 100644
index 09c261bac12a..000000000000
--- a/dev-python/urllib3/urllib3-2.0.4.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_TESTED=( python3_{10..12} pypy3 )
-PYTHON_COMPAT=( "${PYTHON_TESTED[@]}" )
-PYTHON_REQ_USE="ssl(+)"
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="HTTP library with thread-safe connection pooling, file post, and more"
-HOMEPAGE="
- https://github.com/urllib3/urllib3/
- https://pypi.org/project/urllib3/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="brotli test zstd"
-RESTRICT="!test? ( test )"
-
-# [secure] extra is deprecated and slated for removal, we don't need it:
-# https://github.com/urllib3/urllib3/issues/2680
-RDEPEND="
- >=dev-python/PySocks-1.5.8[${PYTHON_USEDEP}]
- <dev-python/PySocks-2.0[${PYTHON_USEDEP}]
- brotli? ( >=dev-python/brotlicffi-0.8.0[${PYTHON_USEDEP}] )
- zstd? ( >=dev-python/zstandard-0.18.0[${PYTHON_USEDEP}] )
-"
-BDEPEND="
- test? (
- $(python_gen_cond_dep "
- ${RDEPEND}
- dev-python/brotlicffi[\${PYTHON_USEDEP}]
- dev-python/freezegun[\${PYTHON_USEDEP}]
- dev-python/pytest[\${PYTHON_USEDEP}]
- >=dev-python/tornado-4.2.1[\${PYTHON_USEDEP}]
- >=dev-python/trustme-0.5.3[\${PYTHON_USEDEP}]
- >=dev-python/zstandard-0.18.0[\${PYTHON_USEDEP}]
- " "${PYTHON_TESTED[@]}")
- )
-"
-
-src_prepare() {
- # upstream considers 0.5 s to be "long" for a timeout
- # we get tons of test failures on *fast* systems because of that
- sed -i -e '/LONG_TIMEOUT/s:0.5:5:' test/__init__.py || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- local -x CI=1
- if ! has "${EPYTHON}" "${PYTHON_TESTED[@]/_/.}"; then
- einfo "Skipping tests on ${EPYTHON}"
- return
- fi
-
- local EPYTEST_DESELECT=(
- # take forever
- test/contrib/test_pyopenssl.py::TestSocketSSL::test_requesting_large_resources_via_ssl
- test/with_dummyserver/test_socketlevel.py::TestSSL::test_requesting_large_resources_via_ssl
- # stupid test, next bump please verify if they fixed it
- test/test_poolmanager.py::TestPoolManager::test_deprecated_no_scheme
- # fails with newer secure SSL configuration, which removes TLS 1.1
- test/contrib/test_pyopenssl.py::TestHTTPS_TLSv1::test_verify_none_and_good_fingerprint
- test/contrib/test_pyopenssl.py::TestHTTPS_TLSv1_1::test_verify_none_and_good_fingerprint
- test/with_dummyserver/test_https.py::TestHTTPS_TLSv1::test_verify_none_and_good_fingerprint
- test/with_dummyserver/test_https.py::TestHTTPS_TLSv1_1::test_verify_none_and_good_fingerprint
- # TODO: timeouts
- test/contrib/test_pyopenssl.py::TestSocketClosing::test_timeout_errors_cause_retries
- test/with_dummyserver/test_socketlevel.py::TestSocketClosing::test_timeout_errors_cause_retries
- # warnings, sigh
- test/with_dummyserver/test_connectionpool.py::TestConnectionPool::test_request_chunked_is_deprecated
- )
-
- # plugins make tests slower, and more fragile
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
-}
diff --git a/dev-python/urllib3/urllib3-2.0.5.ebuild b/dev-python/urllib3/urllib3-2.0.5.ebuild
deleted file mode 100644
index 32852e31e793..000000000000
--- a/dev-python/urllib3/urllib3-2.0.5.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_TESTED=( python3_{10..12} pypy3 )
-PYTHON_COMPAT=( "${PYTHON_TESTED[@]}" )
-PYTHON_REQ_USE="ssl(+)"
-
-inherit distutils-r1 multiprocessing pypi
-
-DESCRIPTION="HTTP library with thread-safe connection pooling, file post, and more"
-HOMEPAGE="
- https://github.com/urllib3/urllib3/
- https://pypi.org/project/urllib3/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="brotli test zstd"
-RESTRICT="!test? ( test )"
-
-# [secure] extra is deprecated and slated for removal, we don't need it:
-# https://github.com/urllib3/urllib3/issues/2680
-RDEPEND="
- >=dev-python/PySocks-1.5.8[${PYTHON_USEDEP}]
- <dev-python/PySocks-2.0[${PYTHON_USEDEP}]
- brotli? ( >=dev-python/brotlicffi-0.8.0[${PYTHON_USEDEP}] )
- zstd? ( >=dev-python/zstandard-0.18.0[${PYTHON_USEDEP}] )
-"
-BDEPEND="
- test? (
- $(python_gen_cond_dep "
- ${RDEPEND}
- dev-python/brotlicffi[\${PYTHON_USEDEP}]
- dev-python/freezegun[\${PYTHON_USEDEP}]
- dev-python/pytest[\${PYTHON_USEDEP}]
- dev-python/pytest-rerunfailures[\${PYTHON_USEDEP}]
- dev-python/pytest-xdist[\${PYTHON_USEDEP}]
- >=dev-python/tornado-4.2.1[\${PYTHON_USEDEP}]
- >=dev-python/trustme-0.5.3[\${PYTHON_USEDEP}]
- >=dev-python/zstandard-0.18.0[\${PYTHON_USEDEP}]
- " "${PYTHON_TESTED[@]}")
- )
-"
-
-src_prepare() {
- # upstream considers 0.5 s to be "long" for a timeout
- # we get tons of test failures on *fast* systems because of that
- sed -i -e '/LONG_TIMEOUT/s:0.5:5:' test/__init__.py || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- local -x CI=1
- if ! has "${EPYTHON}" "${PYTHON_TESTED[@]/_/.}"; then
- einfo "Skipping tests on ${EPYTHON}"
- return
- fi
-
- local EPYTEST_DESELECT=(
- # take forever
- test/contrib/test_pyopenssl.py::TestSocketSSL::test_requesting_large_resources_via_ssl
- test/with_dummyserver/test_socketlevel.py::TestSSL::test_requesting_large_resources_via_ssl
- # stupid test, next bump please verify if they fixed it
- test/test_poolmanager.py::TestPoolManager::test_deprecated_no_scheme
- # fails with newer secure SSL configuration, which removes TLS 1.1
- test/contrib/test_pyopenssl.py::TestHTTPS_TLSv1::test_verify_none_and_good_fingerprint
- test/contrib/test_pyopenssl.py::TestHTTPS_TLSv1_1::test_verify_none_and_good_fingerprint
- test/with_dummyserver/test_https.py::TestHTTPS_TLSv1::test_verify_none_and_good_fingerprint
- test/with_dummyserver/test_https.py::TestHTTPS_TLSv1_1::test_verify_none_and_good_fingerprint
- # TODO: timeouts
- test/contrib/test_pyopenssl.py::TestSocketClosing::test_timeout_errors_cause_retries
- test/with_dummyserver/test_socketlevel.py::TestSocketClosing::test_timeout_errors_cause_retries
- # warnings, sigh
- test/with_dummyserver/test_connectionpool.py::TestConnectionPool::test_request_chunked_is_deprecated
- )
-
- # plugins make tests slower, and more fragile
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- # some tests are very fragile to timing
- epytest -p rerunfailures --reruns=10 --reruns-delay=2 \
- -p xdist -n "$(makeopts_jobs)" --dist=worksteal
-}