summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/ripgrep/Manifest1
-rw-r--r--sys-apps/ripgrep/ripgrep-0.2.6.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/sys-apps/ripgrep/Manifest b/sys-apps/ripgrep/Manifest
index 19845f5190d5..a3a166ec307b 100644
--- a/sys-apps/ripgrep/Manifest
+++ b/sys-apps/ripgrep/Manifest
@@ -1 +1,2 @@
DIST ripgrep-0.2.5.tar.xz 36327796 SHA256 af30c197e8ed4779288023b4b197ebd481f5c644be1ac18495c91556989da5f8 SHA512 4ce2374f677110bc61ac1ee0511a9e801f21f414ba3bf809b3020e82a2a26a7deeff45fea1edc8d20353023e95074899262db2f84e0cd822103dc60b55f39216 WHIRLPOOL e0a50bc59142aa74ecfc93c2089d6916aba6af15d33d9dbd9f7fa7c790b5fa9f46b757419c9db3abd4d17eba6d0e17c6b5a83ceb6842d8a7d57722ef1e6862ff
+DIST ripgrep-0.2.6.tar.xz 36034548 SHA256 1f26e3023a58f52085780f5392241d3781d51746ce1fa8abc155b99bd11eae1e SHA512 1389e97009a30c417f75e8a6804e53ba72c679b6e67366c83c839fe5bc4035cc59ab0261ada1110eda84e8aa9900fd12abc1732bf68b6fd379aee64fbfe7acc9 WHIRLPOOL 416b3eab0146872e86dd9184b17aa73ae4dba5016c7829d2daa845fe304aa2be31fc4505e08b8270ff7589872fcb07852bfbbb30a06c7c13d63abf2c17ae0c01
diff --git a/sys-apps/ripgrep/ripgrep-0.2.6.ebuild b/sys-apps/ripgrep/ripgrep-0.2.6.ebuild
new file mode 100644
index 000000000000..11fc9daa0f8e
--- /dev/null
+++ b/sys-apps/ripgrep/ripgrep-0.2.6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="a command line search tool that combines usability with raw speed"
+HOMEPAGE="https://github.com/BurntSushi/ripgrep"
+#SRC_URI="https://github.com/BurntSushi/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+# custom tarball bundling all deps and index, otherwise cargo fetches from the network
+SRC_URI="http://dev.gentoo.org/~radhermit/dist/${P}.tar.xz"
+
+LICENSE="|| ( MIT Unlicense )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-util/cargo"
+
+src_prepare() {
+ default
+
+ # move cache dir where cargo expects it
+ mv .cargo "${HOME}" || die
+}
+
+src_compile() {
+ cargo build --release --verbose || die
+}
+
+src_test() {
+ cargo test || die "tests failed"
+}
+
+src_install() {
+ dobin target/release/rg
+ doman doc/rg.1
+ dodoc CHANGELOG.md README.md
+}