summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-crypt/mdcrack/files/mdcrack-1.2-asneeded.patch4
-rw-r--r--app-crypt/mdcrack/files/mdcrack-1.2-remove-interactive-test.diff4
-rw-r--r--app-crypt/mdcrack/mdcrack-1.2.ebuild27
3 files changed, 21 insertions, 14 deletions
diff --git a/app-crypt/mdcrack/files/mdcrack-1.2-asneeded.patch b/app-crypt/mdcrack/files/mdcrack-1.2-asneeded.patch
index 3b5abe5967b1..6e9abcf81c30 100644
--- a/app-crypt/mdcrack/files/mdcrack-1.2-asneeded.patch
+++ b/app-crypt/mdcrack/files/mdcrack-1.2-asneeded.patch
@@ -1,5 +1,5 @@
---- Makefile.orig 2009-02-10 17:06:52.786706429 +0100
-+++ Makefile 2009-02-10 17:07:15.947791244 +0100
+--- a/Makefile 2009-02-10 17:06:52.786706429 +0100
++++ b/Makefile 2009-02-10 17:07:15.947791244 +0100
@@ -56,7 +56,7 @@
NCURSES=-DNCURSES
diff --git a/app-crypt/mdcrack/files/mdcrack-1.2-remove-interactive-test.diff b/app-crypt/mdcrack/files/mdcrack-1.2-remove-interactive-test.diff
index 5208bc4b3cae..ae8e9fcd4cb5 100644
--- a/app-crypt/mdcrack/files/mdcrack-1.2-remove-interactive-test.diff
+++ b/app-crypt/mdcrack/files/mdcrack-1.2-remove-interactive-test.diff
@@ -1,5 +1,5 @@
---- Makefile 2010-06-28 22:19:55.000000000 -0400
-+++ myMakefile 2010-06-28 22:20:03.000000000 -0400
+--- a/Makefile 2010-06-28 22:19:55.000000000 -0400
++++ b/Makefile 2010-06-28 22:20:03.000000000 -0400
@@ -47,7 +47,6 @@
BLOCK=-DBLOCKSIZE=50
diff --git a/app-crypt/mdcrack/mdcrack-1.2.ebuild b/app-crypt/mdcrack/mdcrack-1.2.ebuild
index 5dcc0c486b44..67c5a5eca652 100644
--- a/app-crypt/mdcrack/mdcrack-1.2.ebuild
+++ b/app-crypt/mdcrack/mdcrack-1.2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="2"
+EAPI="6"
inherit eutils toolchain-funcs
@@ -15,11 +15,18 @@ LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86"
IUSE="ncurses"
-src_prepare() {
- epatch "${FILESDIR}"/${P}-gcc4.diff \
- "${FILESDIR}"/${P}-asneeded.patch \
- "${FILESDIR}"/${P}-remove-interactive-test.diff
+DOCS=(
+ BENCHMARKS CREDITS FAQ README TODO VERSIONS WWW
+)
+
+PATCHES=(
+ "${FILESDIR}/${P}-gcc4.diff"
+ "${FILESDIR}/${P}-asneeded.patch"
+ "${FILESDIR}/${P}-remove-interactive-test.diff"
+)
+src_prepare() {
+ default
use ncurses || \
sed -i -e 's/^NCURSES/#NCURSES/g' \
-e 's/^LIBS/#LIBS/g' Makefile
@@ -29,13 +36,13 @@ src_prepare() {
}
src_compile() {
- emake CC="$(tc-getCC)" little || die "emake failed"
+ emake CC="$(tc-getCC)" little
}
src_test() {
local failure=false
- make CC="$(tc-getCC)" fulltest || die "self test failed"
+ emake CC="$(tc-getCC)" fulltest
for i in {1..20}; do
if grep "Collision found" out$i ; then
@@ -52,6 +59,6 @@ src_test() {
}
src_install() {
- dobin bin/mdcrack || die "dobin failed"
- dodoc BENCHMARKS CREDITS FAQ README TODO VERSIONS WWW || die
+ einstalldocs
+ dobin bin/mdcrack
}