summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-libs/libxcb/Manifest1
-rw-r--r--x11-libs/libxcb/libxcb-1.15-r1.ebuild55
2 files changed, 0 insertions, 56 deletions
diff --git a/x11-libs/libxcb/Manifest b/x11-libs/libxcb/Manifest
index b23695117198..6529081dae94 100644
--- a/x11-libs/libxcb/Manifest
+++ b/x11-libs/libxcb/Manifest
@@ -1,2 +1 @@
-DIST libxcb-1.15.tar.xz 446492 BLAKE2B d50146ee9b822dfd0c24513110e1706cda05ce588f276005167a911d3097275f36be1ce755c42c2b2970e750f10b2b943f3e373b6e55865fba986e29811a3545 SHA512 f6c7d766b7cf9cab6abe948ee424cbae6951dbfe2f76fa58a109cdc05b0f0919dcc4e38176a22ff4b95fc1e38596115317e32ba33b24cae0035a4e30dbcbdad9
DIST libxcb-1.16.tar.xz 452964 BLAKE2B 1ddd5c2e6be8400a0a77db4b5fbd4698996fd1a00984e370b1f712f6b9ce456c8ccfb6992f2973f5eaf8d5b6b75f39b9f51a1458c2432ddb41edd8199b91b3f9 SHA512 002fbc126c6f09eb7db5e4197cd0572d495f64b6de714a76d9a024fe3e13122c1cfc7c55207c0dee76cc63fcccf87b37db513223eadaf760af2bd2a926443bf8
diff --git a/x11-libs/libxcb/libxcb-1.15-r1.ebuild b/x11-libs/libxcb/libxcb-1.15-r1.ebuild
deleted file mode 100644
index 5ddaeaf03b94..000000000000
--- a/x11-libs/libxcb/libxcb-1.15-r1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{9..12} )
-PYTHON_REQ_USE="xml(+)"
-
-XORG_TARBALL_SUFFIX="xz"
-XORG_MULTILIB=yes
-XORG_DOC=doc
-
-inherit python-any-r1 xorg-3
-
-DESCRIPTION="X C-language Bindings library"
-HOMEPAGE="https://xcb.freedesktop.org/ https://gitlab.freedesktop.org/xorg/lib/libxcb"
-
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="doc selinux test +xkb"
-RESTRICT="!test? ( test )"
-SLOT="0/1.12"
-
-RDEPEND="
- >=x11-libs/libXau-1.0.7-r1[${MULTILIB_USEDEP}]
- >=x11-libs/libXdmcp-1.1.1-r1[${MULTILIB_USEDEP}]
-"
-DEPEND="${RDEPEND}
- x11-base/xorg-proto
- >=x11-base/xcb-proto-1.15.2
- elibc_Darwin? ( dev-libs/libpthread-stubs )
- test? ( dev-libs/check[${MULTILIB_USEDEP}] )
-"
-# Note: ${PYTHON_USEDEP} needs to go verbatim
-BDEPEND="${PYTHON_DEPS}
- $(python_gen_any_dep '>=x11-base/xcb-proto-1.15[${PYTHON_USEDEP}]')
- doc? ( app-doc/doxygen[dot] )
- test? ( dev-libs/libxslt )
-"
-
-python_check_deps() {
- python_has_version ">=x11-base/xcb-proto-1.15[${PYTHON_USEDEP}]"
-}
-
-pkg_setup() {
- python-any-r1_pkg_setup
- xorg-3_pkg_setup
-}
-
-src_configure() {
- local XORG_CONFIGURE_OPTIONS=(
- $(use_enable doc devel-docs)
- $(use_enable selinux)
- )
- xorg-3_src_configure
-}