summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-misc/ddcutil/Manifest2
-rw-r--r--app-misc/ddcutil/ddcutil-0.8.4.ebuild104
-rw-r--r--app-misc/ddcutil/ddcutil-0.8.6-r1.ebuild108
-rw-r--r--app-misc/ddcutil/ddcutil-0.8.6.ebuild106
-rw-r--r--app-misc/ddcutil/files/ddcutil-0.8.6-remove-pedantic-cflag.patch126
5 files changed, 0 insertions, 446 deletions
diff --git a/app-misc/ddcutil/Manifest b/app-misc/ddcutil/Manifest
index f9693bc10f72..886483f6e13b 100644
--- a/app-misc/ddcutil/Manifest
+++ b/app-misc/ddcutil/Manifest
@@ -1,3 +1 @@
-DIST ddcutil-0.8.4.tar.gz 558405 BLAKE2B 4bb93d6b9b28a17ef182c1f39e3b6351070c5541fd8eefccde2a6d771e28a8c656abe1e00a58ee935290cba79af09b1c2d6b611532827455b5ec83532bbb46c4 SHA512 e7bf78295a008607ef520e055873acc0bac6d94b850a6ea1f7d4a4ea9e080d23b4b7d82e5725a220ff120ab1523aa320265ba22671982625c10088521c72a14c
-DIST ddcutil-0.8.6.tar.gz 613272 BLAKE2B ce7072a819c5a2aa125ae8f6d5550cf0a516714f0635672015a0c24c9e525d34139c903ce7791955e0b30b8d4c66e94453eed60f8d8d024caccb49204d6fb853 SHA512 4ec473a37dc135700f4ce06634e6aa303199f4d743fba02c04ca509d0c31d45f59da7c6cd9818efc1fd8bc20dae518c5656fc8a38e9f00057677b1e997434fb0
DIST ddcutil-0.9.1.tar.gz 656853 BLAKE2B e4f11253176587cb5ee3c9647a01ab04d5a92ce4ca7a4098378318fc069e635e43c3716ace316498f64ceaaa00aa90db3b5f409b74b8d7089a7c25254c0e360d SHA512 b2d5866606a4bc081d89180e910822f2a2a653a2782e3df582536ddc86c7d3dc02309dbb41f8d566f6ebdc5d82d3aa11792a04c28b3d83552b024dfd59891fda
diff --git a/app-misc/ddcutil/ddcutil-0.8.4.ebuild b/app-misc/ddcutil/ddcutil-0.8.4.ebuild
deleted file mode 100644
index 2da920970975..000000000000
--- a/app-misc/ddcutil/ddcutil-0.8.4.ebuild
+++ /dev/null
@@ -1,104 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools flag-o-matic linux-info udev user
-
-DESCRIPTION="Program for querying and changing monitor settings"
-HOMEPAGE="http://www.ddcutil.com/"
-SRC_URI="https://github.com/rockowitz/ddcutil/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-# Binary drivers need special instructions compared to the open source counterparts.
-# If a user switches drivers, they will need to set different use flags for
-# Xorg or Wayland or Mesa, so this will trigger the rebuild against
-# the different drivers.
-# Remove ATI/AMD driver since it's masked for removal.
-# Will most likely need to set this for AMDGPU when in portage.
-IUSE="usb-monitor user-permissions video_cards_nvidia"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-
-RDEPEND="x11-libs/libXrandr
- x11-libs/libX11
- dev-libs/glib:2
- sys-apps/i2c-tools
- virtual/udev
- usb-monitor? (
- dev-libs/hidapi
- virtual/libusb:1
- sys-apps/usbutils )"
-DEPEND="virtual/pkgconfig
- ${RDEPEND}"
-
-pkg_pretend() {
- # This program needs /dev/ic2-* devices to communicate with the monitor.
- CONFIG_CHECK="~I2C_CHARDEV"
- ERROR_I2C_CHARDEV="You must enable I2C_CHARDEV in your kernel to continue"
- if use usb-monitor; then
- CONFIG_CHECK+=" ~HIDRAW ~USB_HIDDEV"
- ERROR_HIDRAW="HIDRAW is needed to support USB monitors"
- ERROR_I2C_CHARDEV="USB_HIDDEV is needed to support USB monitors"
- fi
-
- # Now do the actual checks setup above
- check_extra_config
-}
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- # Bug 607818.
- replace-flags -O3 -O2
-
- # Python API is still very experimental.
- local myeconfargs=(
- $(use_enable usb-monitor usb)
- --disable-swig
- --enable-lib
- )
-
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
- if use user-permissions; then
- udev_dorules data/etc/udev/rules.d/45-ddcutil-i2c.rules
- if use usb-monitor; then
- udev_dorules data/etc/udev/rules.d/45-ddcutil-usb.rules
- fi
- fi
-}
-
-pkg_postinst() {
- if use user-permissions; then
- enewgroup i2c
- einfo "To allow non-root users access to the /dev/i2c-* devices, add those"
- einfo "users to the i2c group: usermod -aG i2c user"
- einfo "Restart the computer or reload the i2c-dev module to activate"
- einfo "the new udev rule."
- einfo "For more information read: http://www.ddcutil.com/i2c_permissions/"
-
- if use usb-monitor; then
- enewgroup video
- einfo "To allow non-root users access to USB monitors, add those users"
- einfo "to the video group: usermod -aG video user"
- einfo "Restart the computer, reload the hiddev and hidraw modules, or replug"
- einfo "the monitor to activate the new udev rule."
- einfo "For more information read: http://www.ddcutil.com/usb/"
- fi
-
- udev_reload
- fi
-
- if use video_cards_nvidia; then
- ewarn "Please read the following webpage on proper usage with the nVidia "
- ewarn "binary drivers, or it may not work: http://www.ddcutil.com/nvidia/"
- fi
-}
diff --git a/app-misc/ddcutil/ddcutil-0.8.6-r1.ebuild b/app-misc/ddcutil/ddcutil-0.8.6-r1.ebuild
deleted file mode 100644
index a1402f71b646..000000000000
--- a/app-misc/ddcutil/ddcutil-0.8.6-r1.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools flag-o-matic linux-info udev user
-
-DESCRIPTION="Program for querying and changing monitor settings"
-HOMEPAGE="http://www.ddcutil.com/"
-SRC_URI="https://github.com/rockowitz/ddcutil/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86"
-IUSE="drm usb-monitor user-permissions video_cards_nvidia X"
-REQUIRED_USE="drm? ( X )"
-
-RDEPEND="dev-libs/glib:2
- sys-apps/i2c-tools
- virtual/udev
- drm? ( x11-libs/libdrm )
- usb-monitor? (
- dev-libs/hidapi
- virtual/libusb:1
- sys-apps/usbutils
- )
- X? (
- x11-libs/libXrandr
- x11-libs/libX11
- )"
-
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-PATCHES=( ${FILESDIR}/${P}-remove-pedantic-cflag.patch )
-
-pkg_pretend() {
- # This program needs /dev/ic2-* devices to communicate with the monitor.
- CONFIG_CHECK="~I2C_CHARDEV"
- ERROR_I2C_CHARDEV="You must enable I2C_CHARDEV in your kernel to continue"
- if use usb-monitor; then
- CONFIG_CHECK+=" ~HIDRAW ~USB_HIDDEV"
- ERROR_HIDRAW="HIDRAW is needed to support USB monitors"
- ERROR_I2C_CHARDEV="USB_HIDDEV is needed to support USB monitors"
- fi
-
- # Now do the actual checks setup above
- check_extra_config
-}
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- # Bug 607818.
- replace-flags -O3 -O2
-
- local myeconfargs=(
- $(use_enable drm)
- $(use_enable usb-monitor usb)
- $(use_enable X x11)
- --enable-lib
- --disable-cffi
- --disable-cython
- --disable-swig
- )
-
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
- if use user-permissions; then
- udev_dorules data/etc/udev/rules.d/45-ddcutil-i2c.rules
- if use usb-monitor; then
- udev_dorules data/etc/udev/rules.d/45-ddcutil-usb.rules
- fi
- fi
-}
-
-pkg_postinst() {
- if use user-permissions; then
- enewgroup i2c
- einfo "To allow non-root users access to the /dev/i2c-* devices, add those"
- einfo "users to the i2c group: usermod -aG i2c user"
- einfo "Restart the computer or reload the i2c-dev module to activate"
- einfo "the new udev rule."
- einfo "For more information read: http://www.ddcutil.com/i2c_permissions/"
-
- if use usb-monitor; then
- enewgroup video
- einfo "To allow non-root users access to USB monitors, add those users"
- einfo "to the video group: usermod -aG video user"
- einfo "Restart the computer, reload the hiddev and hidraw modules, or replug"
- einfo "the monitor to activate the new udev rule."
- einfo "For more information read: http://www.ddcutil.com/usb/"
- fi
-
- udev_reload
- fi
-
- if use video_cards_nvidia; then
- ewarn "Please read the following webpage on proper usage with the nVidia "
- ewarn "binary drivers, or it may not work: http://www.ddcutil.com/nvidia/"
- fi
-}
diff --git a/app-misc/ddcutil/ddcutil-0.8.6.ebuild b/app-misc/ddcutil/ddcutil-0.8.6.ebuild
deleted file mode 100644
index 6444e7739e03..000000000000
--- a/app-misc/ddcutil/ddcutil-0.8.6.ebuild
+++ /dev/null
@@ -1,106 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools flag-o-matic linux-info udev user
-
-DESCRIPTION="Program for querying and changing monitor settings"
-HOMEPAGE="http://www.ddcutil.com/"
-SRC_URI="https://github.com/rockowitz/ddcutil/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86"
-IUSE="drm usb-monitor user-permissions video_cards_nvidia X"
-REQUIRED_USE="drm? ( X )"
-
-RDEPEND="dev-libs/glib:2
- sys-apps/i2c-tools
- virtual/udev
- drm? ( x11-libs/libdrm )
- usb-monitor? (
- dev-libs/hidapi
- virtual/libusb:1
- sys-apps/usbutils
- )
- X? (
- x11-libs/libXrandr
- x11-libs/libX11
- )"
-
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-pkg_pretend() {
- # This program needs /dev/ic2-* devices to communicate with the monitor.
- CONFIG_CHECK="~I2C_CHARDEV"
- ERROR_I2C_CHARDEV="You must enable I2C_CHARDEV in your kernel to continue"
- if use usb-monitor; then
- CONFIG_CHECK+=" ~HIDRAW ~USB_HIDDEV"
- ERROR_HIDRAW="HIDRAW is needed to support USB monitors"
- ERROR_I2C_CHARDEV="USB_HIDDEV is needed to support USB monitors"
- fi
-
- # Now do the actual checks setup above
- check_extra_config
-}
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- # Bug 607818.
- replace-flags -O3 -O2
-
- local myeconfargs=(
- $(use_enable drm)
- $(use_enable usb-monitor usb)
- $(use_enable X x11)
- --enable-lib
- --disable-cffi
- --disable-cython
- --disable-swig
- )
-
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
- if use user-permissions; then
- udev_dorules data/etc/udev/rules.d/45-ddcutil-i2c.rules
- if use usb-monitor; then
- udev_dorules data/etc/udev/rules.d/45-ddcutil-usb.rules
- fi
- fi
-}
-
-pkg_postinst() {
- if use user-permissions; then
- enewgroup i2c
- einfo "To allow non-root users access to the /dev/i2c-* devices, add those"
- einfo "users to the i2c group: usermod -aG i2c user"
- einfo "Restart the computer or reload the i2c-dev module to activate"
- einfo "the new udev rule."
- einfo "For more information read: http://www.ddcutil.com/i2c_permissions/"
-
- if use usb-monitor; then
- enewgroup video
- einfo "To allow non-root users access to USB monitors, add those users"
- einfo "to the video group: usermod -aG video user"
- einfo "Restart the computer, reload the hiddev and hidraw modules, or replug"
- einfo "the monitor to activate the new udev rule."
- einfo "For more information read: http://www.ddcutil.com/usb/"
- fi
-
- udev_reload
- fi
-
- if use video_cards_nvidia; then
- ewarn "Please read the following webpage on proper usage with the nVidia "
- ewarn "binary drivers, or it may not work: http://www.ddcutil.com/nvidia/"
- fi
-}
diff --git a/app-misc/ddcutil/files/ddcutil-0.8.6-remove-pedantic-cflag.patch b/app-misc/ddcutil/files/ddcutil-0.8.6-remove-pedantic-cflag.patch
deleted file mode 100644
index e20cc36459ec..000000000000
--- a/app-misc/ddcutil/files/ddcutil-0.8.6-remove-pedantic-cflag.patch
+++ /dev/null
@@ -1,126 +0,0 @@
-diff -urN a/src/app_sysenv/Makefile.am b/src/app_sysenv/Makefile.am
---- a/src/app_sysenv/Makefile.am 2018-01-20 06:40:55.000000000 +0000
-+++ b/src/app_sysenv/Makefile.am 2018-01-28 20:16:44.143484825 +0000
-@@ -15,8 +15,8 @@
-
-
- AM_CFLAGS = -Wall
--AM_CFLAGS += -Werror
--AM_CFLAGS += -Wpedantic
-+#AM_CFLAGS += -Werror
-+#AM_CFLAGS += -Wpedantic
-
- if ENABLE_CALLGRAPH_COND
- AM_CFLAGS += -fdump-rtl-expand
-diff -urN a/src/base/Makefile.am b/src/base/Makefile.am
---- a/src/base/Makefile.am 2018-01-20 06:40:55.000000000 +0000
-+++ b/src/base/Makefile.am 2018-01-28 20:21:31.124936834 +0000
-@@ -4,7 +4,7 @@
- -I$(top_srcdir)/src/public
-
- AM_CFLAGS = -Wall
--AM_CFLAGS += -Werror
-+#AM_CFLAGS += -Werror
- # AM_CFLAGS += -Wpedantic
-
- if ENABLE_CALLGRAPH_COND
-diff -urN a/src/cmdline/Makefile.am b/src/cmdline/Makefile.am
---- a/src/cmdline/Makefile.am 2018-01-20 06:40:55.000000000 +0000
-+++ b/src/cmdline/Makefile.am 2018-01-28 20:20:32.178848976 +0000
-@@ -4,7 +4,7 @@
- -I$(top_srcdir)/src/public
-
- AM_CFLAGS = -Wall
--AM_CFLAGS += -Werror
-+#AM_CFLAGS += -Werror
- # flags g_option parser structs in cmd_parser_goption.c
- # AM_CFLAGS += -Wpedantic
-
-diff -urN a/src/ddc/Makefile.am b/src/ddc/Makefile.am
---- a/src/ddc/Makefile.am 2018-01-20 06:40:55.000000000 +0000
-+++ b/src/ddc/Makefile.am 2018-01-28 20:18:09.643626498 +0000
-@@ -11,8 +11,8 @@
-
-
- AM_CFLAGS = -Wall
--AM_CFLAGS += -Werror
--AM_CFLAGS += -Wpedantic
-+#AM_CFLAGS += -Werror
-+#AM_CFLAGS += -Wpedantic
-
- if ENABLE_CALLGRAPH_COND
- AM_CFLAGS += -fdump-rtl-expand
-diff -urN a/src/i2c/Makefile.am b/src/i2c/Makefile.am
---- a/src/i2c/Makefile.am 2018-01-20 06:40:55.000000000 +0000
-+++ b/src/i2c/Makefile.am 2018-01-28 20:17:30.271562118 +0000
-@@ -4,8 +4,8 @@
- -I$(top_srcdir)/src/public
-
- AM_CFLAGS = -Wall
--AM_CFLAGS += -Werror
--AM_CFLAGS += -Wpedantic
-+#AM_CFLAGS += -Werror
-+#AM_CFLAGS += -Wpedantic
-
- if ENABLE_CALLGRAPH_COND
- AM_CFLAGS += -fdump-rtl-expand
-diff -urN a/src/sample_clients/Makefile.am b/src/sample_clients/Makefile.am
---- a/src/sample_clients/Makefile.am 2018-01-20 06:40:55.000000000 +0000
-+++ b/src/sample_clients/Makefile.am 2018-01-28 20:19:57.230795822 +0000
-@@ -7,7 +7,7 @@
- -I$(top_srcdir)/src
-
- AM_CFLAGS = -Wall -fPIC
--AM_CFLAGS += -Werror
-+#AM_CFLAGS += -Werror
-
- check_PROGRAMS =
- if ENABLE_SHARED_LIB_COND
-diff -urN a/src/test/Makefile.am b/src/test/Makefile.am
---- a/src/test/Makefile.am 2018-01-20 06:40:55.000000000 +0000
-+++ b/src/test/Makefile.am 2018-01-28 20:19:03.509712410 +0000
-@@ -12,7 +12,7 @@
-
-
-
--AM_CFLAGS = -Wall -Werror
-+AM_CFLAGS = -Wall
-
- if ENABLE_CALLGRAPH_COND
- AM_CFLAGS += -fdump-rtl-expand
-diff -urN a/src/usb/Makefile.am b/src/usb/Makefile.am
---- a/src/usb/Makefile.am 2018-01-20 06:40:55.000000000 +0000
-+++ b/src/usb/Makefile.am 2018-01-28 20:18:26.146653076 +0000
-@@ -5,7 +5,7 @@
- -I$(top_srcdir)/src/public
-
- AM_CFLAGS = -Wall
--AM_CFLAGS += -Wpedantic
-+#AM_CFLAGS += -Wpedantic
-
- if ENABLE_CALLGRAPH_COND
- AM_CFLAGS += -fdump-rtl-expand
-diff -urN a/src/util/Makefile.am b/src/util/Makefile.am
---- a/src/util/Makefile.am 2018-01-20 06:40:55.000000000 +0000
-+++ b/src/util/Makefile.am 2018-01-28 20:21:07.245901502 +0000
-@@ -3,7 +3,7 @@
- $(LIBDRM_CFLAGS)
-
- AM_CFLAGS = -Wall
--AM_CFLAGS += -Werror
-+#AM_CFLAGS += -Werror
- # -pedantic issues warnings re code that doesn't conform to ISO C
- # Alas, -m modifier on sscanf is a POSIX extension, not ISO C
- # In combination with -Werror, causes device_util.c to fail compilation
-diff -urN a/src/vcp/Makefile.am b/src/vcp/Makefile.am
---- a/src/vcp/Makefile.am 2018-01-20 06:40:55.000000000 +0000
-+++ b/src/vcp/Makefile.am 2018-01-28 20:19:28.024750741 +0000
-@@ -4,7 +4,7 @@
- -I$(top_srcdir)/src/public
-
- AM_CFLAGS = -Wall
--AM_CFLAGS += -Werror
-+#AM_CFLAGS += -Werror
- # vcp_feature_codes.c requires extensive changes if -Wpedantic
- # AM_CFLAGS += -Wpedantic
-