summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emacs/magit/magit-2.2.2-r1.ebuild36
-rw-r--r--app-emacs/magit/magit-2.2.2-r2.ebuild24
2 files changed, 24 insertions, 36 deletions
diff --git a/app-emacs/magit/magit-2.2.2-r1.ebuild b/app-emacs/magit/magit-2.2.2-r1.ebuild
deleted file mode 100644
index bb0b51abe36c..000000000000
--- a/app-emacs/magit/magit-2.2.2-r1.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit elisp
-
-DESCRIPTION="An Emacs mode for GIT"
-HOMEPAGE="http://magit.github.io/"
-SRC_URI="https://github.com/magit/magit/releases/download/${PV}/${P}.tar.gz"
-
-LICENSE="GPL-3+ FDL-1.2+"
-SLOT="0"
-KEYWORDS="~amd64"
-RESTRICT="test"
-
-SITEFILE="50${PN}-gentoo.el"
-
-DEPEND=">=app-emacs/dash-2.12.0"
-RDEPEND="${DEPEND} >=dev-vcs/git-1.9.4"
-
-src_compile() {
- # The upstream build system ignores errors during byte-compilation
- # and happily installs broken files, causing errors at runtime.
- # Call elisp-compile, in order to catch them here already.
- elisp-compile lisp/*.el
- makeinfo Documentation/*.texi || die
-}
-
-src_install() {
- elisp-install ${PN} lisp/*.{el,elc}
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- doinfo *.info
- dodoc README.md Documentation/AUTHORS.md Documentation/${PV}.txt
-}
diff --git a/app-emacs/magit/magit-2.2.2-r2.ebuild b/app-emacs/magit/magit-2.2.2-r2.ebuild
new file mode 100644
index 000000000000..acb718137f8b
--- /dev/null
+++ b/app-emacs/magit/magit-2.2.2-r2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="A Git porcelain inside Emacs"
+HOMEPAGE="http://magit.vc/"
+SRC_URI="https://github.com/magit/magit/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+S="${WORKDIR}/${P}/lisp"
+SITEFILE="50${PN}-gentoo.el"
+ELISP_TEXINFO="../Documentation/*.texi"
+DOCS="../README.md ../Documentation/AUTHORS.md ../Documentation/${PV}.txt"
+
+DEPEND=">=app-emacs/dash-2.12.1"
+RDEPEND="${DEPEND} >=dev-vcs/git-1.9.4"