summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/github-cli/Manifest2
-rw-r--r--dev-util/github-cli/github-cli-2.12.1.ebuild66
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-util/github-cli/Manifest b/dev-util/github-cli/Manifest
index aafc44154b04..7da0067c9091 100644
--- a/dev-util/github-cli/Manifest
+++ b/dev-util/github-cli/Manifest
@@ -1,2 +1,4 @@
DIST github-cli-2.11.3-deps.tar.xz 76137064 BLAKE2B 6b8a224f8e0b05c32c8be83b4f5a0b05febb44b230c06ce0d14dfb5a814faf0361d24f32a5feb1ec348e9b80dd35635249bdf1febf6cd6202ba5ea1e3e6a3168 SHA512 f72909be8798a7efed8cb2ee2c37f51216056901fd285b4e2c894ebfc2f08194b99d846f2f0080da4c1c3359b47e36f7eece11b4bec93485da5330ad38c073f1
DIST github-cli-2.11.3.tar.gz 716386 BLAKE2B dcb07cda11e03ffe75a9ec2fcb0ed33c1f2c6bb7599ed1b47ee9e1e0df609fa21ae2dd043be417cfee75dcb3686290f510c0fdffc0b1df08f816ab2ac79d940b SHA512 952cd7c2a327c7169e201a4aa7c26a0e5c09a1ecef51b8d7c620fa9a849c2e8cc61447333f785851487a68d058b869e10bb290188594bd2fb00b0384297bdfd8
+DIST github-cli-2.12.1-deps.tar.xz 76485020 BLAKE2B c2d7e31a2fba9c34fc75c8d8f6836accbd2029b8f6be51c4ffda3d96ec06b9f331700573ac8478550676ed9385b8bc34ffa02a81d91aec3bde4bece0addae668 SHA512 1aa684d5aad6c5da45d4e0d8fe2c282a563890d7f48260668b393b0e93674b5c75862a84c421c8600c92d09ebfe655baaa42e3e7a4dc2f7a0792384ea555b2fc
+DIST github-cli-2.12.1.tar.gz 717685 BLAKE2B b9782846185b8fd5295651cfdd082b987555edd0c3ae2ef7e0d69e100f331ea89e5ae9b8824af013f008677df2a0e8313b52cd7e0d95110884a62eb9e6e5c32e SHA512 508f02cfb12bec485a6123bf04056e879832a762d7563c73d1f006f4c382cad75cfb73ae74f66f9ed90b0cfd68956434f2100bab1dd7c93ec6d0d7b3a9d2c13f
diff --git a/dev-util/github-cli/github-cli-2.12.1.ebuild b/dev-util/github-cli/github-cli-2.12.1.ebuild
new file mode 100644
index 000000000000..e08b4ff2cbbe
--- /dev/null
+++ b/dev-util/github-cli/github-cli-2.12.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit bash-completion-r1 flag-o-matic go-module
+
+DESCRIPTION="GitHub CLI"
+HOMEPAGE="https://github.com/cli/cli"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/cli/cli.git"
+else
+ SRC_URI="https://github.com/cli/cli/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+ KEYWORDS="~amd64 ~riscv"
+ S="${WORKDIR}/cli-${PV}"
+fi
+
+LICENSE="MIT Apache-2.0 BSD BSD-2 MPL-2.0"
+SLOT="0"
+
+RDEPEND=">=dev-vcs/git-1.7.3"
+
+RESTRICT="test"
+
+src_unpack() {
+ if [[ ${PV} == *9999 ]]; then
+ git-r3_src_unpack
+ go-module_live_vendor
+ else
+ go-module_src_unpack
+ fi
+}
+
+src_compile() {
+ [[ ${PV} == *9999 ]] || export GH_VERSION="v${PV}"
+ # Filter '-flto*' flags to avoid build failures.
+ filter-flags "-flto*"
+ # Filter '-ggdb3' flag to avoid build failures. bugs.gentoo.org/847991
+ filter-flags "-ggdb3"
+ # Go LDFLAGS are not the same as GCC/Binutils LDFLAGS
+ unset LDFLAGS
+ # Once we set up cross compiling, this line will need to be adjusted
+ # to compile for the target.
+ # Everything else in this function happens on the host.
+ emake
+
+ einfo "Building man pages"
+ emake manpages
+
+ einfo "Building completions"
+ go run ./cmd/gh completion -s bash > gh.bash-completion || die
+ go run ./cmd/gh completion -s zsh > gh.zsh-completion || die
+}
+
+src_install() {
+ dobin bin/gh
+ dodoc README.md
+
+ doman share/man/man?/gh*.?
+
+ newbashcomp gh.bash-completion gh
+ insinto /usr/share/zsh/site-functions
+ newins gh.zsh-completion _gh
+}