summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-libs/libqmi/Manifest1
-rw-r--r--net-libs/libqmi/libqmi-1.28.6.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/net-libs/libqmi/Manifest b/net-libs/libqmi/Manifest
index 95e0379a6d5b..216b6542dcfb 100644
--- a/net-libs/libqmi/Manifest
+++ b/net-libs/libqmi/Manifest
@@ -1 +1,2 @@
DIST libqmi-1.28.4.tar.xz 1168088 BLAKE2B 828a8688a49a08f0848414b8e51c2ece4a0035ecdf449a5dc9e2cf3b6ecaf1525d5a1c29e329a584ec054f66b9a141d0ba3980b8affb34db3088ed2b5591a265 SHA512 dad3cd2740804d2ec6aa04f0f140d385c00d5a3854d75ccdf54ee6fa4f3cdfc02de5da21cd8b43d5a7c6b467b94b5001bc857fbab01aeedbdb51c0e3d9da9690
+DIST libqmi-1.28.6.tar.xz 1192736 BLAKE2B 30330a8d085b26fc461c6fec2cfa58757e91093243aed8a4ac6df53a7656881f295a800979ff8fd42b815f96fafd128848765ecfb163e8101ac9c9a52eaaf507 SHA512 f4f7022e8c9b60618062548ec97450d98a5125dbd0e26df3dfb8bda5ab19a1f4c7864d35f7bd77217a4fe5562ce665fa613902b1d2185680bfa5d0c1e229e6dd
diff --git a/net-libs/libqmi/libqmi-1.28.6.ebuild b/net-libs/libqmi/libqmi-1.28.6.ebuild
new file mode 100644
index 000000000000..ae2df1d55498
--- /dev/null
+++ b/net-libs/libqmi/libqmi-1.28.6.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3 autotools
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/mobile-broadband/libqmi.git"
+else
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~x86"
+ SRC_URI="https://www.freedesktop.org/software/libqmi/${P}.tar.xz"
+fi
+
+DESCRIPTION="Qualcomm MSM (Mobile Station Modem) Interface (QMI) modem protocol library"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/libqmi/ https://gitlab.freedesktop.org/mobile-broadband/libqmi"
+
+LICENSE="LGPL-2"
+SLOT="0/5.7" # soname of libqmi-glib.so
+IUSE="gtk-doc +mbim"
+
+RDEPEND=">=dev-libs/glib-2.48
+ dev-libs/libgudev
+ mbim? ( >=net-libs/libmbim-1.18.0 )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ gtk-doc? ( dev-util/gtk-doc )"
+[[ ${PV} == "9999" ]] && BDEPEND+=" dev-util/gtk-doc" #469214
+
+src_prepare() {
+ default
+ [[ ${PV} == "9999" ]] && eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ --disable-Werror
+ --disable-static
+ --disable-qrtr # libqrtr-glib not packaged
+ $(use_enable mbim mbim-qmux)
+ $(use_enable gtk-doc)
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}