summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail-filter/spf-engine/Manifest1
-rw-r--r--mail-filter/spf-engine/spf-engine-2.9.2-r3.ebuild79
2 files changed, 0 insertions, 80 deletions
diff --git a/mail-filter/spf-engine/Manifest b/mail-filter/spf-engine/Manifest
index eff4661fd37e..4303d92ba1b5 100644
--- a/mail-filter/spf-engine/Manifest
+++ b/mail-filter/spf-engine/Manifest
@@ -1,2 +1 @@
-DIST spf-engine-2.9.2.tar.gz 52737 BLAKE2B 39d6c9831ef3ea489f2910fcbcaec9b2bed627f02459e20826166f04a2fe895aecf83768a3446a037e4231cc317ee277f6ff8e9030c72d8819739f6af889d632 SHA512 fe1fe82411ed4d6fcfadccd6ccc9fbd36372b4676051aafa5984740cba862336b00567576b3e32451cd24b0cfcd992d7dfdee33f0cf65a35f4009837e99b8f98
DIST spf-engine-2.9.3.tar.gz 52974 BLAKE2B 9e6c47af7d523e1486d9bbfee2b0e53a4a97dbfc93e1cd14f70d4676542defaf6fede397d33e21c00e9bb2cdd1016c98981b6c0e735bdfd225b226920b9470b1 SHA512 adde80eca38f372ad00ed7355951007b9c02ef8a52a5a4edcbf2fa9959220f1083e3e313668e9c7ad2c26144148ae8ff62ec468d79936d96b43897598254f528
diff --git a/mail-filter/spf-engine/spf-engine-2.9.2-r3.ebuild b/mail-filter/spf-engine/spf-engine-2.9.2-r3.ebuild
deleted file mode 100644
index 4936a62e0edb..000000000000
--- a/mail-filter/spf-engine/spf-engine-2.9.2-r3.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_7 python3_8 python3_9 )
-
-# The built-in ipaddress module handles the parsing of IP addresses. If
-# python is built without ipv6 support, then ipaddress can't parse ipv6
-# addresses, and the daemon will crash if it sees an ipv6 SPF record. In
-# other words, it's completely broken.
-PYTHON_REQ_USE="ipv6(+)"
-
-# setup.py defines entry_points
-DISTUTILS_USE_SETUPTOOLS=rdepend
-inherit distutils-r1
-
-DESCRIPTION="Policy daemon and milter for Postfix SPF verification"
-HOMEPAGE="https://launchpad.net/spf-engine"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-DEPEND="dev-python/pyspf[${PYTHON_USEDEP}]"
-
-RDEPEND="${DEPEND}
- dev-python/authres[${PYTHON_USEDEP}]"
-
-DOCS=( CHANGES policyd-spf.conf.commented README README.per_user_whitelisting )
-
-python_prepare_all() {
- # The "real" config file mentions the commented one, so we point
- # users in the right direction.
- local oldconf="policyd-spf.conf.commented"
- local newconf="/usr/share/doc/${PF}/${oldconf}"
-
- sed -e "1 s~ ${oldconf}~,\n# ${newconf}~" -i policyd-spf.conf \
- || die 'failed to update commented config file path'
-
- distutils-r1_python_prepare_all
-}
-
-src_install() {
- distutils-r1_src_install
-
- # Remove the milter files that are installed by default. The milter
- # isn't quite ready:
- #
- # * The README says it's experimental not well-tested.
- # * There's no documentation for its configuration parameters
- # (expecially the UserID).
- # * The configuration file is hard-coded to /usr/local.
- # * The paths in the systemd service file are hard-coded to /usr/local.
- # * We need to write an OpenRC service script for it.
- #
- # These are all eventually doable, but I'm not willing to commit to
- # making the milter work before upstream is.
- #
- rm "${ED}/usr/bin/pyspf-milter" \
- || die "failed to remove ${ED}/usr/bin/pyspf-milter"
- rm -r "${ED}/usr/lib/systemd" \
- || die "failed to remove ${ED}/usr/lib/systemd"
- rm -r "${ED}/usr/etc/init.d" \
- || die "failed to remove ${ED}/usr/etc/init.d"
- einfo "The milter component of spf-engine is still deemed experimental"
- einfo "and not well-tested by upstream. It's missing configuration"
- einfo "files, service scripts, and documentation. In other words, it"
- einfo "doesn't work yet."
-
- # The setuptools installation routing always works relative to
- # python's prefix, so that when installing locally you wind up
- # with paths like /usr/local/etc. However for system installs
- # that does the wrong thing and puts the sysconfdir at /usr/etc.
- # Here we move it to the right place.
- mv -v "${ED}/usr/etc" "${ED}/" || die 'failed to relocate sysconfdir'
-}