summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/raft/Manifest1
-rw-r--r--dev-libs/raft/raft-0.11.0.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-libs/raft/Manifest b/dev-libs/raft/Manifest
index 221fb552b3d7..e098eba4909d 100644
--- a/dev-libs/raft/Manifest
+++ b/dev-libs/raft/Manifest
@@ -1 +1,2 @@
DIST raft-0.10.1.tar.gz 318911 BLAKE2B 42ef22dfc89f05a3a9f130011c0f906201126a1615f9a60648587e014bbb63e038b3afd1593c2c07b046c3c35ef07deaa45cdce58062707409e4dbd3a9f7516e SHA512 6fa99d9dbb5895299c5124f5c8cfb544cf1bccae4ee196bc8011cd4cf9c632cd896f8cd93181409fbaf7da115235c72a4e10568080dd9957eceb978784dc0f9d
+DIST raft-0.11.0.tar.gz 324254 BLAKE2B 401be37c2cf9ee9337c24d3e010ce084b983056725096f23654ae0496e6cb1210ab4d6fa38543c19a53d7aa6427bfe01052f85618afe2475a113edc4ba8d2745 SHA512 808ea593e019ed1740ced2de4afd7f522056e08ccd739be77b069de80dd21e60dc9469395d6e18cb8f8056c12f4ef34859ca5892a3937280e708515a8bb3cebf
diff --git a/dev-libs/raft/raft-0.11.0.ebuild b/dev-libs/raft/raft-0.11.0.ebuild
new file mode 100644
index 000000000000..cbf81fcbddb9
--- /dev/null
+++ b/dev-libs/raft/raft-0.11.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="C implementation of the Raft consensus protocol"
+HOMEPAGE="https://github.com/canonical/raft"
+SRC_URI="https://github.com/canonical/raft/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="lz4 test zfs"
+RESTRICT="!test? ( test )"
+
+DEPEND="dev-libs/libuv
+ lz4? ( app-arch/lz4 )"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/raft-0.9.25-Always-skip-init-oom-test.patch
+ "${FILESDIR}"/raft-0.10.0-toggle-zfs.patch
+ )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-uv
+
+ --disable-benchmark
+ --disable-debug
+ --disable-example
+ --disable-sanitize
+ --disable-static
+
+ $(use_enable lz4)
+ $(use_enable test fixture)
+
+ $(use_with zfs)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}