summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-p2p/kubo/Manifest2
-rw-r--r--net-p2p/kubo/kubo-0.14.0.ebuild69
2 files changed, 0 insertions, 71 deletions
diff --git a/net-p2p/kubo/Manifest b/net-p2p/kubo/Manifest
index 0e538fe532e7..14ab16bd8bf8 100644
--- a/net-p2p/kubo/Manifest
+++ b/net-p2p/kubo/Manifest
@@ -1,3 +1 @@
-DIST kubo-0.14.0-deps.tar.xz 169389828 BLAKE2B 9b664286885ad16eba2697bfbd87286fc35edb034beb0b80bcfa307af507013964f83783b0036d35d1e132f0a2a549e96f50f527cb3812cfe1417b36f7c416ed SHA512 cabb3c48bfc5d38996c5635b62b4a8dc49ca497cbe011e51c33086f18882fa74bc613644a4289639a7278dad634c66351c650c8ae041c9fca7f9f2c914644dd2
-DIST kubo-0.14.0.tar.gz 2224560 BLAKE2B d03f2ae98833f07a55cb8d929e3433ee35ad53345c31c80963ff4a183cbfa2ebf803607e0123b08304022673c1aa05013698d2cd3b97b4ecae84f4c4c5b69ab4 SHA512 ecba5d3669d50c382bff1b4d0197f5d8f67f36bb6e995d1db5791413bcf813ea8bf22fd3ea00368c0cf33cfc45621ea2f258acb52bda2b42ee2e1a7392195c10
DIST kubo-0.15.0.tar.gz 13318096 BLAKE2B 92a97eea130d24065c5d8a60ee7eb9b2bd3afba94596c0b538b04970277df11bf11f1cfc8399b303cea58cd249a86f956174d6544e6b6a94b34722ecdd20671a SHA512 26c1945c4ce641953e72a8f08802aa5acdd6c39fee3c1306bec0613a36b3d1ad79e23f7531427631848a6952ed950d27cd6a09f18352043bc145669b491843e6
diff --git a/net-p2p/kubo/kubo-0.14.0.ebuild b/net-p2p/kubo/kubo-0.14.0.ebuild
deleted file mode 100644
index d0a469ae9fd2..000000000000
--- a/net-p2p/kubo/kubo-0.14.0.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit bash-completion-r1 go-module systemd
-
-DESCRIPTION="Main implementation of IPFS"
-HOMEPAGE="https://ipfs.io/"
-SRC_URI="https://github.com/ipfs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
-
-LICENSE="Apache-2.0 BSD BSD-2 CC0-1.0 ISC MIT MPL-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-COMMON_DEPEND="
- acct-group/ipfs
- acct-user/ipfs
- sys-fs/fuse:0
-"
-DEPEND="${COMMON_DEPEND}"
-RDEPEND="${COMMON_DEPEND}"
-BDEPEND="<dev-lang/go-1.19"
-
-DOCS=( CHANGELOG.md CONTRIBUTING.md README.md docs/ )
-
-src_compile() {
- local mygoargs
- mygoargs=(
- -tags release
- )
-
- ego build "${mygoargs[@]}" -o ipfs ./cmd/ipfs
- ego build "${mygoargs[@]}" -o ipfswatch ./cmd/ipfswatch
-
- IPFS_PATH="" ./ipfs commands completion bash > ipfs-completion.bash || die
-}
-
-src_test() {
- ego test ./cmd/ipfs/... ./cmd/ipfswatch/...
-}
-
-src_install() {
- dobin ipfs
- dobin ipfswatch
- newbashcomp ipfs-completion.bash ipfs
- einstalldocs
-
- systemd_dounit "${FILESDIR}/ipfs.service"
- systemd_newunit "${FILESDIR}/ipfs-at.service" "ipfs@.service"
-
- newinitd "${FILESDIR}/ipfs.init" ipfs
- newconfd "${FILESDIR}/ipfs.confd" ipfs
-
- keepdir /var/log/ipfs
- fowners -R ipfs:ipfs /var/log/ipfs
-}
-
-pkg_postinst() {
- elog 'To be able to use the ipfs service you will need to create the ipfs repository'
- elog '(eg: su -s /bin/sh -c "ipfs init -e" ipfs)'
- elog 'or change IPFS_PATH of /etc/conf.d/ipfs with another with proper permissions.'
-
- # See https://bugs.gentoo.org/838238
- ewarn 'In case kubo CPU usage is too high run the next workaround'
- ewarn 'su -s /bin/sh -c "ipfs config profile apply lowpower" ipfs'
- ewarn 'Be aware that this will make your node less visible to other peers'
-}