summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-geosciences/laszip/laszip-3.4.1-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sci-geosciences/laszip/laszip-3.4.1-r1.ebuild b/sci-geosciences/laszip/laszip-3.4.1-r1.ebuild
new file mode 100644
index 000000000000..39ce3fba99a0
--- /dev/null
+++ b/sci-geosciences/laszip/laszip-3.4.1-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="Library for free and lossless compression of the LAS LiDAR format"
+HOMEPAGE="https://laszip.org/"
+SRC_URI="https://github.com/LASzip/LASzip/releases/download/${PV}/${PN}-src-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+S="${WORKDIR}/${PN}-src-${PV}"
+
+src_configure() {
+ # -Werror=odr
+ # https://bugs.gentoo.org/862582
+ # Fixed in newer version.
+ filter-lto
+
+ cmake_src_configure
+}