summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-client/pybugz/pybugz-0.13-r1.ebuild (renamed from www-client/pybugz/pybugz-0.13.ebuild)11
-rw-r--r--www-client/pybugz/pybugz-9999.ebuild11
2 files changed, 10 insertions, 12 deletions
diff --git a/www-client/pybugz/pybugz-0.13.ebuild b/www-client/pybugz/pybugz-0.13-r1.ebuild
index 263a9fda68c9..bdd2da64a75c 100644
--- a/www-client/pybugz/pybugz-0.13.ebuild
+++ b/www-client/pybugz/pybugz-0.13-r1.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+
+PYTHON_COMPAT=( python3_{8..9} )
PYTHON_REQ_USE="readline(+)"
if [ "${PV}" = "9999" ]; then
@@ -17,9 +18,9 @@ inherit bash-completion-r1 distutils-r1
DESCRIPTION="Command line interface to (Gentoo) Bugzilla"
HOMEPAGE="https://github.com/williamh/pybugz"
+
LICENSE="GPL-2"
SLOT="0"
-IUSE="zsh-completion"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
@@ -28,8 +29,6 @@ python_install_all() {
distutils-r1_python_install_all
newbashcomp contrib/bash-completion bugz
- if use zsh-completion ; then
- insinto /usr/share/zsh/site-functions
- newins contrib/zsh-completion _pybugz
- fi
+ insinto /usr/share/zsh/site-functions
+ newins contrib/zsh-completion _pybugz
}
diff --git a/www-client/pybugz/pybugz-9999.ebuild b/www-client/pybugz/pybugz-9999.ebuild
index 96ffebb7859e..f95c65ea1b0d 100644
--- a/www-client/pybugz/pybugz-9999.ebuild
+++ b/www-client/pybugz/pybugz-9999.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+
+PYTHON_COMPAT=( python3_{8..9} )
PYTHON_REQ_USE="readline(+)"
if [ "${PV}" = "9999" ]; then
@@ -17,9 +18,9 @@ inherit bash-completion-r1 distutils-r1
DESCRIPTION="Command line interface to (Gentoo) Bugzilla"
HOMEPAGE="https://github.com/williamh/pybugz"
+
LICENSE="GPL-2"
SLOT="0"
-IUSE="zsh-completion"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
@@ -28,8 +29,6 @@ python_install_all() {
distutils-r1_python_install_all
newbashcomp contrib/bash-completion bugz
- if use zsh-completion ; then
- insinto /usr/share/zsh/site-functions
- newins contrib/zsh-completion _pybugz
- fi
+ insinto /usr/share/zsh/site-functions
+ newins contrib/zsh-completion _pybugz
}