summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/jsonpatch/Manifest1
-rw-r--r--dev-python/jsonpatch/jsonpatch-1.25.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/jsonpatch/Manifest b/dev-python/jsonpatch/Manifest
index 8a86cfc672a8..353a6af6641c 100644
--- a/dev-python/jsonpatch/Manifest
+++ b/dev-python/jsonpatch/Manifest
@@ -1 +1,2 @@
DIST jsonpatch-1.23.tar.gz 18162 BLAKE2B 86322a4de88d37eb674d28425d3aee4ad3b589c724b124f37f16e8303200c742404512b9c675f5b5eb8d8f7916469ebb7915bf289c8190092bcf48a1cb9ca7a0 SHA512 da612fc043e351087fbda26cd5686743107dafca1223e784626c39113dfb4770647db1420e9ab9eee93d12c608a6e0812f0825229ab092962cfb390b6b1795ed
+DIST jsonpatch-1.25.tar.gz 24340 BLAKE2B 0022b4b0b3a0487958b86f14c1738a32593b8056510e3836e15385874b64f5d243d757c99a146a48da6563f0d9330eb38cb91ad6cde3e0a1b4cb8cbd3b15f9dd SHA512 5e1d5b6dcb6ee847ddd561400fe2d00e07aa1827a63ab98a38cd5e91fa0e52d8635eba1192edbccf9c7b9ce9c7ce0a414d580665c427c87a820e533d26092ad6
diff --git a/dev-python/jsonpatch/jsonpatch-1.25.ebuild b/dev-python/jsonpatch/jsonpatch-1.25.ebuild
new file mode 100644
index 000000000000..77592f3ef041
--- /dev/null
+++ b/dev-python/jsonpatch/jsonpatch-1.25.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Apply JSON-Patches like http://tools.ietf.org/html/draft-pbryan-json-patch-04"
+HOMEPAGE="https://github.com/stefankoegl/python-json-patch"
+SRC_URI="https://github.com/stefankoegl/python-json-patch/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/python-json-patch-${PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=">=dev-python/jsonpointer-1.9[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? ( ${RDEPEND} )
+"
+RESTRICT="!test? ( test )"
+
+python_test() {
+ "${EPYTHON}" tests.py || die "Tests of tests.py fail with ${EPYTHON}"
+ "${EPYTHON}" ext_tests.py || die "Tests of ext_tests.py fail with ${EPYTHON}"
+}