summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/botan/botan-2.19.3-r1.ebuild (renamed from dev-libs/botan/botan-2.19.3.ebuild)10
-rw-r--r--dev-libs/botan/botan-3.0.0-r1.ebuild (renamed from dev-libs/botan/botan-3.0.0.ebuild)10
2 files changed, 18 insertions, 2 deletions
diff --git a/dev-libs/botan/botan-2.19.3.ebuild b/dev-libs/botan/botan-2.19.3-r1.ebuild
index 1ad66cddebfd..782d8dcc8ce1 100644
--- a/dev-libs/botan/botan-2.19.3.ebuild
+++ b/dev-libs/botan/botan-2.19.3-r1.ebuild
@@ -40,7 +40,10 @@ DEPEND="
sqlite? ( dev-db/sqlite:3= )
zlib? ( >=sys-libs/zlib-1.2.3:= )
"
-RDEPEND="${DEPEND}"
+RDEPEND="
+ ${DEPEND}
+ !<dev-libs/botan-3.0.0-r1:3[tools]
+"
BDEPEND="
${PYTHON_DEPS}
$(python_gen_any_dep '
@@ -178,4 +181,9 @@ src_install() {
if use python ; then
python_foreach_impl python_domodule src/python/botan$(ver_cut 1).py
fi
+
+ # Avoid collisions between slots for tools (bug #905700)
+ if use tools ; then
+ mv "${ED}"/usr/bin/botan "${ED}"/usr/bin/botan$(ver_cut 1) || die
+ fi
}
diff --git a/dev-libs/botan/botan-3.0.0.ebuild b/dev-libs/botan/botan-3.0.0-r1.ebuild
index e31d7d9348d4..d5f062279dde 100644
--- a/dev-libs/botan/botan-3.0.0.ebuild
+++ b/dev-libs/botan/botan-3.0.0-r1.ebuild
@@ -40,7 +40,10 @@ DEPEND="
sqlite? ( dev-db/sqlite:3= )
zlib? ( >=sys-libs/zlib-1.2.3:= )
"
-RDEPEND="${DEPEND}"
+RDEPEND="
+ ${DEPEND}
+ !<dev-libs/botan-2.19.3-r1:2[tools]
+"
BDEPEND="
${PYTHON_DEPS}
$(python_gen_any_dep '
@@ -178,4 +181,9 @@ src_install() {
if use python ; then
python_foreach_impl python_domodule src/python/botan$(ver_cut 1).py
fi
+
+ # Avoid collisions between slots for tools (bug #905700)
+ if use tools ; then
+ mv "${ED}"/usr/bin/botan "${ED}"/usr/bin/botan$(ver_cut 1) || die
+ fi
}