summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/ddt/Manifest1
-rw-r--r--dev-python/ddt/ddt-1.2.2.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/ddt/Manifest b/dev-python/ddt/Manifest
index 54f13c20f36c..5a27f7e96141 100644
--- a/dev-python/ddt/Manifest
+++ b/dev-python/ddt/Manifest
@@ -1 +1,2 @@
DIST ddt-1.1.1.tar.gz 10021 BLAKE2B b2024bb214bbc13b585ebfedecec32e3e53072a9c82ac2355625ba0e8a77159cc8e3c3d86788b5da4319f9ba6afddd61086b1b305ae7e2b9bd71edde139b7185 SHA512 3839ac0448292bde07d676456640cd9466353e8c4481e60cb51e33704c21f92fdf840901430aa7f5276ccf579a7cd70b277fa2ceae03bce183e2422d514897a9
+DIST ddt-1.2.2.tar.gz 15170 BLAKE2B 4fb4a4493b96b7d45e060146212d6f2b4b31ecfa8ad5650da34cedb53725b20cbecafc765f3208cffbb3bb3c4f92579e94f369c9b8216e9693eb0fcddff96af9 SHA512 9b45c4b422cab9e6858235b413b622f077bf4e5254214165c50afdea767dda7d9f39e7be7b0d583b87849a078271f4fba34ac5fe0f35bd196eb7f396bd308fe7
diff --git a/dev-python/ddt/ddt-1.2.2.ebuild b/dev-python/ddt/ddt-1.2.2.ebuild
new file mode 100644
index 000000000000..b3e404bebdea
--- /dev/null
+++ b/dev-python/ddt/ddt-1.2.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7,8}} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="A library to multiply test cases"
+HOMEPAGE="https://pypi.org/project/ddt/ https://github.com/txels/ddt"
+SRC_URI="https://github.com/datadriventests/ddt/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests nose