summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-fs/unionfs-fuse/unionfs-fuse-2.1.ebuild3
-rw-r--r--sys-fs/unionfs-fuse/unionfs-fuse-9999.ebuild3
2 files changed, 4 insertions, 2 deletions
diff --git a/sys-fs/unionfs-fuse/unionfs-fuse-2.1.ebuild b/sys-fs/unionfs-fuse/unionfs-fuse-2.1.ebuild
index b9d37ded3403..329020ca1173 100644
--- a/sys-fs/unionfs-fuse/unionfs-fuse-2.1.ebuild
+++ b/sys-fs/unionfs-fuse/unionfs-fuse-2.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -41,6 +41,7 @@ src_install() {
}
src_test() {
+ [[ -e /dev/fuse ]] || return 0
addwrite /dev/fuse
pytest -vv || die "Tests fail with ${EPYTHON}"
}
diff --git a/sys-fs/unionfs-fuse/unionfs-fuse-9999.ebuild b/sys-fs/unionfs-fuse/unionfs-fuse-9999.ebuild
index 61aad0ff62cf..c5479601a118 100644
--- a/sys-fs/unionfs-fuse/unionfs-fuse-9999.ebuild
+++ b/sys-fs/unionfs-fuse/unionfs-fuse-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -41,6 +41,7 @@ src_install() {
}
src_test() {
+ [[ -e /dev/fuse ]] || return 0
addwrite /dev/fuse
pytest -vv || die "Tests fail with ${EPYTHON}"
}