summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/entrypoint2/Manifest1
-rw-r--r--dev-python/entrypoint2/entrypoint2-1.0-r1.ebuild29
-rw-r--r--dev-python/entrypoint2/entrypoint2-1.0.ebuild25
-rw-r--r--dev-python/entrypoint2/files/entrypoint2-1.0-python311.patch13
4 files changed, 0 insertions, 68 deletions
diff --git a/dev-python/entrypoint2/Manifest b/dev-python/entrypoint2/Manifest
index 5e0b8c117185..7aad354e11cd 100644
--- a/dev-python/entrypoint2/Manifest
+++ b/dev-python/entrypoint2/Manifest
@@ -1,2 +1 @@
-DIST entrypoint2-1.0.tar.gz 15424 BLAKE2B 1270a35218cde90922fe8f675917545f4c43e5ec0effd632583cd0bd02200d6a453716787c222722cec633bcb108c1b8c26e284e9659e754d3bc6a77895a6042 SHA512 6580dbf19482af95cbccad61b6f6dc73c068ac78d166e2cea4fae54243921e577316d38e204ad5983f0f52d898d67a10f4c90332d4eeaff1ea713bfc82c70890
DIST entrypoint2-1.1.gh.tar.gz 15480 BLAKE2B e9a834b863e624971266b78fed75ce2621511f7529f88e4950803c8978a1e27e81585751c25eab82aa1507b6abf8500b11e6ab7ec80052ccd31bec16bf3ed790 SHA512 807b8a53cc5c3e88de971c624dc69b3d526637d84856a0a67fdf2d15c51224cb5c48a7614eaa1942783ce2e954791a86f5ae6eb4dbf1a6e7928161e2cc8f293d
diff --git a/dev-python/entrypoint2/entrypoint2-1.0-r1.ebuild b/dev-python/entrypoint2/entrypoint2-1.0-r1.ebuild
deleted file mode 100644
index 758a23521d24..000000000000
--- a/dev-python/entrypoint2/entrypoint2-1.0-r1.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-inherit distutils-r1
-
-DESCRIPTION="Easy to use command-line interface for python modules"
-HOMEPAGE="https://github.com/ponty/entrypoint2"
-SRC_URI="https://github.com/ponty/entrypoint2/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-
-BDEPEND="
- test? (
- dev-python/easyprocess[${PYTHON_USEDEP}]
- dev-python/path-py[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}/${P}-python311.patch"
-)
-
-distutils_enable_tests pytest
diff --git a/dev-python/entrypoint2/entrypoint2-1.0.ebuild b/dev-python/entrypoint2/entrypoint2-1.0.ebuild
deleted file mode 100644
index 3547ae9dde3c..000000000000
--- a/dev-python/entrypoint2/entrypoint2-1.0.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Easy to use command-line interface for python modules"
-HOMEPAGE="https://github.com/ponty/entrypoint2"
-SRC_URI="https://github.com/ponty/entrypoint2/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-
-BDEPEND="
- test? (
- dev-python/easyprocess[${PYTHON_USEDEP}]
- dev-python/path-py[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
diff --git a/dev-python/entrypoint2/files/entrypoint2-1.0-python311.patch b/dev-python/entrypoint2/files/entrypoint2-1.0-python311.patch
deleted file mode 100644
index 95de1d3b689a..000000000000
--- a/dev-python/entrypoint2/files/entrypoint2-1.0-python311.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/entrypoint2/__init__.py b/entrypoint2/__init__.py
-index 63ab78b..a99a298 100644
---- a/entrypoint2/__init__.py
-+++ b/entrypoint2/__init__.py
-@@ -345,7 +345,7 @@ def _correct_args(func, kwargs):
- Convert a dictionary of arguments including __argv into a list
- for passing to the function.
- """
-- args = inspect.getargspec(func)[0]
-+ args = inspect.getfullargspec(func)[0]
- return [kwargs[arg] for arg in args] + kwargs["__args"]
-
-