summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/buildbot-worker/Manifest4
-rw-r--r--dev-util/buildbot-worker/buildbot-worker-0.9.12.ebuild134
-rw-r--r--dev-util/buildbot-worker/buildbot-worker-1.3.0.ebuild134
-rw-r--r--dev-util/buildbot-worker/buildbot-worker-2.8.0.ebuild (renamed from dev-util/buildbot-worker/buildbot-worker-1.1.2.ebuild)42
-rw-r--r--dev-util/buildbot-worker/buildbot-worker-9999.ebuild13
5 files changed, 22 insertions, 305 deletions
diff --git a/dev-util/buildbot-worker/Manifest b/dev-util/buildbot-worker/Manifest
index 72f72b3635ae..6c7a62608379 100644
--- a/dev-util/buildbot-worker/Manifest
+++ b/dev-util/buildbot-worker/Manifest
@@ -1,4 +1,2 @@
-DIST buildbot-worker-0.9.12.tar.gz 101655 BLAKE2B a73f98ec56bd3ad6d19ad0b9dfa015869fd6115789a7ddcecdebdac8707850715c677ee248668f73035ea5656665973634829f2f97e3e75fe8e1515cb0838b88 SHA512 c2e86bd8818eddc2849626a0c7642169bc91fa2cc1d531977736e53c4ad3c87c3f0cb17d7b9acd137e783ae822f558a19f4668e3cd37e90a8435157485bd1d57
-DIST buildbot-worker-1.1.2.tar.gz 103013 BLAKE2B b44593b71e61fee4037911759fa4f686aaabf5ef4be9efaecd539e88c5fc2ed2059d8dd8d6d1c4b3ba57d3563f79aaa404176529622003070c136803c90beb10 SHA512 3dd3da7e87d667307fca264d91af4671f76c3aad93a0512ae5777bb2e3972efe349968cf72fa17b99e45f2d7cec1ec16b1180c48d296e2702c9548bf858951a7
-DIST buildbot-worker-1.3.0.tar.gz 103765 BLAKE2B a5f06ad6b87442292f9fe0c7935f791d2fdb450db09c9614324f8230d0bec408380a7b1637dc32806259c4de7699b164f20f76d959232a82253f7134749531d7 SHA512 5e59aab6cecf8dd932df0e8063c69fda5613b76a46df63479ff554085275d4a19fb1b5142034bd4245423e99f3e46d45e765b10c3c74a9f28b92b70119fab9e2
DIST buildbot-worker-2.7.0.tar.gz 101075 BLAKE2B 2ee82434f565bef111685712b9b4dd7b0c522de59eefe3eda672827e4bcffae8288c5b9842221b52aa7d5907eeadd4bc5c635382b8c6c4e82977b3c139afdd4b SHA512 bdfce0a7b222fdddbf7830f90c1775e2bded7080e5053b114b7c136b3e114f6c8b26ee4ad802fce66514524e29e863a2f1a4366758c59ebbc6eeadb4b0a271db
+DIST buildbot-worker-2.8.0.tar.gz 102605 BLAKE2B 4cd6d8755803d7649acaf1b45e6632a7a9bddd8a58590a8caa73f686584fedf62d98911a9e148e5a6f34c99b8551cd80c2acbd03fc4f892300cad89a4f68e0b8 SHA512 62f3a72ed7d7ca724b667528e55673c20382ed95abc898dc43e43c5e09bc1d8116eeb2791145097a9b9f7ab2d38a90d974dfbbf5697d8c045a630632ece8512e
diff --git a/dev-util/buildbot-worker/buildbot-worker-0.9.12.ebuild b/dev-util/buildbot-worker/buildbot-worker-0.9.12.ebuild
deleted file mode 100644
index 2fc5d7a0f231..000000000000
--- a/dev-util/buildbot-worker/buildbot-worker-0.9.12.ebuild
+++ /dev/null
@@ -1,134 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-PYTHON_COMPAT=( python3_6 )
-
-EGIT_REPO_URI="https://github.com/buildbot/buildbot.git"
-
-[[ ${PV} == *9999 ]] && inherit git-r3
-inherit readme.gentoo-r1 user distutils-r1
-
-DESCRIPTION="BuildBot Worker (slave) Daemon"
-HOMEPAGE="https://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.org/project/buildbot-worker/"
-
-MY_V="${PV/_p/p}"
-MY_P="${PN}-${MY_V}"
-[[ ${PV} == *9999 ]] || SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-if [[ ${PV} == *9999 ]]; then
- KEYWORDS=""
-else
- KEYWORDS="~amd64"
-fi
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=dev-python/setuptools-21.2.1[${PYTHON_USEDEP}]
- >=dev-python/twisted-17.9.0[${PYTHON_USEDEP}]
- dev-python/future[${PYTHON_USEDEP}]
- !<dev-util/buildbot-0.9.7
-"
-DEPEND="${RDEPEND}
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/setuptools_trial[${PYTHON_USEDEP}]
- )
-"
-
-S="${WORKDIR}/${MY_P}"
-[[ ${PV} == *9999 ]] && S=${S}/slave
-
-pkg_setup() {
- enewuser buildbot
-
- DOC_CONTENTS="The \"buildbot\" user and the \"buildbot_worker\" init script has been added
- to support starting buildbot_worker through Gentoo's init system. To use this,
- execute \"emerge --config =${CATEGORY}/${PF}\" to create a new instance.
- Set up your build worker following the documentation, make sure the
- resulting directories are owned by the \"buildbot\" user and point
- \"${ROOT}etc/conf.d/buildbot_worker.myinstance\" at the right location.
- The scripts can run as a different user if desired."
-}
-
-python_test() {
- distutils_install_for_testing
-
- esetup.py test || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- doman docs/buildbot-worker.1
-
- newconfd "${FILESDIR}/buildbot_worker.confd2" buildbot_worker
- newinitd "${FILESDIR}/buildbot_worker.initd2" buildbot_worker
-
- dodir /var/lib/buildbot_worker
- cp "${FILESDIR}/buildbot.tac.sample" "${D}/var/lib/buildbot_worker"|| die "Install failed!"
-
- readme.gentoo_create_doc
-}
-
-pkg_postinst() {
- readme.gentoo_print_elog
-
- if [[ -n ${REPLACING_VERSIONS} ]]; then
- ewarn
- ewarn "Starting with buildbot-worker-0.9.10-r1, more than one instance of a buildbot_worker"
- ewarn "can be run simultaneously. Note that \"BASEDIR\" in the buildbot_worker configuration file"
- ewarn "is now the common base directory for all instances. If you are migrating from an older"
- ewarn "version, make sure that you copy the current contents of \"BASEDIR\" to a subdirectory."
- ewarn "The name of the subdirectory corresponds to the name of the buildbot_worker instance."
- ewarn "In order to start the service running OpenRC-based systems need to link to the init file:"
- ewarn " ln --symbolic --relative /etc/init.d/buildbot_worker /etc/init.d/buildbot_worker.myinstance"
- ewarn " rc-update add buildbot_worker.myinstance default"
- ewarn " /etc/init.d/buildbot_worker.myinstance start"
- ewarn "Systems using systemd can do the following:"
- ewarn " systemctl enable buildbot_worker@myinstance.service"
- ewarn " systemctl enable buildbot_worker.target"
- ewarn " systemctl start buildbot_worker.target"
- fi
-}
-
-pkg_config() {
- local buildworker_path="/var/lib/buildbot_worker"
- local log_path="/var/log/buildbot_worker"
-
- einfo "This will prepare a new buildbot_worker instance in ${buildworker_path}."
- einfo "Press Control-C to abort."
-
- einfo "Enter the name for the new instance: "
- read instance_name
- [[ -z "${instance_name}" ]] && die "Invalid instance name"
-
- local instance_path="${buildworker_path}/${instance_name}"
- local instance_log_path="${log_path}/${instance_name}"
-
- if [[ -e "${instance_path}" ]]; then
- eerror "The instance with the specified name already exists:"
- eerror "${instance_path}"
- die "Instance already exists"
- fi
-
- if [[ ! -d "${instance_path}" ]]; then
- mkdir --parents "${instance_path}" || die "Unable to create directory ${buildworker_path}"
- fi
- chown --recursive buildbot "${instance_path}" || die "Setting permissions for instance failed"
- cp "${buildworker_path}/buildbot.tac.sample" "${instance_path}/buildbot.tac" \
- || die "Moving sample configuration failed"
- ln --symbolic --relative "/etc/init.d/buildbot_worker" "/etc/init.d/buildbot_worker.${instance_name}" \
- || die "Unable to create link to init file"
-
- if [[ ! -d "${instance_log_path}" ]]; then
- mkdir --parents "${instance_log_path}" || die "Unable to create directory ${instance_log_path}"
- fi
- ln --symbolic --relative "${instance_log_path}/twistd.log" "${instance_path}/twistd.log" \
- || die "Unable to create link to log file"
-
- einfo "Successfully created a buildbot_worker instance at ${instance_path}."
- einfo "To change the default settings edit the buildbot.tac file in this directory."
-}
diff --git a/dev-util/buildbot-worker/buildbot-worker-1.3.0.ebuild b/dev-util/buildbot-worker/buildbot-worker-1.3.0.ebuild
deleted file mode 100644
index a8ac9da44f52..000000000000
--- a/dev-util/buildbot-worker/buildbot-worker-1.3.0.ebuild
+++ /dev/null
@@ -1,134 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-PYTHON_COMPAT=( python3_6 )
-
-EGIT_REPO_URI="https://github.com/buildbot/buildbot.git"
-
-[[ ${PV} == *9999 ]] && inherit git-r3
-inherit readme.gentoo-r1 user distutils-r1
-
-DESCRIPTION="BuildBot Worker (slave) Daemon"
-HOMEPAGE="https://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.org/project/buildbot-worker/"
-
-MY_V="${PV/_p/.post}"
-MY_P="${PN}-${MY_V}"
-[[ ${PV} == *9999 ]] || SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-if [[ ${PV} == *9999 ]]; then
- KEYWORDS=""
-else
- KEYWORDS="~amd64"
-fi
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=dev-python/setuptools-21.2.1[${PYTHON_USEDEP}]
- >=dev-python/twisted-17.9.0[${PYTHON_USEDEP}]
- dev-python/future[${PYTHON_USEDEP}]
- !<dev-util/buildbot-0.9.7
-"
-DEPEND="${RDEPEND}
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/setuptools_trial[${PYTHON_USEDEP}]
- )
-"
-
-S="${WORKDIR}/${MY_P}"
-[[ ${PV} == *9999 ]] && S=${S}/worker
-
-pkg_setup() {
- enewuser buildbot
-
- DOC_CONTENTS="The \"buildbot\" user and the \"buildbot_worker\" init script has been added
- to support starting buildbot_worker through Gentoo's init system. To use this,
- execute \"emerge --config =${CATEGORY}/${PF}\" to create a new instance.
- Set up your build worker following the documentation, make sure the
- resulting directories are owned by the \"buildbot\" user and point
- \"${ROOT}etc/conf.d/buildbot_worker.myinstance\" at the right location.
- The scripts can run as a different user if desired."
-}
-
-python_test() {
- distutils_install_for_testing
-
- esetup.py test || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- doman docs/buildbot-worker.1
-
- newconfd "${FILESDIR}/buildbot_worker.confd2" buildbot_worker
- newinitd "${FILESDIR}/buildbot_worker.initd2" buildbot_worker
-
- dodir /var/lib/buildbot_worker
- cp "${FILESDIR}/buildbot.tac.sample" "${D}/var/lib/buildbot_worker"|| die "Install failed!"
-
- readme.gentoo_create_doc
-}
-
-pkg_postinst() {
- readme.gentoo_print_elog
-
- if [[ -n ${REPLACING_VERSIONS} ]]; then
- ewarn
- ewarn "Starting with buildbot-worker-0.9.10-r1, more than one instance of a buildbot_worker"
- ewarn "can be run simultaneously. Note that \"BASEDIR\" in the buildbot_worker configuration file"
- ewarn "is now the common base directory for all instances. If you are migrating from an older"
- ewarn "version, make sure that you copy the current contents of \"BASEDIR\" to a subdirectory."
- ewarn "The name of the subdirectory corresponds to the name of the buildbot_worker instance."
- ewarn "In order to start the service running OpenRC-based systems need to link to the init file:"
- ewarn " ln --symbolic --relative /etc/init.d/buildbot_worker /etc/init.d/buildbot_worker.myinstance"
- ewarn " rc-update add buildbot_worker.myinstance default"
- ewarn " /etc/init.d/buildbot_worker.myinstance start"
- ewarn "Systems using systemd can do the following:"
- ewarn " systemctl enable buildbot_worker@myinstance.service"
- ewarn " systemctl enable buildbot_worker.target"
- ewarn " systemctl start buildbot_worker.target"
- fi
-}
-
-pkg_config() {
- local buildworker_path="/var/lib/buildbot_worker"
- local log_path="/var/log/buildbot_worker"
-
- einfo "This will prepare a new buildbot_worker instance in ${buildworker_path}."
- einfo "Press Control-C to abort."
-
- einfo "Enter the name for the new instance: "
- read instance_name
- [[ -z "${instance_name}" ]] && die "Invalid instance name"
-
- local instance_path="${buildworker_path}/${instance_name}"
- local instance_log_path="${log_path}/${instance_name}"
-
- if [[ -e "${instance_path}" ]]; then
- eerror "The instance with the specified name already exists:"
- eerror "${instance_path}"
- die "Instance already exists"
- fi
-
- if [[ ! -d "${instance_path}" ]]; then
- mkdir --parents "${instance_path}" || die "Unable to create directory ${buildworker_path}"
- fi
- chown --recursive buildbot "${instance_path}" || die "Setting permissions for instance failed"
- cp "${buildworker_path}/buildbot.tac.sample" "${instance_path}/buildbot.tac" \
- || die "Moving sample configuration failed"
- ln --symbolic --relative "/etc/init.d/buildbot_worker" "/etc/init.d/buildbot_worker.${instance_name}" \
- || die "Unable to create link to init file"
-
- if [[ ! -d "${instance_log_path}" ]]; then
- mkdir --parents "${instance_log_path}" || die "Unable to create directory ${instance_log_path}"
- fi
- ln --symbolic --relative "${instance_log_path}/twistd.log" "${instance_path}/twistd.log" \
- || die "Unable to create link to log file"
-
- einfo "Successfully created a buildbot_worker instance at ${instance_path}."
- einfo "To change the default settings edit the buildbot.tac file in this directory."
-}
diff --git a/dev-util/buildbot-worker/buildbot-worker-1.1.2.ebuild b/dev-util/buildbot-worker/buildbot-worker-2.8.0.ebuild
index a8ac9da44f52..3bd934a50342 100644
--- a/dev-util/buildbot-worker/buildbot-worker-1.1.2.ebuild
+++ b/dev-util/buildbot-worker/buildbot-worker-2.8.0.ebuild
@@ -1,35 +1,32 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
-PYTHON_COMPAT=( python3_6 )
+EAPI="7"
+PYTHON_COMPAT=( python3_{6,7,8} )
-EGIT_REPO_URI="https://github.com/buildbot/buildbot.git"
+DISTUTILS_USE_SETUPTOOLS="rdepend"
-[[ ${PV} == *9999 ]] && inherit git-r3
-inherit readme.gentoo-r1 user distutils-r1
+inherit readme.gentoo-r1 distutils-r1
DESCRIPTION="BuildBot Worker (slave) Daemon"
HOMEPAGE="https://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.org/project/buildbot-worker/"
MY_V="${PV/_p/.post}"
MY_P="${PN}-${MY_V}"
-[[ ${PV} == *9999 ]] || SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-if [[ ${PV} == *9999 ]]; then
- KEYWORDS=""
-else
- KEYWORDS="~amd64"
-fi
+KEYWORDS="~amd64"
+
IUSE="test"
RESTRICT="!test? ( test )"
-RDEPEND=">=dev-python/setuptools-21.2.1[${PYTHON_USEDEP}]
+RDEPEND="
+ acct-user/buildbot
>=dev-python/twisted-17.9.0[${PYTHON_USEDEP}]
dev-python/future[${PYTHON_USEDEP}]
- !<dev-util/buildbot-0.9.7
+ !<dev-util/buildbot-1.0.0
"
DEPEND="${RDEPEND}
test? (
@@ -39,25 +36,18 @@ DEPEND="${RDEPEND}
"
S="${WORKDIR}/${MY_P}"
-[[ ${PV} == *9999 ]] && S=${S}/worker
pkg_setup() {
- enewuser buildbot
-
DOC_CONTENTS="The \"buildbot\" user and the \"buildbot_worker\" init script has been added
to support starting buildbot_worker through Gentoo's init system. To use this,
execute \"emerge --config =${CATEGORY}/${PF}\" to create a new instance.
Set up your build worker following the documentation, make sure the
resulting directories are owned by the \"buildbot\" user and point
- \"${ROOT}etc/conf.d/buildbot_worker.myinstance\" at the right location.
+ \"${ROOT}/etc/conf.d/buildbot_worker.myinstance\" at the right location.
The scripts can run as a different user if desired."
}
-python_test() {
- distutils_install_for_testing
-
- esetup.py test || die "Tests failed under ${EPYTHON}"
-}
+distutils_enable_tests setup.py
python_install_all() {
distutils-r1_python_install_all
@@ -78,8 +68,8 @@ pkg_postinst() {
if [[ -n ${REPLACING_VERSIONS} ]]; then
ewarn
- ewarn "Starting with buildbot-worker-0.9.10-r1, more than one instance of a buildbot_worker"
- ewarn "can be run simultaneously. Note that \"BASEDIR\" in the buildbot_worker configuration file"
+ ewarn "More than one instance of a buildbot_worker can be run simultaneously."
+ ewarn " Note that \"BASEDIR\" in the buildbot_worker configuration file"
ewarn "is now the common base directory for all instances. If you are migrating from an older"
ewarn "version, make sure that you copy the current contents of \"BASEDIR\" to a subdirectory."
ewarn "The name of the subdirectory corresponds to the name of the buildbot_worker instance."
@@ -117,7 +107,7 @@ pkg_config() {
if [[ ! -d "${instance_path}" ]]; then
mkdir --parents "${instance_path}" || die "Unable to create directory ${buildworker_path}"
fi
- chown --recursive buildbot "${instance_path}" || die "Setting permissions for instance failed"
+ chown --recursive buildbot:buildbot "${instance_path}" || die "Setting permissions for instance failed"
cp "${buildworker_path}/buildbot.tac.sample" "${instance_path}/buildbot.tac" \
|| die "Moving sample configuration failed"
ln --symbolic --relative "/etc/init.d/buildbot_worker" "/etc/init.d/buildbot_worker.${instance_name}" \
@@ -125,6 +115,8 @@ pkg_config() {
if [[ ! -d "${instance_log_path}" ]]; then
mkdir --parents "${instance_log_path}" || die "Unable to create directory ${instance_log_path}"
+ chown --recursive buildbot:buildbot "${instance_log_path}" \
+ || die "Setting permissions for instance failed"
fi
ln --symbolic --relative "${instance_log_path}/twistd.log" "${instance_path}/twistd.log" \
|| die "Unable to create link to log file"
diff --git a/dev-util/buildbot-worker/buildbot-worker-9999.ebuild b/dev-util/buildbot-worker/buildbot-worker-9999.ebuild
index be5258cd9984..68c35436d35e 100644
--- a/dev-util/buildbot-worker/buildbot-worker-9999.ebuild
+++ b/dev-util/buildbot-worker/buildbot-worker-9999.ebuild
@@ -8,7 +8,7 @@ EGIT_REPO_URI="https://github.com/buildbot/buildbot.git"
DISTUTILS_USE_SETUPTOOLS="rdepend"
-[[ ${PV} == *9999 ]] && inherit git-r3
+inherit git-r3
inherit readme.gentoo-r1 distutils-r1
DESCRIPTION="BuildBot Worker (slave) Daemon"
@@ -16,15 +16,11 @@ HOMEPAGE="https://buildbot.net/ https://github.com/buildbot/buildbot https://pyp
MY_V="${PV/_p/.post}"
MY_P="${PN}-${MY_V}"
-[[ ${PV} == *9999 ]] || SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-if [[ ${PV} == *9999 ]]; then
- KEYWORDS=""
-else
- KEYWORDS="~amd64"
-fi
+KEYWORDS=""
+
IUSE="test"
RESTRICT="!test? ( test )"
@@ -41,8 +37,7 @@ DEPEND="${RDEPEND}
)
"
-S="${WORKDIR}/${MY_P}"
-[[ ${PV} == *9999 ]] && S=${S}/worker
+S="${S}/worker"
pkg_setup() {
DOC_CONTENTS="The \"buildbot\" user and the \"buildbot_worker\" init script has been added