summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/assimp/Manifest1
-rw-r--r--media-libs/assimp/assimp-5.2.4-r1.ebuild67
-rw-r--r--media-libs/assimp/files/assimp-5.2.2-disable-failing-tests.patch52
-rw-r--r--media-libs/assimp/files/assimp-5.2.2-fix-usage-of-incompatible-minizip-data-structure.patch24
-rw-r--r--media-libs/assimp/files/assimp-5.2.4-drop-failing-tests-for-abi_x86_32.patch165
-rw-r--r--media-libs/assimp/files/assimp-5.2.4-update-version.patch34
6 files changed, 0 insertions, 343 deletions
diff --git a/media-libs/assimp/Manifest b/media-libs/assimp/Manifest
index 3810c5ca0704..34611184f6fc 100644
--- a/media-libs/assimp/Manifest
+++ b/media-libs/assimp/Manifest
@@ -1,2 +1 @@
-DIST assimp-5.2.4.tar.gz 49613683 BLAKE2B d99243ce84a76ea237becd0b0982619e8f948ebc75784d8ea35e3800b9ca5084291fa58484433e4f2a7c3cd7ec2869033cf458daf94ee0fc4fe3283592721e73 SHA512 ee988b1806b46c78f97bb5b25237a3f56a7028ed37898fb9b243e379e29e8bfd29e4dffc616566941ed9bdcf502bd30568904ad2ef2ef7d0f63b40daefdc66bf
DIST assimp-5.2.5.tar.gz 49543936 BLAKE2B 77e0eecd1307646211a86244a371e24401dffd03dceb569acdd63751cdb38bd169c8b12c942efd2e77b5f541653f2775739150b9fe352b8c903dcc4fe7bccca8 SHA512 ac0dc4243f9d1ff077966f0037187b4374075ac97e75e1a3cd6bdc1caf5f8e4d40953d9a8a316480969c09524d87daa9d3ed75e6ac6f037dd5b1c5f25fce3afb
diff --git a/media-libs/assimp/assimp-5.2.4-r1.ebuild b/media-libs/assimp/assimp-5.2.4-r1.ebuild
deleted file mode 100644
index 135d40e3ca95..000000000000
--- a/media-libs/assimp/assimp-5.2.4-r1.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="Importer library to import assets from 3D files"
-HOMEPAGE="https://github.com/assimp/assimp"
-SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/5.2.4"
-KEYWORDS="amd64 ~arm arm64 ~riscv x86"
-IUSE="samples test"
-
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-libs/boost:=
- sys-libs/zlib[minizip]
- samples? (
- media-libs/freeglut
- virtual/opengl
- x11-libs/libX11
- )
-"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-5.2.2-fix-usage-of-incompatible-minizip-data-structure.patch
- "${FILESDIR}"/${PN}-5.2.2-disable-failing-tests.patch
- "${FILESDIR}"/${P}-update-version.patch
-)
-
-DOCS=( CodeConventions.md Readme.md )
-
-src_prepare() {
- if use x86 ; then
- eapply "${FILESDIR}"/${P}-drop-failing-tests-for-abi_x86_32.patch
- fi
-
- cmake_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DASSIMP_ASAN=OFF
- -DASSIMP_BUILD_DOCS=OFF
- -DASSIMP_BUILD_SAMPLES=$(usex samples)
- -DASSIMP_BUILD_TESTS=$(usex test)
- -DASSIMP_INJECT_DEBUG_POSTFIX=OFF
- -DASSIMP_IGNORE_GIT_HASH=ON
- -DASSIMP_UBSAN=OFF
- -DASSIMP_WARNINGS_AS_ERRORS=OFF
- )
-
- if use samples; then
- mycmakeargs+=( -DOpenGL_GL_PREFERENCE="GLVND" )
- fi
-
- cmake_src_configure
-}
-
-src_test() {
- "${BUILD_DIR}/bin/unit" || die
-}
diff --git a/media-libs/assimp/files/assimp-5.2.2-disable-failing-tests.patch b/media-libs/assimp/files/assimp-5.2.2-disable-failing-tests.patch
deleted file mode 100644
index 3c423ac5107a..000000000000
--- a/media-libs/assimp/files/assimp-5.2.2-disable-failing-tests.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-From 8bff102329461e88a879472672b584585c6fbd7e Mon Sep 17 00:00:00 2001
-From: Bernd Waibel <waebbl-gentoo@posteo.net>
-Date: Fri, 11 Mar 2022 11:24:13 +0100
-Subject: [PATCH] disable failing tests
-
-Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net>
---- a/test/unit/AssimpAPITest_aiMatrix4x4.cpp
-+++ b/test/unit/AssimpAPITest_aiMatrix4x4.cpp
-@@ -249,11 +249,3 @@ TEST_F(AssimpAPITest_aiMatrix4x4, aiMatrix4ScalingTest) {
- aiMatrix4Scaling(&result_c, &scaling);
- EXPECT_EQ(result_cpp, result_c);
- }
--
--TEST_F(AssimpAPITest_aiMatrix4x4, aiMatrix4FromToTest) {
-- // Use predetermined vectors to prevent running into division by zero.
-- const auto from = aiVector3D(1,2,1).Normalize(), to = aiVector3D(-1,1,1).Normalize();
-- aiMatrix4x4::FromToMatrix(from, to, result_cpp);
-- aiMatrix4FromTo(&result_c, &from, &to);
-- EXPECT_EQ(result_cpp, result_c);
--}
---- a/test/unit/AssimpAPITest_aiQuaternion.cpp
-+++ b/test/unit/AssimpAPITest_aiQuaternion.cpp
-@@ -84,13 +84,6 @@ TEST_F(AssimpAPITest_aiQuaternion, aiQuaternionFromAxisAngleTest) {
- EXPECT_EQ(result_cpp, result_c);
- }
-
--TEST_F(AssimpAPITest_aiQuaternion, aiQuaternionFromNormalizedQuaternionTest) {
-- const auto qvec3 = random_unit_vec3();
-- result_cpp = aiQuaternion(qvec3);
-- aiQuaternionFromNormalizedQuaternion(&result_c, &qvec3);
-- EXPECT_EQ(result_cpp, result_c);
--}
--
- TEST_F(AssimpAPITest_aiQuaternion, aiQuaternionAreEqualTest) {
- result_c = result_cpp = random_quat();
- EXPECT_EQ(result_cpp == result_c,
---- a/test/unit/utVersion.cpp
-+++ b/test/unit/utVersion.cpp
-@@ -68,10 +68,6 @@ TEST_F( utVersion, aiGetCompileFlagsTest ) {
- EXPECT_NE( aiGetCompileFlags(), 0U );
- }
-
--TEST_F( utVersion, aiGetVersionRevisionTest ) {
-- EXPECT_NE( aiGetVersionRevision(), 0U );
--}
--
- TEST_F( utVersion, aiGetBranchNameTest ) {
- EXPECT_NE( nullptr, aiGetBranchName() );
- }
---
-2.35.1
-
diff --git a/media-libs/assimp/files/assimp-5.2.2-fix-usage-of-incompatible-minizip-data-structure.patch b/media-libs/assimp/files/assimp-5.2.2-fix-usage-of-incompatible-minizip-data-structure.patch
deleted file mode 100644
index 6d48161646ef..000000000000
--- a/media-libs/assimp/files/assimp-5.2.2-fix-usage-of-incompatible-minizip-data-structure.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From https://github.com/assimp/assimp/issues/4334#issue-1097591121
-From: Brecht Sanders (@brechtsanders)
-Date: Fri, 11 Mar 2022 10:01:15 +0100
-Subject: [PATCH] fix usage of incompatible minizip data structure
-
-Suggested-by: Brecht Sanders (@brechtsanders)
-Bug: https://github.com/assimp/assimp/issues/4334
-
-Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net>
---- a/code/Common/ZipArchiveIOSystem.cpp
-+++ b/code/Common/ZipArchiveIOSystem.cpp
-@@ -196,7 +196,9 @@ zlib_filefunc_def IOSystem2Unzip::get(IOSystem *pIOHandler) {
- zlib_filefunc_def mapping;
-
- mapping.zopen_file = (open_file_func)open;
-+#ifdef ZOPENDISK64
- mapping.zopendisk_file = (opendisk_file_func)opendisk;
-+#endif
- mapping.zread_file = (read_file_func)read;
- mapping.zwrite_file = (write_file_func)write;
- mapping.ztell_file = (tell_file_func)tell;
---
-2.35.1
-
diff --git a/media-libs/assimp/files/assimp-5.2.4-drop-failing-tests-for-abi_x86_32.patch b/media-libs/assimp/files/assimp-5.2.4-drop-failing-tests-for-abi_x86_32.patch
deleted file mode 100644
index fba27be45315..000000000000
--- a/media-libs/assimp/files/assimp-5.2.4-drop-failing-tests-for-abi_x86_32.patch
+++ /dev/null
@@ -1,165 +0,0 @@
-https://bugs.gentoo.org/840767
-https://github.com/assimp/assimp/issues/4438
-
-From 48cb5451383855755debfc17cb5e3428cba2d94e Mon Sep 17 00:00:00 2001
-From: Bernd Waibel <waebbl-gentoo@posteo.net>
-Date: Sat, 21 May 2022 17:37:04 +0200
-Subject: [PATCH] drop failing tests for abi_x86_32
-
-Drop two additional test wrt 5.2.3
-Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net>
---- a/test/unit/AssimpAPITest_aiMatrix3x3.cpp
-+++ b/test/unit/AssimpAPITest_aiMatrix3x3.cpp
-@@ -68,13 +68,6 @@ TEST_F(AssimpAPITest_aiMatrix3x3, aiMatrix3FromMatrix4Test) {
- EXPECT_EQ(result_cpp, result_c);
- }
-
--TEST_F(AssimpAPITest_aiMatrix3x3, aiMatrix3FromQuaternionTest) {
-- const auto q = random_quat();
-- result_cpp = q.GetMatrix();
-- aiMatrix3FromQuaternion(&result_c, &q);
-- EXPECT_EQ(result_cpp, result_c);
--}
--
- TEST_F(AssimpAPITest_aiMatrix3x3, aiMatrix3AreEqualTest) {
- result_c = result_cpp = random_mat3();
- EXPECT_EQ(result_cpp == result_c,
-@@ -127,14 +120,6 @@ TEST_F(AssimpAPITest_aiMatrix3x3, aiMatrix3RotationZTest) {
- EXPECT_EQ(result_cpp, result_c);
- }
-
--TEST_F(AssimpAPITest_aiMatrix3x3, aiMatrix3FromRotationAroundAxisTest) {
-- const float angle(RandPI.next());
-- const auto axis = random_unit_vec3();
-- aiMatrix3x3::Rotation(angle, axis, result_cpp);
-- aiMatrix3FromRotationAroundAxis(&result_c, &axis, angle);
-- EXPECT_EQ(result_cpp, result_c);
--}
--
- TEST_F(AssimpAPITest_aiMatrix3x3, aiMatrix3TranslationTest) {
- const auto axis = random_vec2();
- aiMatrix3x3::Translation(axis, result_cpp);
---- a/test/unit/AssimpAPITest_aiMatrix4x4.cpp
-+++ b/test/unit/AssimpAPITest_aiMatrix4x4.cpp
-@@ -78,15 +78,6 @@ TEST_F(AssimpAPITest_aiMatrix4x4, aiMatrix4FromMatrix3Test) {
- EXPECT_EQ(result_cpp, result_c);
- }
-
--TEST_F(AssimpAPITest_aiMatrix4x4, aiMatrix4FromScalingQuaternionPositionTest) {
-- const aiVector3D s = random_vec3();
-- const aiQuaternion q = random_quat();
-- const aiVector3D t = random_vec3();
-- result_cpp = aiMatrix4x4(s, q, t);
-- aiMatrix4FromScalingQuaternionPosition(&result_c, &s, &q, &t);
-- EXPECT_EQ(result_cpp, result_c);
--}
--
- TEST_F(AssimpAPITest_aiMatrix4x4, aiMatrix4AddTest) {
- const aiMatrix4x4 temp = random_mat4();
- result_c = result_cpp = random_mat4();
-@@ -135,12 +126,6 @@ TEST_F(AssimpAPITest_aiMatrix4x4, aiMatrix4InverseTest) {
- EXPECT_EQ(result_cpp, result_c);
- }
-
--TEST_F(AssimpAPITest_aiMatrix4x4, aiMatrix4DeterminantTest) {
-- result_c = result_cpp = random_mat4();
-- EXPECT_EQ(result_cpp.Determinant(),
-- aiMatrix4Determinant(&result_c));
--}
--
- TEST_F(AssimpAPITest_aiMatrix4x4, aiMatrix4IsIdentityTest) {
- EXPECT_EQ(result_cpp.IsIdentity(),
- (bool)aiMatrix4IsIdentity(&result_c));
-@@ -228,14 +213,6 @@ TEST_F(AssimpAPITest_aiMatrix4x4, aiMatrix4RotationZTest) {
- EXPECT_EQ(result_cpp, result_c);
- }
-
--TEST_F(AssimpAPITest_aiMatrix4x4, aiMatrix4FromRotationAroundAxisTest) {
-- const float angle(RandPI.next());
-- const auto axis = random_unit_vec3();
-- aiMatrix4x4::Rotation(angle, axis, result_cpp);
-- aiMatrix4FromRotationAroundAxis(&result_c, &axis, angle);
-- EXPECT_EQ(result_cpp, result_c);
--}
--
- TEST_F(AssimpAPITest_aiMatrix4x4, aiMatrix4TranslationTest) {
- const auto axis = random_vec3();
- aiMatrix4x4::Translation(axis, result_cpp);
---- a/test/unit/AssimpAPITest_aiQuaternion.cpp
-+++ b/test/unit/AssimpAPITest_aiQuaternion.cpp
-@@ -54,19 +54,6 @@ protected:
- aiQuaternion result_c, result_cpp;
- };
-
--TEST_F(AssimpAPITest_aiQuaternion, aiCreateQuaternionFromMatrixTest) {
-- // Use a predetermined transformation matrix
-- // to prevent running into division by zero.
-- aiMatrix3x3 m, r;
-- aiMatrix3x3::Translation(aiVector2D(14,-25), m);
-- aiMatrix3x3::RotationZ(Math::aiPi<float>() / 4.0f, r);
-- m = m * r;
--
-- result_cpp = aiQuaternion(m);
-- aiCreateQuaternionFromMatrix(&result_c, &m);
-- EXPECT_EQ(result_cpp, result_c);
--}
--
- TEST_F(AssimpAPITest_aiQuaternion, aiQuaternionFromEulerAnglesTest) {
- const float x(RandPI.next()),
- y(RandPI.next()),
---- a/test/unit/AssimpAPITest_aiVector2D.cpp
-+++ b/test/unit/AssimpAPITest_aiVector2D.cpp
-@@ -67,28 +67,6 @@ TEST_F(AssimpAPITest_aiVector2D, aiVector2AreEqualEpsilonTest) {
- (bool)aiVector2AreEqualEpsilon(&result_cpp, &result_c, Epsilon));
- }
-
--TEST_F(AssimpAPITest_aiVector2D, aiVector2AddTest) {
-- result_c = result_cpp = random_vec2();
-- result_cpp += temp;
-- aiVector2Add(&result_c, &temp);
-- EXPECT_EQ(result_cpp, result_c);
--}
--
--TEST_F(AssimpAPITest_aiVector2D, aiVector2SubtractTest) {
-- result_c = result_cpp = random_vec2();
-- result_cpp -= temp;
-- aiVector2Subtract(&result_c, &temp);
-- EXPECT_EQ(result_cpp, result_c);
--}
--
--TEST_F(AssimpAPITest_aiVector2D, aiVector2ScaleTest) {
-- const float FACTOR = RandNonZero.next();
-- result_c = result_cpp = random_vec2();
-- result_cpp *= FACTOR;
-- aiVector2Scale(&result_c, FACTOR);
-- EXPECT_EQ(result_cpp, result_c);
--}
--
- TEST_F(AssimpAPITest_aiVector2D, aiVector2SymMulTest) {
- result_c = result_cpp = random_vec2();
- result_cpp = result_cpp.SymMul(temp);
-@@ -96,21 +74,6 @@ TEST_F(AssimpAPITest_aiVector2D, aiVector2SymMulTest) {
- EXPECT_EQ(result_cpp, result_c);
- }
-
--TEST_F(AssimpAPITest_aiVector2D, aiVector2DivideByScalarTest) {
-- const float DIVISOR = RandNonZero.next();
-- result_c = result_cpp = random_vec2();
-- result_cpp /= DIVISOR;
-- aiVector2DivideByScalar(&result_c, DIVISOR);
-- EXPECT_EQ(result_cpp, result_c);
--}
--
--TEST_F(AssimpAPITest_aiVector2D, aiVector2DivideByVectorTest) {
-- result_c = result_cpp = random_vec2();
-- result_cpp = result_cpp / temp;
-- aiVector2DivideByVector(&result_c, &temp);
-- EXPECT_EQ(result_cpp, result_c);
--}
--
- TEST_F(AssimpAPITest_aiVector2D, aiVector2LengthTest) {
- result_c = result_cpp = random_vec2();
- EXPECT_EQ(result_cpp.Length(), aiVector2Length(&result_c));
---
-2.35.1
-
diff --git a/media-libs/assimp/files/assimp-5.2.4-update-version.patch b/media-libs/assimp/files/assimp-5.2.4-update-version.patch
deleted file mode 100644
index cc70165bc2e0..000000000000
--- a/media-libs/assimp/files/assimp-5.2.4-update-version.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-https://github.com/assimp/assimp/issues/4655
-https://github.com/assimp/assimp/pull/4656
-
-From 304b0f61d7c9ef7e2e5ca2eed185b32a2951aa90 Mon Sep 17 00:00:00 2001
-From: Bernd Waibel <waebbl-gentoo@posteo.net>
-Date: Sat, 30 Jul 2022 09:39:12 +0200
-Subject: [PATCH] update version
-
-Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net>
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -56,7 +56,7 @@ IF(ASSIMP_HUNTER_ENABLED)
- add_definitions(-DASSIMP_USE_HUNTER)
- ENDIF()
-
--PROJECT(Assimp VERSION 5.2.0)
-+PROJECT(Assimp VERSION 5.2.4)
-
- # All supported options ###############################################
-
---- a/test/unit/utVersion.cpp
-+++ b/test/unit/utVersion.cpp
-@@ -61,7 +61,7 @@ TEST_F( utVersion, aiGetVersionMajorTest ) {
- }
-
- TEST_F( utVersion, aiGetVersionPatchTest ) {
-- EXPECT_EQ(aiGetVersionPatch(), 0U );
-+ EXPECT_EQ(aiGetVersionPatch(), 4U );
- }
-
- TEST_F( utVersion, aiGetCompileFlagsTest ) {
---
-2.35.1
-