summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pycuda/Manifest1
-rw-r--r--dev-python/pycuda/pycuda-2018.1.1.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/dev-python/pycuda/Manifest b/dev-python/pycuda/Manifest
index 1c8c7530d163..2f14ffb0735a 100644
--- a/dev-python/pycuda/Manifest
+++ b/dev-python/pycuda/Manifest
@@ -3,3 +3,4 @@ DIST pycuda-2013.1.1.tar.gz 1586425 BLAKE2B 2d566de0bf5ee5d231f8f7089bd2921f6790
DIST pycuda-2014.1.tar.gz 1588986 BLAKE2B 70baa81e8d1b77bcab73eeccf4d38dbe7cea1a8dcd73da4363eaecb87b68eb72b5c96733637eb5082ae81bff2aa264427c1415b9660df5cd95693d1eedc6250a SHA512 57e333941c472feea6974e583f9d27f7f5083011bd8a7cc0bc31d27032885a130f1f57a16b0730696c607b9dca32ad84b96c984cd82351800ec854acdfa8fe9f
DIST pycuda-2016.1.2.tar.gz 1603373 BLAKE2B 35a5972cd4280cace9375314635131b4e8f0f397f0a3f799fd537c13fc2190ee183ab3b2248487f0c79a15a06031776b9c3bbff9ce2545090590d004ff97f0a4 SHA512 7a1a9d6723651bdc6f584de884c46bbaa17970e622b4d800c7f36ff57817807a51c7e4aa0a40872e46fc1243087af6dda07489bb60b6a33f52740a4d7a9e69a7
DIST pycuda-2017.1.tar.gz 1608187 BLAKE2B 483bfd8e2da6d1c2dee9f1b5512e3f8120b29aa87d5fab49d7b1b738e9949aba14f87b102c5ff04cd2f2061c6c64c5036fdea71129e35505cce00ce76b6943aa SHA512 ce3de28de613352bec4efb86ffaa055f92ccd0c758b903aecc60af5b84f0f0643d04a869d6a23ce329c3d33670cfb266ad69c784ba917a190a11bdfea1fe6690
+DIST pycuda-2018.1.1.tar.gz 1612853 BLAKE2B 7afbcc33891da96d726f07f1686bfb9a28b4a5ce3dfc754707166556153f91a0fbc3454d50ca678ac56b71e8dc15e8f7b797e8ff025e42aa9eed2eaaa797d952 SHA512 cb93855cf3cee6650ba0564bccce73c2f59ecbd579235eb3623ec32dde8d9247216e756b1342a876fc7d37c0159e741f5f626a86f2e7ab11c4b03c7a4e581a28
diff --git a/dev-python/pycuda/pycuda-2018.1.1.ebuild b/dev-python/pycuda/pycuda-2018.1.1.ebuild
new file mode 100644
index 000000000000..db9fad22bfa6
--- /dev/null
+++ b/dev-python/pycuda/pycuda-2018.1.1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit cuda distutils-r1
+
+DESCRIPTION="Python wrapper for NVIDIA CUDA"
+HOMEPAGE="https://mathema.tician.de/software/pycuda/ https://pypi.org/project/pycuda/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples opengl test"
+
+RDEPEND="
+ dev-libs/boost:=[python,${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/pytools-2013[${PYTHON_USEDEP}]
+ dev-util/nvidia-cuda-toolkit
+ x11-drivers/nvidia-drivers
+ opengl? ( virtual/opengl )"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}] )"
+
+# We need write acccess /dev/nvidia0 and /dev/nvidiactl and the portage
+# user is (usually) not in the video group
+RESTRICT="userpriv"
+
+python_prepare_all() {
+ cuda_sanitize
+ sed -e "s:'--preprocess':\'--preprocess\', \'--compiler-bindir=$(cuda_gccdir)\':g" \
+ -e "s:\"--cubin\":\'--cubin\', \'--compiler-bindir=$(cuda_gccdir)\':g" \
+ -e "s:/usr/include/pycuda:${S}/src/cuda:g" \
+ -i pycuda/compiler.py || die
+
+ touch siteconf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_configure() {
+ mkdir -p "${BUILD_DIR}" || die
+ cd "${BUILD_DIR}" || die
+ "${EPYTHON}" "${S}"/configure.py \
+ --boost-inc-dir="${EPREFIX}/usr/include" \
+ --boost-lib-dir="${EPREFIX}/usr/$(get_libdir)" \
+ --boost-python-libname=boost_python-$(echo ${EPYTHON} | sed 's/python//')-mt \
+ --boost-thread-libname=boost_thread-mt \
+ --cuda-root="${EPREFIX}/opt/cuda" \
+ --cudadrv-lib-dir="${EPREFIX}/usr/$(get_libdir)" \
+ --cudart-lib-dir="${EPREFIX}/opt/cuda/$(get_libdir)" \
+ --cuda-inc-dir="${EPREFIX}/opt/cuda/include" \
+ --no-use-shipped-boost \
+ $(usex opengl --cuda-enable-gl "") || die
+}
+
+src_test() {
+ # we need write access to this to run the tests
+ addwrite /dev/nvidia0
+ addwrite /dev/nvidiactl
+ addwrite /dev/nvidia-uvm
+ addwrite /dev/nvidia-uvm-tools
+ python_test() {
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+ }
+ distutils-r1_src_test
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+
+ fi
+}