summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-apps/jekyll/Manifest1
-rw-r--r--www-apps/jekyll/jekyll-4.2.0-r1.ebuild93
2 files changed, 0 insertions, 94 deletions
diff --git a/www-apps/jekyll/Manifest b/www-apps/jekyll/Manifest
index d45493d18823..fcd44e6a0371 100644
--- a/www-apps/jekyll/Manifest
+++ b/www-apps/jekyll/Manifest
@@ -1,2 +1 @@
-DIST jekyll-4.2.0.tar.gz 1412419 BLAKE2B 351852b52abc227f8e1eedeeef0871a593d66ffc95f4ed644441f81e841582ab9f393b206f049107daa7e9deaa63d36359ff8d0b47c69b629dda2ea462cd0481 SHA512 aee4d832631a285c3d37576b5f3d80073b56afefcb8c8a19a74435ce431b606b5cedc28a02c8e3930f9bc35ab432c952f96e1878b3bee6b9d33fbd01f0a147ec
DIST jekyll-4.2.2.tar.gz 1413485 BLAKE2B 08f4b8b72aecc19d5c8d7bd29897d88edb66ce82b172306ee4fe356a5d2598362f3946354eaa3701f14df0f97e7fc95361b5cc59ec8820703c879bcf05e6331a SHA512 3c72a24a2193493c9e417a05a113fa85889abd8df4d4c114fdc082e40de81d24824e3c4e41ecb3633ef780d4e3f3b0ab091c5f4234326a83b1a8a3da543275ff
diff --git a/www-apps/jekyll/jekyll-4.2.0-r1.ebuild b/www-apps/jekyll/jekyll-4.2.0-r1.ebuild
deleted file mode 100644
index 40520250a3c6..000000000000
--- a/www-apps/jekyll/jekyll-4.2.0-r1.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-USE_RUBY="ruby25 ruby26"
-
-inherit ruby-fakegem
-
-RUBY_FAKEGEM_EXTRADOC="README.markdown History.markdown"
-RUBY_FAKEGEM_EXTRAINSTALL="features"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-RUBY_FAKEGEM_BINDIR="exe"
-
-DESCRIPTION="A simple, blog aware, static site generator"
-HOMEPAGE="https://jekyllrb.com https://github.com/jekyll/jekyll"
-SRC_URI="https://github.com/jekyll/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64"
-IUSE="test"
-
-ruby_add_rdepend "
- >=dev-ruby/addressable-2.4
- >=dev-ruby/colorator-1.0
- >=dev-ruby/em-websocket-0.5
- dev-ruby/i18n:1
- >=dev-ruby/kramdown-2.1:2
- dev-ruby/kramdown-parser-gfm:1
- dev-ruby/liquid:4
- >=dev-ruby/mercenary-0.4.0
- >=dev-ruby/pathutil-0.9
- =dev-ruby/rouge-3*
- >=dev-ruby/safe_yaml-1.0
- >=dev-ruby/terminal-table-1.8:0
- >=www-apps/jekyll-sass-converter-2.0
- >=www-apps/jekyll-watch-2.2.1-r1
-"
-
-ruby_add_bdepend "
- test? (
- >=dev-ruby/classifier-reborn-2.1.0
- dev-ruby/httpclient
- dev-ruby/kramdown-syntax-coderay
- dev-ruby/launchy
- dev-ruby/nokogiri
- >=dev-ruby/rdiscount-2.0
- >=dev-ruby/redcarpet-3.2.3
- dev-ruby/rspec-mocks
- >=dev-ruby/shoulda-3
- dev-ruby/test-unit:2
- www-apps/jekyll-coffeescript
- )
-"
-
-all_ruby_prepare() {
- eapply "${FILESDIR}"/jekyll-3.6.0-test-helper.patch
-
- # Drop tests requiring bundler
- sed -i -e '/bundle_message/d' test/test_new_command.rb || die
- rm test/test_plugin_manager.rb || die
-
- # Replace git command in gemspec
- sed -e 's/git ls-files/find -not -type d -print/' \
- -e 's:_relative ": "./:' \
- -i $RUBY_FAKEGEM_GEMSPEC || die
-
- # FIXMEs:
- # fails to find fixtures because this requires bundler
- rm test/test_theme.rb || die
- rm test/test_theme_assets_reader.rb || die
- sed -i -e '/^ should.*theme/,/^ end$/d' \
- -e '/^ should.*theme/,/^ end$/d' test/test_site.rb || die
- sed -i -e '/context "with a theme"/,/^ end/ s:^:#:' test/test_layout_reader.rb || die
- sed -i -e '/normalize paths of rendered items/askip "test-theme"' test/test_liquid_renderer.rb || die
- # partially requires 'toml'
- rm test/test_configuration.rb || die
- # pygments tests fail because of line numbering
- sed -i -e '/^ context.*pygments/,/^ end$/d' test/test_tags.rb || die
- #sed -i -e '/^ context.*pygments/,/^ end$/d' test/test_redcarpet.rb || die
-
- # Tries to use bundler and install packages.
- rm -f test/test_new_command.rb || die
-}
-
-src_test() {
- local -x JEKYLL_NO_BUNDLER_REQUIRE=true
-
- ruby-ng_src_test
-}