summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/nbwmon/nbwmon-0.5.2.ebuild23
1 files changed, 11 insertions, 12 deletions
diff --git a/net-analyzer/nbwmon/nbwmon-0.5.2.ebuild b/net-analyzer/nbwmon/nbwmon-0.5.2.ebuild
index f2c7742f396c..613256373c42 100644
--- a/net-analyzer/nbwmon/nbwmon-0.5.2.ebuild
+++ b/net-analyzer/nbwmon/nbwmon-0.5.2.ebuild
@@ -1,27 +1,26 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils toolchain-funcs
+EAPI=7
+
+inherit toolchain-funcs
DESCRIPTION="ncurses bandwidth monitor"
-HOMEPAGE="http://causes.host.funtoo.org/?p=nbwmon https://github.com/causes-/nbwmon"
+HOMEPAGE="https://github.com/causes-/nbwmon"
SRC_URI="https://github.com/causes-/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-RDEPEND="
- sys-libs/ncurses
-"
-DEPEND="
- ${RDEPEND}
- virtual/pkgconfig
-"
+RDEPEND="sys-libs/ncurses"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.5.2-tinfo.patch )
src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.5.2-tinfo.patch
+ default
tc-export CC PKG_CONFIG
}