summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/consul/consul-0.6.4.ebuild2
-rw-r--r--app-admin/consul/consul-0.7.0.ebuild2
-rw-r--r--app-admin/consul/files/consul.logrotated8
3 files changed, 12 insertions, 0 deletions
diff --git a/app-admin/consul/consul-0.6.4.ebuild b/app-admin/consul/consul-0.6.4.ebuild
index 89b6d5420968..760b1a094971 100644
--- a/app-admin/consul/consul-0.6.4.ebuild
+++ b/app-admin/consul/consul-0.6.4.ebuild
@@ -164,6 +164,8 @@ src_install() {
newinitd "${FILESDIR}/consul.initd" "${PN}"
newconfd "${FILESDIR}/consul.confd" "${PN}"
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/${PN}.logrotated" "${PN}"
systemd_dounit "${FILESDIR}/consul.service"
find "${WORKDIR}"/src/${GO_PN} -mindepth 1 -maxdepth 1 -type f -delete || die
diff --git a/app-admin/consul/consul-0.7.0.ebuild b/app-admin/consul/consul-0.7.0.ebuild
index dee540ff628a..c3b7b2fc3faa 100644
--- a/app-admin/consul/consul-0.7.0.ebuild
+++ b/app-admin/consul/consul-0.7.0.ebuild
@@ -104,6 +104,8 @@ src_install() {
newinitd "${FILESDIR}/consul.initd" "${PN}"
newconfd "${FILESDIR}/consul.confd" "${PN}"
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/${PN}.logrotated" "${PN}"
systemd_dounit "${FILESDIR}/consul.service"
find "${WORKDIR}"/src/${GO_PN} -mindepth 1 -maxdepth 1 -type f -delete || die
diff --git a/app-admin/consul/files/consul.logrotated b/app-admin/consul/files/consul.logrotated
new file mode 100644
index 000000000000..e27b8aa543d9
--- /dev/null
+++ b/app-admin/consul/files/consul.logrotated
@@ -0,0 +1,8 @@
+/var/log/consul/consul.log {
+ su consul consul
+ missingok
+ size 5M
+ rotate 3
+ compress
+ copytruncate
+}