summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/apt-cacher-ng/apt-cacher-ng-3.2.ebuild118
-rw-r--r--net-misc/apt-cacher-ng/files/initd32
2 files changed, 0 insertions, 150 deletions
diff --git a/net-misc/apt-cacher-ng/apt-cacher-ng-3.2.ebuild b/net-misc/apt-cacher-ng/apt-cacher-ng-3.2.ebuild
deleted file mode 100644
index d04cec3cc611..000000000000
--- a/net-misc/apt-cacher-ng/apt-cacher-ng-3.2.ebuild
+++ /dev/null
@@ -1,118 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit cmake-utils toolchain-funcs user
-
-DESCRIPTION="Yet another caching HTTP proxy for Debian/Ubuntu software packages"
-HOMEPAGE="
- https://www.unix-ag.uni-kl.de/~bloch/acng/
- https://packages.qa.debian.org/a/apt-cacher-ng.html
-"
-LICENSE="BSD-4 ZLIB public-domain"
-SLOT="0"
-SRC_URI="mirror://debian/pool/main/a/${PN}/${PN}_${PV}.orig.tar.xz"
-
-KEYWORDS="~amd64 ~x86"
-IUSE="doc fuse systemd tcpd"
-
-COMMON_DEPEND="
- app-arch/bzip2
- app-arch/xz-utils
- dev-libs/openssl:0=
- sys-libs/zlib
- systemd? (
- sys-apps/systemd
- )
-"
-DEPEND="
- ${COMMON_DEPEND}
- dev-util/cmake
- >sys-devel/gcc-4.8
- virtual/pkgconfig
-"
-RDEPEND="
- ${COMMON_DEPEND}
- dev-lang/perl
- fuse? ( sys-fs/fuse )
- tcpd? ( sys-apps/tcp-wrappers )
-"
-
-S=${WORKDIR}/${P/_}
-
-pkg_pretend() {
- if [[ $(gcc-major-version) -lt 4 ]]; then
- die "GCC 4.8 or greater is required but you have $(gcc-major-version).$(gcc-minor-version)"
- elif [[ $(gcc-major-version) = 4 ]] && [[ $(gcc-minor-version) -lt 8 ]]; then
- die "GCC 4.8 or greater is required but you have $(gcc-major-version).$(gcc-minor-version)"
- fi
-}
-
-pkg_setup() {
- # add new user & group for daemon
- enewgroup ${PN}
- enewuser ${PN} -1 -1 -1 ${PN}
-}
-
-src_configure(){
- mycmakeargs=( "-DCMAKE_INSTALL_PREFIX=/usr" )
- if use fuse; then
- mycmakeargs+=( "-DHAVE_FUSE_25=yes" )
- else
- mycmakeargs+=( "-DHAVE_FUSE_25=no" )
- fi
- if use tcpd; then
- mycmakeargs=( "-DHAVE_LIBWRAP=yes" )
- else
- mycmakeargs=( "-DHAVE_LIBWRAP=no" )
- fi
-
- cmake-utils_src_configure
-}
-
-src_install() {
- pushd ${CMAKE_BUILD_DIR}
- dosbin ${PN}
- if use fuse; then
- dobin acngfs
- fi
- popd
-
- newinitd "${FILESDIR}"/initd-r1 ${PN}
- newconfd "${FILESDIR}"/confd ${PN}
-
- insinto /etc/logrotate.d
- newins "${FILESDIR}"/logrotate ${PN}
-
- doman doc/man/${PN}*
- if use fuse; then
- doman doc/man/acngfs*
- fi
-
- # Documentation
- dodoc doc/README TODO VERSION INSTALL ChangeLog
- if use doc; then
- dodoc doc/*.pdf
- docinto html
- dodoc doc/html/*
- docinto examples/conf
- dodoc conf/*
- fi
-
- # perl daily cron script
- dosbin scripts/expire-caller.pl
- exeinto /etc/cron.daily
- newexe "${FILESDIR}"/cron.daily ${PN}
-
- # default configuration
- insinto /etc/${PN}
- newins "${CMAKE_BUILD_DIR}"/conf/acng.conf ${PN}.conf
- doins $( echo conf/* | sed 's|conf/acng.conf.in||g' )
-
- keepdir /var/log/${PN}
- # Some directories must exists
- keepdir /var/log/${PN}
- fowners -R ${PN}:${PN} \
- /etc/${PN} \
- /var/log/${PN}
-}
diff --git a/net-misc/apt-cacher-ng/files/initd b/net-misc/apt-cacher-ng/files/initd
deleted file mode 100644
index d054b4de76bd..000000000000
--- a/net-misc/apt-cacher-ng/files/initd
+++ /dev/null
@@ -1,32 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-NAME="apt-cacher-ng"
-DAEMON="/usr/sbin/$NAME"
-RUNDIR="/var/run/$NAME"
-PIDFILE="$RUNDIR/$NAME.pid"
-SOCKETFILE="$RUNDIR/$NAME.socket"
-DAEMON_OPTS="$DAEMON_OPTS pidfile=$PIDFILE SocketPath=$SOCKETFILE foreground=0"
-
-depend() {
- use net
-}
-
-start() {
- ebegin "Starting $NAME"
- checkpath -d -m 0755 -o ${NAME}:${NAME} ${RUNDIR}
- start-stop-daemon --start --exec $DAEMON \
- --user $NAME --group $NAME \
- --pidfile $PIDFILE \
- -- $DAEMON_OPTS
- eend $?
-}
-
-stop() {
- ebegin "Stopping $NAME"
- start-stop-daemon --stop --retry 15 --exec $DAEMON \
- --pidfile $PIDFILE
- rm -f $PIDFILE
- eend $?
-}