summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/cmd2/Manifest1
-rw-r--r--dev-python/cmd2/cmd2-2.4.1.ebuild64
-rw-r--r--dev-python/cmd2/files/cmd2-2.4.1-py311.patch26
3 files changed, 0 insertions, 91 deletions
diff --git a/dev-python/cmd2/Manifest b/dev-python/cmd2/Manifest
index 3edbbc44a97c..50e96a260ae0 100644
--- a/dev-python/cmd2/Manifest
+++ b/dev-python/cmd2/Manifest
@@ -1,2 +1 @@
-DIST cmd2-2.4.1.tar.gz 676903 BLAKE2B 10b27d7658ee366d44d5fd13a4daf3adb65537043e0475e4c30b5a3b5e142cae982515f033e52fbd63bbce583ffc64e7b0a032d4cc0bbca76303720ecb2a8232 SHA512 862ff0ed301dc8fd588fb564602b32c9e8dee1dcae9965b0ed4605acc98b63ca5767b28c0030410395fb34ea1a0c7cf966972c19b75b93c1a3a3b90b582279fb
DIST cmd2-2.4.2.tar.gz 677598 BLAKE2B 38b767e70d42125639578a906a6bd0ac737ee1e3be2951b122f91a1a2bfe366ea23db2d7d7350842b667aca7614a3520057f689cb1c253d1c4b11e164c2ee4a1 SHA512 d70d264671db2783526c589199ff74cc70d53a4fbaa1d78636a508dbf8216aefab17f5764bf25b2b86e9c1413e0e61977819fbb0dec59d3209195df522d3fa5f
diff --git a/dev-python/cmd2/cmd2-2.4.1.ebuild b/dev-python/cmd2/cmd2-2.4.1.ebuild
deleted file mode 100644
index d14b273ef06b..000000000000
--- a/dev-python/cmd2/cmd2-2.4.1.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1 virtualx
-
-DESCRIPTION="Extra features for standard library's cmd module"
-HOMEPAGE="
- https://github.com/python-cmd2/cmd2/
- https://pypi.org/project/cmd2/
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ~ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- dev-python/attrs[${PYTHON_USEDEP}]
- >=dev-python/colorama-0.3.7[${PYTHON_USEDEP}]
- >=dev-python/pyperclip-1.6[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/wcwidth[${PYTHON_USEDEP}]
-"
-# pyperclip uses clipboard backends in the following preference order:
-# pygtk, xclip, xsel, klipper, qtpy, pyqt5, pyqt4.
-# klipper is known to be broken in Xvfb, and therefore causes test
-# failures. to avoid them, we must ensure that one of the backends
-# preferred to it is available (i.e. xclip or xsel).
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- || (
- x11-misc/xclip
- x11-misc/xsel
- )
- )
-"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- "${FILESDIR}"/${P}-py311.patch
-)
-
-src_prepare() {
- distutils-r1_src_prepare
- sed -i -e '/--cov/d' setup.cfg || die
-}
-
-src_test() {
- # tests rely on very specific text wrapping...
- local -x COLUMNS=80
- virtx distutils-r1_src_test
-}
-
-python_test() {
- epytest -p no:pytest-qt || die
-}
diff --git a/dev-python/cmd2/files/cmd2-2.4.1-py311.patch b/dev-python/cmd2/files/cmd2-2.4.1-py311.patch
deleted file mode 100644
index c0e9da528a08..000000000000
--- a/dev-python/cmd2/files/cmd2-2.4.1-py311.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From c02bb7dce587886fe380704a8c6a6009eb677a74 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Sat, 21 May 2022 15:41:11 +0200
-Subject: [PATCH] Fixed duplicate subparser name in
- test_add_parser_custom_completer
-
-If I'm not mistaken, the use of the same name for both subparsers was
-not intentional but a typo. In Python 3.11, this is an error and causes
-the test to fail.
-
-Fixes #1228
----
- tests/test_argparse_completer.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/tests/test_argparse_completer.py b/tests/test_argparse_completer.py
-index 135d3de4..14c8c1de 100644
---- a/tests/test_argparse_completer.py
-+++ b/tests/test_argparse_completer.py
-@@ -1371,5 +1371,5 @@ def test_add_parser_custom_completer():
- no_custom_completer_parser = subparsers.add_parser(name="no_custom_completer")
- assert no_custom_completer_parser.get_ap_completer_type() is None # type: ignore[attr-defined]
-
-- custom_completer_parser = subparsers.add_parser(name="no_custom_completer", ap_completer_type=CustomCompleter)
-+ custom_completer_parser = subparsers.add_parser(name="custom_completer", ap_completer_type=CustomCompleter)
- assert custom_completer_parser.get_ap_completer_type() is CustomCompleter # type: ignore[attr-defined]