summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-haskell/hsql-odbc/files/hsql-odbc-1.8.2-cabal22.patch13
-rw-r--r--dev-haskell/hsql-odbc/hsql-odbc-1.8.2.ebuild10
2 files changed, 20 insertions, 3 deletions
diff --git a/dev-haskell/hsql-odbc/files/hsql-odbc-1.8.2-cabal22.patch b/dev-haskell/hsql-odbc/files/hsql-odbc-1.8.2-cabal22.patch
new file mode 100644
index 000000000000..1c6c599b9cd7
--- /dev/null
+++ b/dev-haskell/hsql-odbc/files/hsql-odbc-1.8.2-cabal22.patch
@@ -0,0 +1,13 @@
+--- a/Setup.lhs
++++ b/Setup.lhs
+@@ -3,5 +3,10 @@
+ \begin{code}
++{-# LANGUAGE CPP #-}
+ import Distribution.Simple(defaultMainWithHooks ,simpleUserHooks ,preConf)
+ import Distribution.Simple.Setup(ConfigFlags)
++#if MIN_VERSION_Cabal(2,2,0)
++import Distribution.PackageDescription.PrettyPrint(writeHookedBuildInfo)
++#else
+ import Distribution.PackageDescription.Parse(writeHookedBuildInfo)
++#endif
+ import Distribution.PackageDescription
diff --git a/dev-haskell/hsql-odbc/hsql-odbc-1.8.2.ebuild b/dev-haskell/hsql-odbc/hsql-odbc-1.8.2.ebuild
index 0e404b50ee54..ed0ebe28b8f6 100644
--- a/dev-haskell/hsql-odbc/hsql-odbc-1.8.2.ebuild
+++ b/dev-haskell/hsql-odbc/hsql-odbc-1.8.2.ebuild
@@ -3,7 +3,7 @@
# ebuild generated by hackport 0.2.13
-EAPI=4
+EAPI=6
CABAL_FEATURES="lib profile haddock hscolour hoogle"
inherit haskell-cabal
@@ -17,8 +17,12 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-RDEPEND=">=dev-haskell/hsql-1.8.2[profile?]
- >=dev-lang/ghc-6.10.1
+RDEPEND=">=dev-haskell/hsql-1.8.2:=[profile?]
+ >=dev-lang/ghc-6.10.1:=
>=dev-db/unixODBC-2.2"
DEPEND="${RDEPEND}
dev-haskell/cabal"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-cabal22.patch
+)