summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-libs/libmbim/Manifest1
-rw-r--r--net-libs/libmbim/libmbim-1.28.4.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/net-libs/libmbim/Manifest b/net-libs/libmbim/Manifest
index a5dbff631cc7..b5babf8997f7 100644
--- a/net-libs/libmbim/Manifest
+++ b/net-libs/libmbim/Manifest
@@ -1 +1,2 @@
DIST libmbim-1.26.4.tar.xz 566188 BLAKE2B 96fb932e89455364eec39d879256eb10efd4fafc18c0dc69619b3a73cea1e62e3ea50b828c2785082e6422c39d8775c9bc1c084db3aaafdf054b1e7aa7d6929f SHA512 a530a3611aa353d7b7a4a3d845a8a8b08e508004f44e9bc63a4c04729589397e264a5dca499ebb7c57f135e6848909d78124c4799bd932c24271c57824c3b5d8
+DIST libmbim-1.28.4.tar.bz2 213993 BLAKE2B 86418182fea2ed50d6b606b898e58f0511ecc5ed4be36748678befa3c005d37a2364db6f4f5537f6a616015f635bb77cfcae282b328b1dd3f5807eae360e93a7 SHA512 f6ac196106e70c790727438a4f42c14b3f8e82dc96b9ac244fbe44b9173132d9562dd6250a51bbf21fc3b84a2a059ae9d7d02d08cac5ba5775715507a64d66d2
diff --git a/net-libs/libmbim/libmbim-1.28.4.ebuild b/net-libs/libmbim/libmbim-1.28.4.ebuild
new file mode 100644
index 000000000000..b96cccddabb4
--- /dev/null
+++ b/net-libs/libmbim/libmbim-1.28.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{9..12} )
+inherit bash-completion-r1 meson python-any-r1
+
+DESCRIPTION="Mobile Broadband Interface Model (MBIM) modem protocol helper library"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/libmbim/ https://gitlab.freedesktop.org/mobile-broadband/libmbim"
+SRC_URI="https://gitlab.freedesktop.org/mobile-broadband/libmbim/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~x86"
+IUSE="gtk-doc"
+
+RDEPEND="
+ >=dev-libs/glib-2.56:2
+ >=dev-libs/gobject-introspection-0.9.6:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ gtk-doc? ( dev-util/gtk-doc )
+ dev-util/glib-utils
+ sys-apps/help2man
+ virtual/pkgconfig
+"
+
+src_configure() {
+ # Let's avoid BuildRequiring bash-completion, install it manually
+ local emesonargs=(
+ -Dintrospection=true
+ -Dman=true
+ -Dbash_completion=false
+ $(meson_use gtk-doc gtk_doc)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ dobashcomp src/mbimcli/mbimcli
+}