summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/slixmpp/Manifest1
-rw-r--r--dev-python/slixmpp/slixmpp-1.5.2.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/slixmpp/Manifest b/dev-python/slixmpp/Manifest
index df5a662ffbc5..4ea9f8f47eb8 100644
--- a/dev-python/slixmpp/Manifest
+++ b/dev-python/slixmpp/Manifest
@@ -1 +1,2 @@
DIST slixmpp-1.4.2.tar.gz 864608 BLAKE2B 9689b274a9c787174248c094329ea33783627a45ef39708a611013454953de4fa8799ca5a35950a3f3ed49bebf5c56f6f2bea079bcc2a3dce7d2648bfd812371 SHA512 3b3356352af8d7ec8cca15210c0524ce0bb5e313d8c5455bec13e82aec261f6d094a99df9f08642418a0e4abea4ee1ff607e42e1c166b9be1c26534b690c330b
+DIST slixmpp-1.5.2.tar.gz 886383 BLAKE2B 6b5ed074ab182f449bf7d2919c241694ea4ff24567546c50a3d228af7708826fb9bfd89b4fccf8a31ae2909399b57caa752a71c187cffbe133bab13b41da814f SHA512 4f377246526c03ae02ece370ba8c9fa7c26a89eca7a012a1a89b8186b6c226d72287c15a7668ca85bfc8f2200765406dbc0fa9cb0e358c3755f551df8eb0d59f
diff --git a/dev-python/slixmpp/slixmpp-1.5.2.ebuild b/dev-python/slixmpp/slixmpp-1.5.2.ebuild
new file mode 100644
index 000000000000..eb42815f81e4
--- /dev/null
+++ b/dev-python/slixmpp/slixmpp-1.5.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python 3 library for XMPP"
+HOMEPAGE="https://dev.louiz.org/projects/slixmpp"
+LICENSE="MIT"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://lab.louiz.org/poezio/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DEPEND="
+ net-dns/libidn
+"
+RDEPEND="
+ dev-python/aiodns[${PYTHON_USEDEP}]
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/pyasn1-modules[${PYTHON_USEDEP}]
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+ ${DEPEND}
+"
+
+distutils_enable_tests pytest