summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-libs/gsoap/Manifest1
-rw-r--r--net-libs/gsoap/gsoap-2.8.31.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/net-libs/gsoap/Manifest b/net-libs/gsoap/Manifest
index 477e6abb047d..0499f6e511ef 100644
--- a/net-libs/gsoap/Manifest
+++ b/net-libs/gsoap/Manifest
@@ -4,3 +4,4 @@ DIST gsoap_2.8.27.zip 22643224 SHA256 cdd9188f3a00caf14fae54d7cc975227128118e818
DIST gsoap_2.8.28.zip 23729531 SHA256 453b36d97a98b35c2829284219dd09a4d60f073a5b77c658c403961c54cfa328 SHA512 1ada2993ca2fe52ff8337484f1be387a0d74b894c633fb0a947f0c160bf875a17825983c174d6e0d84dc8292964f854638dbd9bb54402a8de618036a7db9623b WHIRLPOOL 5c2255d868b140646d0609d25681dea7cf2861d5ee39c771c84e16af77d4f2b6a8541f93bcf1dcefb642f35571936b63fc69acdcec0ae46de87fc96fb7af75bd
DIST gsoap_2.8.29.zip 24006374 SHA256 a9dacc4f862892df6cf9119d1c5d627af3a864c17f17b6542c560e72070b1381 SHA512 ce79cf52210e8ce34b39dc25931dbdc36bdd770ac01e70583e1e4a2f1006f20d259dd57d02a1baf2f937016c63837b9a9befca3d71f992f7a798a55de70a8c61 WHIRLPOOL a5c884b7c7e9144d293674d4977edbe8fda780003cca554acd08db5aade0f09702b294d69bb67f26f668d3a6f195791f9f6483d4a94df83f09ab79bc8985fb08
DIST gsoap_2.8.30.zip 24060216 SHA256 edd20799656471d330033d6d945e684f988b4e79e009fab6c258c83c07ce2b42 SHA512 a4dfb1b5d1021ef2d37a23fedef21135e019ad4fb8ab6bce2d27e159a2bf71aa1660065300f0c790766bccfa630f3b132bb6142aad9104bb1718a9a92e403e19 WHIRLPOOL 41660292d7e05835c87ee46a90dab1223dbaf931574310223099d5c25bc27f91a345f43a4d05cd36212bc558b70f56d1c052833a59d3c8a1133cbfd50550368e
+DIST gsoap_2.8.31.zip 24083228 SHA256 ca786022130dc6bb33ef7e94913e911e8867a67f4712977cd4ee34e3c9e5e9ca SHA512 607e557ccc488f1dfb5d533078528032530fb01ecdfd489b856110a145bb655f7718797fbca59ab839bb1b7e31319a4682ebdcf723c6b3c7211e4a8b6ecbe21d WHIRLPOOL e9c99d73f8a9357d73a07fc4bc4b17171b30868723547e7d53a1cb6361f3ccfcd1a793a1803b9236008d57c83f508b4cdc5d684c73cb607d61507c851290076d
diff --git a/net-libs/gsoap/gsoap-2.8.31.ebuild b/net-libs/gsoap/gsoap-2.8.31.ebuild
new file mode 100644
index 000000000000..e8c1c2e6b7c7
--- /dev/null
+++ b/net-libs/gsoap/gsoap-2.8.31.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools eutils
+
+MY_P="${PN}-2.8"
+
+DESCRIPTION="A cross-platform open source C and C++ SDK for SOAP/XML Web services"
+HOMEPAGE="http://gsoap2.sourceforge.net"
+SRC_URI="mirror://sourceforge/gsoap2/gsoap_${PV}.zip"
+
+LICENSE="GPL-2 gSOAP"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc debug examples ipv6 libressl gnutls +ssl"
+
+RDEPEND="
+ sys-libs/zlib
+ gnutls? ( net-libs/gnutls )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl )
+ )
+"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ sys-devel/flex
+ sys-devel/bison
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+
+ # Fix Pre-ISO headers
+ eapply "${FILESDIR}/${PN}-2.7.10-fedora-install_soapcpp2_wsdl2h_aux.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=()
+ use ssl || myconf+=( --disable-ssl )
+ use gnutls && myconf+=( --enable-gnutls )
+ use ipv6 && myconf+=( --enable-ipv6 )
+ econf \
+ ${myconf[@]} \
+ $(use_enable debug) \
+ $(use_enable examples samples)
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # yes, we also install the license-file since
+ # it contains info about how to apply the licenses
+ dodoc *.txt
+
+ dohtml changelog.md
+
+ prune_libtool_files --all
+
+ if use examples; then
+ rm -rf gsoap/samples/Makefile* gsoap/samples/*/Makefile* gsoap/samples/*/*.o || die
+ insinto /usr/share/doc/${PF}/examples
+ doins -r gsoap/samples/*
+ fi
+
+ if use doc; then
+ dohtml -r gsoap/doc/*
+ fi
+}