summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/nest_asyncio/nest_asyncio-1.5.1.ebuild15
1 files changed, 12 insertions, 3 deletions
diff --git a/dev-python/nest_asyncio/nest_asyncio-1.5.1.ebuild b/dev-python/nest_asyncio/nest_asyncio-1.5.1.ebuild
index 256fec2c5b5a..cde8a0405f28 100644
--- a/dev-python/nest_asyncio/nest_asyncio-1.5.1.ebuild
+++ b/dev-python/nest_asyncio/nest_asyncio-1.5.1.ebuild
@@ -1,9 +1,9 @@
# Copyright 2020-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -15,4 +15,13 @@ LICENSE="BSD-2"
SLOT="0"
KEYWORDS="amd64 ~arm arm64 ~sparc x86"
-distutils_enable_tests setup.py
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=()
+ [[ ${EPYTHON} == python3.10 ]] && deselect+=(
+ # incorrect args in test itself
+ tests/nest_test.py::NestTest::test_two_run_until_completes_in_one_outer_loop
+ )
+ epytest ${deselect[@]/#/--deselect }
+}