summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-plugins/passff-host/Manifest2
-rw-r--r--www-plugins/passff-host/passff-host-1.2.4.ebuild68
2 files changed, 70 insertions, 0 deletions
diff --git a/www-plugins/passff-host/Manifest b/www-plugins/passff-host/Manifest
index dc0d3ec7ab24..67b1d77bd8f1 100644
--- a/www-plugins/passff-host/Manifest
+++ b/www-plugins/passff-host/Manifest
@@ -1,2 +1,4 @@
DIST passff-host-1.2.3.json 176 BLAKE2B 8eddc19cd0c072d25afff5cfa86a95d960ae7b986727099a04a1d983b887922f9ad77e940a2c80e0838a169afe81fa3f6529a901998bb98a6750ac888a09c264 SHA512 e4a4b90fb5323c6dbec339b9e67a7d546c6d7a95754fe03b3a4d96396c28de1caba3068b4e936ee0ce0997f865c8b5e53a3da1fb34f0123a04c5889302c28911
DIST passff-host-1.2.3.py 3691 BLAKE2B 428573d2493f9ff8ef1dc6c8971508a05afa1bef7e06831462106e8daa98c9bedf63489e6630ff9c441ef981164656932c404ffd47e12a2e1e77a55c3ec4955e SHA512 be01e5ed3974bc0967e0dd102593ea8b4f62a5b4ca3f8f2fa2743f9abb4118334cfd27ecd595ce31dd079831614ebf8d91c5b504ad5ead067c245b921d756ceb
+DIST passff-host-1.2.4.json 176 BLAKE2B 8eddc19cd0c072d25afff5cfa86a95d960ae7b986727099a04a1d983b887922f9ad77e940a2c80e0838a169afe81fa3f6529a901998bb98a6750ac888a09c264 SHA512 e4a4b90fb5323c6dbec339b9e67a7d546c6d7a95754fe03b3a4d96396c28de1caba3068b4e936ee0ce0997f865c8b5e53a3da1fb34f0123a04c5889302c28911
+DIST passff-host-1.2.4.py 4427 BLAKE2B 495947577f9ee7b2e02e42e5200d29896c63234f33dd3576b9d19fb986ac9419685f39c6bfd061fcc3754ab386030a62b08147b0967a6f49ac2be79268ea8e5a SHA512 ddc14a634f5ae33d3dd8db211fbea0e7728eb8fec8bca366b1860f0d92abc019556c1e3643fbcf85e92cbfbe99a4a67dda0c1d9c5651d20676fdd63b3635ffaa
diff --git a/www-plugins/passff-host/passff-host-1.2.4.ebuild b/www-plugins/passff-host/passff-host-1.2.4.ebuild
new file mode 100644
index 000000000000..7a0d38a68576
--- /dev/null
+++ b/www-plugins/passff-host/passff-host-1.2.4.ebuild
@@ -0,0 +1,68 @@
+# Copyright 2018-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit python-single-r1
+
+DESCRIPTION="Host app for the PassFF WebExtension"
+HOMEPAGE="https://github.com/passff/passff-host"
+
+SRC_URI="
+ https://github.com/passff/passff-host/releases/download/${PV}/passff.py -> ${P}.py
+ https://github.com/passff/passff-host/releases/download/${PV}/passff.json -> ${P}.json
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="chrome chromium +firefox vivaldi"
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ || ( chrome chromium firefox vivaldi )
+"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ app-crypt/pinentry
+"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ cp "${DISTDIR}/${P}.json" . || die
+ cp "${DISTDIR}/${P}.py" . || die
+}
+
+src_prepare() {
+ default
+ python_fix_shebang "${P}.py"
+}
+
+src_install() {
+ local target_dirs=()
+
+ use chrome && target_dirs+=( "/etc/opt/chrome/native-messaging-hosts" )
+ use chromium && target_dirs+=( "/etc/chromium/native-messaging-hosts" )
+ use firefox && target_dirs+=( "/usr/$(get_libdir)/mozilla/native-messaging-hosts" )
+ # www-client/firefox-bin compile-time dir is under /usr/lib/
+ use firefox && target_dirs+=( "/usr/lib/mozilla/native-messaging-hosts" )
+ use vivaldi && target_dirs+=( "/etc/vivaldi/native-messaging-hosts" )
+
+ for target_dir in "${target_dirs[@]}"; do
+ sed "s;PLACEHOLDER;${target_dir}/passff.py;g" "${P}.json" > "passff.json" || die
+
+ insinto "${target_dir}"
+ doins passff.json
+ exeinto "${target_dir}"
+ newexe "${P}.py" passff.py
+ done
+}
+
+pkg_postinst() {
+ elog "Make sure to use graphical version of pinentry for ${PN} to work properly"
+ elog "Run 'eselect pinentry list'"
+ elog "And select 'pinentry-qt5' or 'pinentry-gnome'. efl might work too."
+}