summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-plugins/wmcdplay/Manifest1
-rw-r--r--x11-plugins/wmcdplay/files/wmcdplay-ComplexProgramTargetNoMan.patch8
-rw-r--r--x11-plugins/wmcdplay/files/wmcdplay-c++.patch11
-rw-r--r--x11-plugins/wmcdplay/files/wmcdplay-xpmdir.patch10
-rw-r--r--x11-plugins/wmcdplay/wmcdplay-1.0_beta1.ebuild50
5 files changed, 0 insertions, 80 deletions
diff --git a/x11-plugins/wmcdplay/Manifest b/x11-plugins/wmcdplay/Manifest
index 25a3d764e92e..ad79d178d9d4 100644
--- a/x11-plugins/wmcdplay/Manifest
+++ b/x11-plugins/wmcdplay/Manifest
@@ -1,2 +1 @@
-DIST wmcdplay-1.0-beta1.tgz 31919 BLAKE2B 4c2654a13670a892e159c3ad5f1460e8228d76226eccc3e76f09120efa0a9ea6766a69ee40277789b568041b276e2173c624ab548ca2d527ac29179bc49fd81c SHA512 bf771e7b8e46096514dd2060230238cb6875ee36e473b8339650026276b97a83ee6862bcbf55ae8c06e55a5f7070d856e9158154a59778199de96b9f8e5116e0
DIST wmcdplay-1.1.tar.gz 32082 BLAKE2B 5fd8f57aca1d3d53d34a31f9814c132a98241b848ac04e69c367065ea291add5f025598b7b03c44033024d20e24271690cdb38830e56d3795f6232b02f1d81c6 SHA512 db657ee2cf0a1a7e323e1a6fbf2ec70251005b84fb18808661cd44a50b4203786e56e90329d81957d2496a6e79d76e9d87620680186c85e476b7f94d8f234133
diff --git a/x11-plugins/wmcdplay/files/wmcdplay-ComplexProgramTargetNoMan.patch b/x11-plugins/wmcdplay/files/wmcdplay-ComplexProgramTargetNoMan.patch
deleted file mode 100644
index 78aaf3022d19..000000000000
--- a/x11-plugins/wmcdplay/files/wmcdplay-ComplexProgramTargetNoMan.patch
+++ /dev/null
@@ -1,8 +0,0 @@
---- ./Imakefile.org Wed Nov 28 01:18:02 2001
-+++ ./Imakefile Wed Nov 28 01:19:28 2001
-@@ -7,4 +7,4 @@
- SRCS = wmcdplay.cc
- OBJS = wmcdplay.o
-
--ComplexProgramTarget(wmcdplay)
-+ComplexProgramTargetNoMan(wmcdplay)
diff --git a/x11-plugins/wmcdplay/files/wmcdplay-c++.patch b/x11-plugins/wmcdplay/files/wmcdplay-c++.patch
deleted file mode 100644
index a0461c380b4e..000000000000
--- a/x11-plugins/wmcdplay/files/wmcdplay-c++.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -uNr wmcdplay.old/Imakefile wmcdplay/Imakefile
---- wmcdplay.old/Imakefile Sat Sep 5 10:11:26 1998
-+++ wmcdplay/Imakefile Mon Nov 16 18:27:37 1998
-@@ -1,5 +1,7 @@
- DEPLIBS = $(DEPXLIB)
-
-+CC = c++
-+
- LOCAL_LIBRARIES = $(XPMLIB) $(XLIB)
-
- SRCS = wmcdplay.cc
diff --git a/x11-plugins/wmcdplay/files/wmcdplay-xpmdir.patch b/x11-plugins/wmcdplay/files/wmcdplay-xpmdir.patch
deleted file mode 100644
index 084a4597d19a..000000000000
--- a/x11-plugins/wmcdplay/files/wmcdplay-xpmdir.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- wmcdplay.cc
-+++ wmcdplay.cc
-@@ -20,6 +20,6 @@
- #define CLASS "WMCDPlay"
-
- // User defines - custom
--#define SYSARTDIR "/usr/X11R6/lib/X11/wmcdplay/"
-+#define SYSARTDIR "/usr/share/WMcdplay/"
- #define CDDEV "/dev/cdrom"
- #define BACKCOLOR "#282828"
diff --git a/x11-plugins/wmcdplay/wmcdplay-1.0_beta1.ebuild b/x11-plugins/wmcdplay/wmcdplay-1.0_beta1.ebuild
deleted file mode 100644
index 10e95d419418..000000000000
--- a/x11-plugins/wmcdplay/wmcdplay-1.0_beta1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=0
-
-inherit eutils
-
-IUSE=""
-
-MY_P=${P/_beta/-beta}
-S=${WORKDIR}/${PN}
-
-DESCRIPTION="CD player applet for WindowMaker"
-SRC_URI="https://www.dockapps.net/download/${MY_P}.tgz"
-HOMEPAGE="https://www.dockapps.net/wmcdplay"
-
-RDEPEND="x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXpm"
-DEPEND="${RDEPEND}
- x11-base/xorg-proto
- x11-misc/imake"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~ppc x86"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-xpmdir.patch
- epatch "${FILESDIR}"/${PN}-ComplexProgramTargetNoMan.patch
- epatch "${FILESDIR}"/${PN}-c++.patch
-}
-
-src_compile() {
- xmkmf || die "xmkmf failed."
- emake CDEBUGFLAGS="${CFLAGS}" LDOPTIONS="${LDFLAGS}" || die "emake failed."
-}
-
-src_install() {
- einstall DESTDIR="${D}" BINDIR="/usr/bin" || die "emake install failed."
-
- insinto /usr/share/WMcdplay
- doins XPM/*.art
-
- dodoc ARTWORK README
-
- domenu "${FILESDIR}"/${PN}.desktop
-}