summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pychroot/pychroot-9999.ebuild13
1 files changed, 5 insertions, 8 deletions
diff --git a/dev-python/pychroot/pychroot-9999.ebuild b/dev-python/pychroot/pychroot-9999.ebuild
index 6cb401faea51..57a2af631a20 100644
--- a/dev-python/pychroot/pychroot-9999.ebuild
+++ b/dev-python/pychroot/pychroot-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+EAPI=6
+PYTHON_COMPAT=( python{3_4,3_5,3_6} )
inherit distutils-r1
if [[ ${PV} == *9999 ]] ; then
@@ -23,15 +23,12 @@ IUSE="test"
if [[ ${PV} == *9999 ]]; then
RDEPEND="=dev-python/snakeoil-9999[${PYTHON_USEDEP}]"
else
- RDEPEND=">=dev-python/snakeoil-0.7.4[${PYTHON_USEDEP}]"
+ RDEPEND=">=dev-python/snakeoil-0.8.0[${PYTHON_USEDEP}]"
fi
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)
- dev-python/pytest[${PYTHON_USEDEP}]
- )"
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
[[ ${PV} == *9999 ]] && DEPEND+=" dev-python/sphinx[${PYTHON_USEDEP}]"
python_compile_all() {