summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-misc/urlwatch/Manifest2
-rw-r--r--www-misc/urlwatch/files/urlwatch-2.2-fix-install.patch42
-rw-r--r--www-misc/urlwatch/urlwatch-1.18.ebuild28
-rw-r--r--www-misc/urlwatch/urlwatch-2.2.ebuild46
4 files changed, 0 insertions, 118 deletions
diff --git a/www-misc/urlwatch/Manifest b/www-misc/urlwatch/Manifest
index f82a79b979bf..4b2b452d8fa5 100644
--- a/www-misc/urlwatch/Manifest
+++ b/www-misc/urlwatch/Manifest
@@ -1,3 +1 @@
-DIST urlwatch-1.18.tar.gz 14987 SHA256 6b17411b6658f3aeb5839d1b32458f020ce40ee1e62a3d40387a2622fa731824 SHA512 ffbfb41e5b6ca71abf19132424dc1bfb3d0cfc30a644615c34539bb5b00acea5803d4c30637c58e9682820c5411227f7c579344c1e212f575431a1c650a7e520 WHIRLPOOL 49915ef83cc835b8ac67216eaeb61391195f28fa28b5716c7e1cc8c8dac465d9f3670beb408c80dc3fa5315683467524b02b1663fb671f26338059acfa247b23
-DIST urlwatch-2.2.tar.gz 24435 SHA256 a3257ab795adb91514c7163610c7a916ccce9df9ab2cfdef2b72c250ab292069 SHA512 680547d01da6830059048247be4467c68ce9977786f3ba1ec0ad470eb77608b6938c244ed9341ddfd382d65cae167338c685bff2eac91a5f15e881c2aca7bb9b WHIRLPOOL 46d0dce6dc904e15561986e724882592a174c0c2480daf4eac81a4616b7b73d32033b06e70fafad3b399e557365b084e6f7518fa070420ecd22e4340b7b45f96
DIST urlwatch-2.5.tar.gz 25322 SHA256 6010a45dbc20d5449f214655c94977a65e1e2b8ba32f58e9045ddfdaaabf3962 SHA512 993d2596288d014a3b84ae22c29ce89282c4320dd95b339c9892db07997059fc80a96198cb89ba04d935f68d2d051da96dc981f8e8b3657492443b060d2126a1 WHIRLPOOL d8be345d19027e475825d708f9ce2c55fe4abb23e903d629aec872104a0e890f225dfe3f1c8de87541e9cbed7c62592d362e464f3014f0a7ce27000fd9a5f880
diff --git a/www-misc/urlwatch/files/urlwatch-2.2-fix-install.patch b/www-misc/urlwatch/files/urlwatch-2.2-fix-install.patch
deleted file mode 100644
index 66626dbf0259..000000000000
--- a/www-misc/urlwatch/files/urlwatch-2.2-fix-install.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From ebe7b90100a3d960f53fdc9409d2d89eaa61bf11 Mon Sep 17 00:00:00 2001
-From: Thomas Perl <m@thp.io>
-Date: Tue, 28 Jun 2016 18:15:51 +0200
-Subject: [PATCH] Check current directory and use os.path.relpath (Fixes #73)
-
----
- setup.py | 11 ++++++++---
- 1 file changed, 8 insertions(+), 3 deletions(-)
-
-diff --git a/setup.py b/setup.py
-index 947a7c8..45405cd 100644
---- a/setup.py
-+++ b/setup.py
-@@ -7,10 +7,15 @@
-
- import os
- import re
-+import sys
-
- PACKAGE_NAME = 'urlwatch'
- DEPENDENCIES = ['minidb', 'PyYAML', 'requests']
--HERE = os.path.dirname(__file__)
-+HERE = os.path.abspath(os.path.dirname(__file__))
-+
-+if os.path.normpath(os.getcwd()) != os.path.normpath(HERE):
-+ print('You must run {} inside {} (cwd={})'.format(os.path.basename(__file__), HERE, os.getcwd()))
-+ sys.exit(1)
-
- # Assumptions:
- # 1. Package name equals main script file name (and only one script)
-@@ -29,9 +34,9 @@
-
- m['scripts'] = [os.path.join(HERE, PACKAGE_NAME)]
- m['package_dir'] = {'': os.path.join(HERE, 'lib')}
--m['packages'] = ['.'.join(dirname[len(HERE)+1:].split(os.sep)[1:])
-+m['packages'] = ['.'.join(os.path.relpath(dirname, HERE).split(os.sep)[1:])
- for dirname, _, files in os.walk(os.path.join(HERE, 'lib')) if '__init__.py' in files]
--m['data_files'] = [(dirname[len(HERE)+1:], [os.path.join(dirname[len(HERE)+1:], fn) for fn in files])
-+m['data_files'] = [(os.path.relpath(dirname, HERE), [os.path.join(os.path.relpath(dirname, HERE), fn) for fn in files])
- for dirname, _, files in os.walk(os.path.join(HERE, 'share')) if files]
- m['install_requires'] = DEPENDENCIES
-
diff --git a/www-misc/urlwatch/urlwatch-1.18.ebuild b/www-misc/urlwatch/urlwatch-1.18.ebuild
deleted file mode 100644
index 938f929161b0..000000000000
--- a/www-misc/urlwatch/urlwatch-1.18.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-
-inherit distutils-r1
-
-DESCRIPTION="A tool for monitoring webpages for updates"
-HOMEPAGE="http://thp.io/2008/urlwatch/ https://pypi.python.org/pypi/urlwatch"
-SRC_URI="http://thp.io/2008/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-DEPEND="virtual/python-futures[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}
- || ( www-client/lynx app-text/html2text )"
-
-python_prepare() {
- if [[ ${EPYTHON} == python3.* ]]; then
- 2to3 -nw --no-diffs urlwatch lib/urlwatch/*.py \
- share/urlwatch/examples/hooks.py.example setup.py || die
- fi
-}
diff --git a/www-misc/urlwatch/urlwatch-2.2.ebuild b/www-misc/urlwatch/urlwatch-2.2.ebuild
deleted file mode 100644
index a9d7a735c7d8..000000000000
--- a/www-misc/urlwatch/urlwatch-2.2.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="6"
-PYTHON_COMPAT=( python{3_4,3_5} )
-
-inherit distutils-r1
-
-DESCRIPTION="A tool for monitoring webpages for updates"
-HOMEPAGE="https://thp.io/2008/urlwatch/ https://pypi.python.org/pypi/urlwatch"
-SRC_URI="https://thp.io/2008/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RDEPEND="
- dev-python/keyring[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/minidb[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- || ( www-client/lynx app-text/html2text )
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=( "${FILESDIR}/${P}-fix-install.patch" )
-
-python_test() {
- nosetests test || die "tests failed with ${EPYTHON}"
-}
-
-pkg_postinst() {
- if [[ -z "${REPLACING_VERSIONS}" ]] && \
- ! has_version dev-python/chump; then
- elog "Install 'dev-python/chump' to enable Pushover" \
- "notifications support"
- fi
-}