summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ml/ocaml-expect/Manifest1
-rw-r--r--dev-ml/ocaml-expect/ocaml-expect-0.0.5.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-ml/ocaml-expect/Manifest b/dev-ml/ocaml-expect/Manifest
index 1c7fa8d5922d..52d479984794 100644
--- a/dev-ml/ocaml-expect/Manifest
+++ b/dev-ml/ocaml-expect/Manifest
@@ -1 +1,2 @@
DIST ocaml-expect-0.0.4.tar.gz 60664 SHA256 cc7c2d74d56f5cddf191a835fcd0827a5c0913598f8547f1bd3961089fde6447 SHA512 fb45e48fe532fe73234084c6c887ab14377bfd41851659cec80a995167d075fdc9873c24b8e31be4bac10e567d9235da71fd30d1ecd5ccbd06c712cb8c1563d6 WHIRLPOOL 3f33f7aaa4098c92c78436c13d22474e89791ec7d8c8d12ec48e0ab0fc447f28338e06354ca0d935326c2ed6d87486f1dcaa2188b3b04c24e51d4d5f41380be8
+DIST ocaml-expect-0.0.5.tar.gz 63245 SHA256 7ea1b75bc8160213bf0c958a0a380bcb2d2e49f066eef3c560ce6dd10547b81f SHA512 fbb2ae41c12e57db4440e67d80740380d4cd7bab0f8fdf59d3b69ff91eb6e35a82ca718cf32ad2c791ae76be8a08174a5b3a95e8910351413cc98afd3105a63c WHIRLPOOL 850bc558d64ed228a1d823a38db4c7eae8d1c387de368c6d1408c21f703a6f45db42c431ecf3296d2c1c57306ef45835204c5d53af97802cffd6a1ff6b01df50
diff --git a/dev-ml/ocaml-expect/ocaml-expect-0.0.5.ebuild b/dev-ml/ocaml-expect/ocaml-expect-0.0.5.ebuild
new file mode 100644
index 000000000000..0de90b2cc0ed
--- /dev/null
+++ b/dev-ml/ocaml-expect/ocaml-expect-0.0.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="Ocaml implementation of expect to help building unitary testing"
+HOMEPAGE="http://forge.ocamlcore.org/projects/ocaml-expect/"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/1372/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ dev-ml/batteries:=
+ dev-ml/pcre-ocaml:="
+DEPEND="${RDEPEND}
+ test? ( >=dev-ml/ounit-2.0.0 )"
+
+DOCS=( "README.txt" "CHANGES.txt" "AUTHORS.txt" )