summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-apps/klaus/Manifest1
-rw-r--r--www-apps/klaus/klaus-2.0.2.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/www-apps/klaus/Manifest b/www-apps/klaus/Manifest
index 375f12323851..cdbfdada9389 100644
--- a/www-apps/klaus/Manifest
+++ b/www-apps/klaus/Manifest
@@ -1 +1,2 @@
DIST klaus-1.5.2.tar.gz 38168 BLAKE2B 4bcaf91ce641ca1f937d8b1b46367caf0ac7e9130fe222c820ded7cca8a708d1374142b09ae511da2695a64b3f2b67be69645d05602779c05081081b29494d9d SHA512 6423bfbef83f09b9abe4a1150d096ae72fc058a81c60fac585796918fa7c12b9a81c4d5808cf2e18acda5f6b891eaf93ed72a2e229b5b8d6ab5f060ea3230932
+DIST klaus-2.0.2.tar.gz 43030 BLAKE2B ba3a1d07d92ab02e43a31f9e720e26bafc744c2867b8bd6cf300d6e2fdcbcb560a426e8cf55bd6d8c11d23775ae5beddb8fd3ee89c3b0f21302bb463cc2571f3 SHA512 87aa4943d4e918c7ac9c269c095b8381b9e367ed68a50fb70bd75e02ec723c379d0ceaa2da9d5b81484b4c308941283dd2fb58046ba18e0950611c51b2337edd
diff --git a/www-apps/klaus/klaus-2.0.2.ebuild b/www-apps/klaus/klaus-2.0.2.ebuild
new file mode 100644
index 000000000000..3bea3595f8e4
--- /dev/null
+++ b/www-apps/klaus/klaus-2.0.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple, easy-to-set-up Git web viewer"
+HOMEPAGE="https://github.com/jonashaag/klaus/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ctags"
+
+RDEPEND="
+ >=dev-python/dulwich-0.19.3[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/httpauth[${PYTHON_USEDEP}]
+ dev-python/humanize[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ ctags? ( dev-python/python-ctags[${PYTHON_USEDEP}] )
+"
+
+# The tests can only be run from a git repository
+# so they are not included in the source distributions
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman ${PN}.1
+}