summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--virtual/pypy/pypy-7.0.0.ebuild17
1 files changed, 17 insertions, 0 deletions
diff --git a/virtual/pypy/pypy-7.0.0.ebuild b/virtual/pypy/pypy-7.0.0.ebuild
new file mode 100644
index 000000000000..76abaa124207
--- /dev/null
+++ b/virtual/pypy/pypy-7.0.0.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A virtual for PyPy Python implementation"
+# pypy -c 'import sysconfig; print sysconfig.get_config_var("SOABI")'
+# pypy 7.0.0: install directory changed to 'pypy2.7'
+SLOT="0/41-py27"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="bzip2 gdbm ncurses sqlite tk"
+
+RDEPEND="
+ || (
+ >=dev-python/pypy-${PV}:${SLOT}[bzip2?,gdbm(-)?,ncurses?,sqlite?,tk?]
+ >=dev-python/pypy-bin-${PV}:${SLOT}[gdbm(-)?,sqlite?,tk?]
+ )"