summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-libs/gssdp/Manifest1
-rw-r--r--net-libs/gssdp/gssdp-1.6.2.ebuild72
2 files changed, 0 insertions, 73 deletions
diff --git a/net-libs/gssdp/Manifest b/net-libs/gssdp/Manifest
index a0e4d7bcc2c2..5353d0d5a0ea 100644
--- a/net-libs/gssdp/Manifest
+++ b/net-libs/gssdp/Manifest
@@ -1,3 +1,2 @@
DIST gssdp-1.4.0.1.tar.xz 1229264 BLAKE2B b94e46c79ad0615f976bad4b8efe9dbcaa27105b3189ee23ff349002d175ff83b0a9507846a23f0d8b5ed1e98381658f863a77bec6beff83933ebae5458a6b0e SHA512 c2132b27f49071941be1ad9bd1e642b8b82341aac7e10b87d8a9a0ed3d88759ab6730a4a05ddb904af5e0799602c470b9e83a987c72ec3c1444b7aaef0e36ad8
-DIST gssdp-1.6.2.tar.xz 2081568 BLAKE2B d11ea1f5d5980c6380dd3a072fc6d8a33894e4cd5c5978862b1fe99ecaed679cee2ecd37a80aa374bb255c8771520501243f334092261465e641a772561a15e0 SHA512 501e2839022b3c175b17b27b8b1134021631726eca331ab7b64f895be770f5b754c50cdfaa03e833a3d95180471cda6a87b17ffeff661f3de228a5b70a2a6cbb
DIST gssdp-1.6.3.tar.xz 108080 BLAKE2B f9deddf2b221eda9c3d7a6e6fa78cfb6388d3f3549caf166ebf7ac41f6edf39b8bc2521838ae5d954c743f844d5e7ba28b50f5a7beb6b2d70241782275c50fe4 SHA512 e5c9851032538cf093ed8c34a71c5d171eafb2edc5d3f3f5f0284005d4b1cca29ffca34b7f7d38b4a68a86c9bd888dd7a5a8e758dbd926bc4b4c995ea0b1110b
diff --git a/net-libs/gssdp/gssdp-1.6.2.ebuild b/net-libs/gssdp/gssdp-1.6.2.ebuild
deleted file mode 100644
index 40f5e9915a31..000000000000
--- a/net-libs/gssdp/gssdp-1.6.2.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit gnome.org meson-multilib vala xdg
-
-DESCRIPTION="GObject-based API for handling resource discovery and announcement over SSDP"
-HOMEPAGE="https://wiki.gnome.org/Projects/GUPnP https://gitlab.gnome.org/GNOME/gssdp"
-
-LICENSE="LGPL-2+"
-SLOT="1.6/1.6-0" # <API version>-<soname>
-KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~loong ~ppc ppc64 ~riscv ~sparc x86"
-IUSE="gtk gtk-doc +introspection man +vala"
-REQUIRED_USE="
- gtk-doc? ( introspection )
- vala? ( introspection )
-"
-
-# has file collision with Slot 0 (/usr/bin/gssdp-device-sniffer), so we remove that from this build
-# and depend on the other slot that has the file as well
-RDEPEND="
- >=dev-libs/glib-2.70:2[${MULTILIB_USEDEP}]
- >=net-libs/libsoup-2.99.0:3.0[${MULTILIB_USEDEP},introspection?]
- gtk? ( gui-libs/gtk:4 )
- introspection? ( >=dev-libs/gobject-introspection-1.54:= )
- man? ( virtual/pandoc )
- >=net-libs/gssdp-1.4:0
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- gtk-doc? (
- >=dev-util/gi-docgen-2021.1
- app-text/docbook-xml-dtd:4.1.2
- )
- virtual/pkgconfig
- vala? (
- $(vala_depend)
- net-libs/libsoup:3.0[vala]
- )
-"
-
-src_prepare() {
- default
- use vala && vala_setup
-}
-
-multilib_src_configure() {
- local emesonargs=(
- # Never use gi-docgen subproject
- --wrap-mode nofallback
-
- $(meson_native_use_bool gtk-doc gtk_doc)
- $(meson_native_use_bool gtk sniffer)
- $(meson_native_use_bool introspection)
- $(meson_native_use_bool man manpages)
- $(meson_native_use_bool vala vapi)
- -Dexamples=false
- )
- meson_src_configure
-}
-
-multilib_src_install_all() {
- if use gtk-doc ; then
- mkdir "${ED}"/usr/share/gtk-doc || die
- mv "${ED}"/usr/share/{doc,gtk-doc}/gssdp-1.6 || die
- fi
-
- if use gtk; then
- rm "${ED}"/usr/bin/gssdp-device-sniffer || die # because of file collision with slot 0
- fi
-}