summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--kde-plasma/plasma-thunderbolt/Manifest1
-rw-r--r--kde-plasma/plasma-thunderbolt/plasma-thunderbolt-6.0.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/kde-plasma/plasma-thunderbolt/Manifest b/kde-plasma/plasma-thunderbolt/Manifest
index 6746c5691fea..4949893307f4 100644
--- a/kde-plasma/plasma-thunderbolt/Manifest
+++ b/kde-plasma/plasma-thunderbolt/Manifest
@@ -1,2 +1,3 @@
DIST plasma-thunderbolt-5.27.10.tar.xz 72112 BLAKE2B b527f7225fe6f85b2168406b4d049813ed3da9616b577f3d9606151d391bbb1237ed2a84e49f3b3dbdc601d52f54a8f25f91d5980ee812518cff105b602656c4 SHA512 5a93e390332ab14f212ef60c1fe8b0af16256058ab70d7504699b8109c4b28a02dfe7597665168f6dc9061397fa08c670897c0f5cc9cb64576cc979052d924d8
DIST plasma-thunderbolt-5.93.0.tar.xz 74440 BLAKE2B f85792c87e3afdad97ee8d03bc122270c02c69b23823d139a73d277a84777ad6dfc620fdf9a15ea6dfdeff516f383f69c95ca86878142a8366ab7a7c898a2c91 SHA512 f6b0dbb87ce15f2725e6df2fa5f6a21c3b004e4c101d30a816845206937595ca5b8cbd2329a8ec911467c804f4e218e49824abba1a591de864585517b14d0c52
+DIST plasma-thunderbolt-6.0.0.tar.xz 74468 BLAKE2B eb3d1a20e45f67c96a289d19e950437b8702c6ba18ea0f7b9e0e406e5de85e50807e08d9a898c930a923a08d8d424ce3758b21f0b0007785877dd634cf8086f6 SHA512 5114c2f40a2357328c1fd0e8176d844c5e4ee9c78fb4d21533b45b562302730ec9a40e267b1121fe9689f06c67a37f518d25ad554309ebdf4705f032415566e8
diff --git a/kde-plasma/plasma-thunderbolt/plasma-thunderbolt-6.0.0.ebuild b/kde-plasma/plasma-thunderbolt/plasma-thunderbolt-6.0.0.ebuild
new file mode 100644
index 000000000000..88642424e300
--- /dev/null
+++ b/kde-plasma/plasma-thunderbolt/plasma-thunderbolt-6.0.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="true"
+KFMIN=6.0
+QTMIN=6.6.2
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Plasma integration for controlling Thunderbolt devices"
+HOMEPAGE="https://invent.kde.org/plasma/plasma-thunderbolt"
+
+LICENSE="|| ( GPL-2 GPL-3+ )"
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE=""
+
+# tests require DBus
+RESTRICT="test"
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gui]
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ >=kde-frameworks/kcmutils-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/kdbusaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/knotifications-${KFMIN}:6
+ >=kde-frameworks/kservice-${KFMIN}:6
+"
+RDEPEND="${DEPEND}
+ >=kde-frameworks/kirigami-${KFMIN}:6
+ sys-apps/bolt
+"
+BDEPEND=">=kde-frameworks/kcmutils-${KFMIN}:6"