summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-proxy/dnsproxy/Manifest1
-rw-r--r--net-proxy/dnsproxy/dnsproxy-1.17.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/net-proxy/dnsproxy/Manifest b/net-proxy/dnsproxy/Manifest
index c045a9a52add..bf94c73f0b92 100644
--- a/net-proxy/dnsproxy/Manifest
+++ b/net-proxy/dnsproxy/Manifest
@@ -1 +1,2 @@
DIST dnsproxy-1.16.tar.gz 47239 BLAKE2B 38134f93c95ec9f24d3e142251cd0dfd2b51fcaf02381ed00890e951f7a61af45e978264c4c17e3518585c408f6c88e47b6a0291939aedfc9f27b13a057650ff SHA512 f02498de963555556b656be432612e6d9ed72f29c838672c45ed2b4100cd6ae30b19091cbd33587259935342c86a733b820d2df54a8c3c1c699edb050b1b3d2b
+DIST dnsproxy-1.17.tar.gz 47128 BLAKE2B 37b033b4c8f515b516ebf4780f7d28f6924fd66b9ca826d98567e8d3aab139c9a91a39bd0e8cf6d38084fce86f9ce8cb56f93d16918240d0d0815787dc06a72f SHA512 499910f59306477870f2c1cc7899fed409c5a569be348d11d17277bf4208ecd44173606022566b91b09546f915f1d990d56936f92245501af9fecf2110e88c32
diff --git a/net-proxy/dnsproxy/dnsproxy-1.17.ebuild b/net-proxy/dnsproxy/dnsproxy-1.17.ebuild
new file mode 100644
index 000000000000..77a4f6123f42
--- /dev/null
+++ b/net-proxy/dnsproxy/dnsproxy-1.17.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit flag-o-matic
+
+DESCRIPTION="The dnsproxy daemon is a proxy for DNS queries"
+HOMEPAGE="https://www.wolfermann.org/dnsproxy.html"
+SRC_URI="https://www.wolfermann.org/${P}.tar.gz"
+
+LICENSE="MIT GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-libs/libevent
+"
+RDEPEND="
+ ${DEPEND}
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.16-include.patch
+)
+
+src_compile() {
+ append-cppflags -D_GNU_SOURCE
+ emake ${PN}
+}
+
+src_install() {
+ dosbin ${PN}
+ keepdir /var/empty
+
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ insinto /etc/${PN}
+ newins ${PN}.conf ${PN}.conf.dist
+
+ dodoc README
+ doman ${PN}.1
+}