summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-process/glances/Manifest1
-rw-r--r--sys-process/glances/glances-2.8.1.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/sys-process/glances/Manifest b/sys-process/glances/Manifest
index 6e37a88fbb72..21c3adf8ee87 100644
--- a/sys-process/glances/Manifest
+++ b/sys-process/glances/Manifest
@@ -1 +1,2 @@
DIST Glances-2.7.1.tar.gz 13277845 SHA256 afdfdb4b14ae514422c4a882788800473c6cff53719266735c9a2af400c14b86 SHA512 c13e7fb8e6025d284cfabade4eaf10189f6605f53f219889c3c636780ac11773c579f39d956a9eebcf5618de2bffec42446982fb892d775109341af74e621b83 WHIRLPOOL 119792772e45e4a23ca7ddb0e84081eb79a6e72d68311fcba42f4305ae068b105a882b8dda3d14b3f9da6fb7fa55208a125d16c4170767c623c1d1286927fa11
+DIST Glances-2.8.1.tar.gz 5530699 SHA256 12c10f9a9cac9c7ba70b0b5aa6551a97599731f2c8751c2cc53232da395c6b8b SHA512 27759f621d5e29e1f4da0465abf9112b3e4146a8644110481000a7bf0fc8f2d3171a8082e7db7acd9a4a12558a8b3de8db1ae1bf0b1e5503b618aa5648b07c10 WHIRLPOOL 93ea9affc069a7c00fc7795d9afa625bfe9ba6dddf784c45403a305b7c4e186f964eebf15638709487aa66040f8270daf5bae06bf0ece434da1a7011a4085a5a
diff --git a/sys-process/glances/glances-2.8.1.ebuild b/sys-process/glances/glances-2.8.1.ebuild
new file mode 100644
index 000000000000..84f43f88532d
--- /dev/null
+++ b/sys-process/glances/glances-2.8.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5}} )
+PYTHON_REQ_USE="ncurses"
+
+inherit distutils-r1 eutils linux-info
+
+DESCRIPTION="CLI curses based monitoring tool"
+HOMEPAGE="https://github.com/nicolargo/glances"
+SRC_URI="mirror://pypi/G/${PN^}/${P^}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+# There is another optional extra batinfo, absent from portage
+RDEPEND="${DEPEND}
+ >=dev-python/psutil-2.0.0[${PYTHON_USEDEP}]"
+
+CONFIG_CHECK="~TASK_IO_ACCOUNTING ~TASK_DELAY_ACCT ~TASKSTATS"
+
+S="${WORKDIR}/${P^}"
+
+pkg_setup() {
+ linux-info_pkg_setup
+}
+
+python_prepare_all() {
+ # Remove duplicate entries of a prebuilt doc build and
+ # ensure install of the file glances.conf in /etc/${PN}
+ sed \
+ -e '/share\/doc\/glances/d' \
+ -e "s:'conf/glances.conf':('etc/glances', ['conf/glances.conf':g" \
+ -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ # add an intended file from original data set from setup.py to DOCS
+ local DOCS=( README.rst conf/glances.conf )
+ # setup for pre-built html docs in setup.py
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ optfeature "Action script feature" dev-python/pystache
+ optfeature "Autodiscover mode" dev-python/zeroconf
+ optfeature "Battery monitoring support" dev-python/batinfo
+ optfeature "Docker monitoring support" dev-python/docker-py
+ optfeature "Graphical/chart support" dev-python/matplotlib
+ # https://bitbucket.org/gleb_zhulik/py3sensors
+ # optfeature "Hardware monitoring support" dev-python/py3sensors
+ optfeature "IP plugin" dev-python/netifaces
+ optfeature "InfluxDB export module" dev-python/influxdb
+ optfeature "Hard drive temperature monitoring" app-admin/hddtemp
+ optfeature "Quicklook CPU info" dev-python/py-cpuinfo
+ optfeature "RAID support" dev-python/pymdstat
+ optfeature "RabbitMQ/ActiveMQ export module" dev-python/pika
+ # https://github.com/banjiewen/bernhard
+ # optfeature "Riemann export" dev-python/bernhard
+ optfeature "SNMP support" dev-python/pysnmp
+ optfeature "StatsD export module" dev-python/statsd
+ optfeature "Web server mode" dev-python/bottle
+}