summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pyasn1-modules/Manifest1
-rw-r--r--dev-python/pyasn1-modules/pyasn1-modules-0.1.4.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pyasn1-modules/Manifest b/dev-python/pyasn1-modules/Manifest
index 415887846617..0473a8badf6f 100644
--- a/dev-python/pyasn1-modules/Manifest
+++ b/dev-python/pyasn1-modules/Manifest
@@ -1,3 +1,4 @@
DIST pyasn1-modules-0.0.10.tar.gz 63543 SHA256 3d86ab0fa226a60897c8123c505b3d0712e042990f061237799639f6fa742bf3 SHA512 c20322a515e9916e0f8fa2e10972d0543a5ffb7f5d68a1b2fad3b4d7808bcb0bc98fc9e1f81349feabd1a55093aab73b8be4977c0ec34a45e0c3148037fd294a WHIRLPOOL 534d11e3dddc429b69b445df6ee440e967607831629e77f393a787bc9ed8b8b053ec38aa7dbca499fe6686561bdcfd14aafa0bbae198124dc01148faf09d7201
DIST pyasn1-modules-0.0.5.tar.gz 38710 SHA256 be65f00ed28e30756f1ef39377cb382480a2368699179d646a84d79fe9349941 SHA512 b8fa41ed28087097502e8362022d819fe6914511c09f60f64f173c5674684fa8c45de23ce718700001d9f2d9b11adc17657d7cfd4cb24ea740b8d14eba8d8161 WHIRLPOOL c0df005909ffa4320f0ff7c580410ff2468cdd4002dfa5383e561c9c65721c0a72169e10c72fdc225b308d8fd1d5691dc519b6ee811c167ddc466ba1657e92c8
DIST pyasn1-modules-0.0.8.tar.gz 38776 SHA256 10561934f1829bcc455c7ecdcdacdb4be5ffd3696f26f468eb6eb41e107f3837 SHA512 6040d4f83c6b00f7a0e6ba0e1264090d0fa96fc39e97b04d624721cef200b6cf4dabfe550127ade4edc181187ca1b4219fb46a95082a39e6291d0e2e08f36d78 WHIRLPOOL 45f3c2ad6e3320f5d7d1f3bef6f0168f2d85b3093f33438aaacc8251d6457d88c2db659d0912a76417196f5ed431c427fc9a47a8a6af5c490d97f931515d2884
+DIST pyasn1-modules-0.1.4.tar.gz 65552 SHA256 b07c17bdb34d6f64aafea6269f2e8fb306a57473f0f38d9a6ca389d6ab30ac4a SHA512 29467aa9fff15b7a7ef999389db01fe696350e29910397f0c867685689a9fa8e5df8128a7703ae0de095804ae20c3759b24656467cec8d086d07a1014ccf5d65 WHIRLPOOL 99ff13b3d4b5749360f9ae9845ccce228e6c1835b3cf692216c4dee49b0ab834ae11aef256e869b18a3517114707ae5eb1b13aaf068c1610bf5c5ad8102a0467
diff --git a/dev-python/pyasn1-modules/pyasn1-modules-0.1.4.ebuild b/dev-python/pyasn1-modules/pyasn1-modules-0.1.4.ebuild
new file mode 100644
index 000000000000..e417c99978f8
--- /dev/null
+++ b/dev-python/pyasn1-modules/pyasn1-modules-0.1.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="pyasn1 modules"
+HOMEPAGE="http://pyasn1.sourceforge.net/ https://pypi.python.org/pypi/pyasn1-modules"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=dev-python/pyasn1-0.1.8[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ echoit() { echo "$@"; "$@"; }
+ local exit_status=0 test
+ cd tools || die
+ for test in ../test/*.sh; do
+ echoit sh "${test}" || exit_status=1
+ done
+ return ${exit_status}
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ insinto /usr/share/${P}
+ doins -r tools
+}